and again
[bootstrapfs.git] / slicerepo.spec
index 2b57922..8f81bf6 100644 (file)
@@ -7,8 +7,8 @@
 %define obsolete_nodefamily %{pldistro}-%{_arch}
 
 %define name slicerepo-%{nodefamily}
-%define version 2.1
-%define taglevel 4
+%define version 5.2
+%define taglevel 9
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -67,7 +67,15 @@ install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/ins
 rm -rf $RPM_BUILD_ROOT
 
 %post
-service plc start packages
+if [ ! -e /bin/systemctl ] ; then
+   echo "Systemd is not there. Just starting PLC to handle packages (may fail of PLC is not configured) ..."
+   service plc start packages
+elif /bin/systemctl status plc >/dev/null ; then
+   echo "Restarting PLC to handle packages ..."
+   service plc restart packages
+else
+   echo "The PLC is not running. Skipping a restart ..."
+fi
 
 %files
 %defattr(-,root,root,-)
@@ -76,6 +84,41 @@ service plc start packages
 %config(noreplace) /var/www/html/install-rpms/slice-%{nodefamily}/yumgroups.xml
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - nodeimage-5.2-9
+- ok for f27 and f29
+- cleanup old distros
+
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-8
+- fix the fedora and fedora-updates repo definitions for f25
+- add /etc/plc.d/packages index
+
+* Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-7
+- yum config ; deprecates old fedora releases, add support for f23/f24
+
+* Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
+- fix for f22 and dnf.conf
+
+* Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
+- the yum config for nodes on f21 and f22
+- define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
+- is taken into account on f22
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
+- minor change; start plc packages only at run-time, not build-time
+- only available on systems that have systemctl
+
+* Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
+- Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
+- template for f20 yum config
+
+* Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
+- more timestamps during build
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
+- add support for f18 yum config
+
 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
 
 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3