Setting tag codemux-0.1-15
[codemux.git] / codemux.spec
1 %define name codemux 
2 %define version 0.1
3 %define taglevel 15
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: CoDemux - HTTP port DeMux
8 Name: %{name} 
9 Version: %{version}
10 Release: %{release}
11 License: Private
12 Group: System Environment/Base
13 Source: %{name}-%{version}.tar.gz
14 Vendor: PlanetLab
15 Packager: PlanetLab Central <support@planet-lab.org>
16 Distribution: PlanetLab %{plrelease}
17 URL: %{SCMURL}
18 #URL: http://codeen.cs.princeton.edu/
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20 #Requires: vnet
21
22 %description
23 codemux is a privileged port (80) sharing service that passes traffic to and from slices via localhost ports.
24
25
26 %prep
27 %setup -q
28
29 make clean
30
31 %build
32 make RPM_VERSION=%{version}.%{taglevel}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 make INSTALL_ROOT=$RPM_BUILD_ROOT install
37 install -D -m 644 codemux.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/codemux
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(0644,root,root)
44 %attr(0755,root,root) %{_initrddir}/codemux
45 %config(noreplace) /etc/codemux/codemux.conf
46 %attr(0755,root,root) /usr/sbin/codemux
47 %{_sysconfdir}/logrotate.d/codemux
48
49 %post
50 chkconfig --add codemux
51
52 if [ -z "$PL_BOOTCD" ]; then
53     /etc/init.d/codemux condrestart
54 fi
55
56 %preun
57 if [ "$1" = 0 ]; then
58     # erase, not upgrade
59     chkconfig --del codemux
60
61     # stop daemon if its currently running
62     if [ "`/etc/init.d/codemux status`" = "running" ]; then
63         /etc/init.d/codemux stop
64     fi
65 fi
66
67 %changelog
68 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - codemux-0.1-15
69 - no semantic change - just fixed specfile for git URL
70
71 * Tue Mar 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - CoDemux-0.1-14
72 - introduce an IP field
73
74 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - CoDemux-0.1-13
75 - Add condrestart to the initscript and add a way to limit codemux to one IP.
76
77 * Fri Jun 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - CoDemux-0.1-12
78
79 - KyoungSoo added fix to prevent failure with new compilers
80
81
82 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - CoDemux-0.1-11
83
84
85 * Thu Apr 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - CoDemux-0.1-10
86
87 - Examples in conf file are enough.  Removed PLC specific entries.
88
89
90 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - CoDemux-0.1-7 CoDemux-0.1-8
91
92
93 * Sun Apr 22 2007 KYOUNGSOO PARK <kyoungso@park.cs.princeton.edu> - 
94 - Initial build.
95