fix mac address are truncated problem when compiling ulogd with -D_FORTIFY_SOURCE...
[distributedratelimiting.git] / DistributedRateLimiting.spec
index a08afda..64b27eb 100644 (file)
@@ -17,6 +17,8 @@ License:      Academic
 URL: %(echo %{url} | cut -d ' ' -f 2)
 Source0:       %{name}-%{version}.tar.bz2
 Buildroot:     %{_tmppath}/%{name}-buildroot
+BuildRequires:  libxml2-devel
+Requires:       libxml2
 Provides:      DistributedRateLimiting
 
 %description
@@ -27,7 +29,7 @@ was a centralized limiter.
 %setup
 aclocal
 autoconf
-%configure --without-mysql --without-pgsql --without-pcap
+%configure --without-zookeeper
 
 %build
 make
@@ -43,6 +45,7 @@ make DESTDIR=%{buildroot} install
 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/init.d
 install ulogd.init %{buildroot}/%{_sysconfdir}/rc.d/init.d/ulogd
 install ulogd.8 %{buildroot}/%{_mandir}/man8/ulogd.8
+install drl.xml %{buildroot}/%{_sysconfdir}
 install -D -m 644 ulogd.logrotate %{buildroot}/%{_sysconfdir}/logrotate.d/ulogd
                
 %clean
@@ -51,8 +54,8 @@ rm -rf %{buildroot}
 %files
 %defattr(0644,root,root,0755)
 %attr(0755,root,root) %{_sbindir}/ulogd
-%attr(0755,root,root) %{_bindir}/netflow-import
-%{_sysconfdir}/ulogd.conf
+%config %{_sysconfdir}/ulogd.conf
+%config %{_sysconfdir}/drl.xml
 %{_sysconfdir}/logrotate.d/ulogd
 %attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/ulogd
 %{_mandir}/man8/*
@@ -60,12 +63,13 @@ rm -rf %{buildroot}
 %{_libdir}/ulogd/ulogd_BASE.so
 %{_libdir}/ulogd/ulogd_LOCAL.so
 %{_libdir}/ulogd/ulogd_LOGEMU.so
-%{_libdir}/ulogd/ulogd_NETFLOW.so
 %{_libdir}/ulogd/ulogd_OPRINT.so
 %{_libdir}/ulogd/ulogd_PWSNIFF.so
+%{_libdir}/ulogd/ulogd_SYSLOG.so
 %{_libdir}/ulogd/ulogd_DRL.so
 %doc COPYING AUTHORS README
 %doc doc/ulogd.txt doc/ulogd.a4.ps doc/ulogd.html
+%doc drl/DRL-LICENSE
 
 %changelog
 * Tue Oct 14 2008 Kevin Webb <kcwebb@cs.ucsd.edu> - DistributedRateLimiting-0.1