Setting tag drupal-4.7-17
[drupal.git] / drupal.spec
1 #
2 # $Id$
3 #
4
5 %define name drupal
6 %define version 4.7
7 %define taglevel 17
8 %define minorversion 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Packager: PlanetLab Central <support@planet-lab.org>
13
14 # remain compliant with former planetlab practices
15 %define drupaldir /var/www/html
16 Name: %{name}
17 Version:  %{version}
18 Release:  %{release}
19 Summary: An open-source content-management platform
20
21 Group: Applications/Publishing
22 License: GPLv2+        
23 URL: http://www.drupal.org
24 Source0: http://ftp.osuosl.org/pub/drupal/files/projects/%{name}-%{version}.%{minorversion}.tar.gz
25 #Source1: drupal.conf
26 Source2: drupal-cron
27 Source3: http://ftp.drupal.org/files/projects/taxonomy_block-4.7.x-1.x-dev.tar.gz
28
29 BuildArch: noarch
30 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
31 Requires: php, php-gd, php-mbstring, wget
32
33 %description
34 Equipped with a powerful blend of features, Drupal is a Content Management 
35 System written in PHP that can support a variety of websites ranging from
36 personal weblogs to large community-driven websites.  Drupal is highly
37 configurable, skinnable, and secure.
38
39 %prep
40 %setup -q -n %{name}-%{version}.%{minorversion} -a 3
41
42 %build
43 mv taxonomy_block modules
44
45 %install
46 rm -rf %{buildroot}
47 install -d %{buildroot}%{drupaldir}
48 cp -pr * %{buildroot}%{drupaldir}
49 cp -pr .htaccess %{buildroot}%{drupaldir}
50 mkdir -p %{buildroot}%{_docdir}
51 install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/cron.hourly/drupal 
52 mkdir %{buildroot}%{drupaldir}/files
53
54 %clean
55 rm -rf %{buildroot}
56
57 %files
58 %defattr(-,root,root,-)
59 %doc CHANGELOG.txt INSTALL* LICENSE* MAINTAINERS.txt UPGRADE.txt 
60 %{drupaldir}
61 %config(noreplace) %{drupaldir}/.htaccess
62 %exclude %{drupaldir}/CHANGELOG.txt
63 %exclude %{drupaldir}/INSTALL* 
64 %exclude %{drupaldir}/LICENSE* 
65 %exclude %{drupaldir}/MAINTAINERS.txt 
66 %exclude %{drupaldir}/UPGRADE.txt
67 %config(noreplace) %{drupaldir}/sites/default
68 %attr(755,root,apache) %{_sysconfdir}/cron.hourly/drupal
69 %dir %attr(775,root,apache) %{drupaldir}/files
70
71 %changelog
72 * Mon Jan 07 2019 Thierry <Parmentelat> - drupal-4.7-17
73 - apply patch for php7.2 on fedora29
74
75 * Tue Jan 19 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - drupal-4.7-16
76 - download at onelab first, as the upstream version mysteriously has a new hash
77
78 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - drupal-4.7-15
79 - dual mirror build
80
81 * Sun Jul 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - drupal-4.7-14
82 - Use local URL
83
84 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - drupal-4.7-13
85 - fix build; drupal version not linked to this tagleve;l
86
87 * Wed Jun 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - drupal-4.7-12
88 - add taxonomy_block to default install
89
90 * Fri Jan 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
91 - plain drupal 4.7.11