Work around a kernel issue with futexes
[fprobe-ulog.git] / fprobe-ulog.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 # please keep these three lines as they are used by the tagging script
7 # see build/module-tag.py for details
8 %define name fprobe-ulog
9 %define version 1.1.4
10 %define taglevel 1
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name:           %{name}
15 Version:        %{version}
16 Release:        %{release}
17 Summary:        fprobe-ulog: a NetFlow probe
18 Group:          Network/Monitoring
19 License:        GPL
20 #URL:           http://fprobe.sourceforge.net
21 URL: %(echo %{url} | cut -d ' ' -f 2)
22 Source0:        %{name}-%{version}.tar.bz2
23 Buildroot:      %{_tmppath}/%{name}-buildroot
24 Provides:       fprobe-ulog
25
26 %description
27 fprobe-ulog - libipulog-based tool that collect network traffic data and emit
28 it as NetFlow flows towards the specified collector. PlanetLab version.
29
30 %prep
31 %setup -q
32
33 %build
34 ./configure --sbindir=/sbin --mandir=%{_mandir} --enable-uptime_trick=no $EXTRA_OPTIONS
35 make
36
37 %install
38 rm -rf %{buildroot}
39 make install DESTDIR=%{buildroot}
40 install -d -v %{buildroot}/etc/init.d
41 mkdir -p %{buildroot}/var/local/fprobe
42 install -m 755 -v fprobe-initscript %{buildroot}/etc/init.d/fprobe-ulog
43 gzip --best %{buildroot}%{_mandir}/man8/fprobe-ulog.8
44
45 %clean
46 rm -rf %{buildroot}
47
48 %files
49 %defattr(-,root,root)
50 %doc AUTHORS ChangeLog NEWS README COPYING TODO
51 /etc/init.d/fprobe-ulog
52 /sbin/fprobe-ulog
53 /var/local/fprobe
54 %{_mandir}/man8/fprobe-ulog.8.gz
55
56 %post
57 chkconfig --add fprobe-ulog
58 if [ "$PL_BOOTCD" != "1" ] ; then
59     service fprobe-ulog condrestart
60 fi
61
62 %preun
63 # 0 = erase, 1 = upgrade
64 if [ "$1" -eq 0 ]; then
65     if [ "$PL_BOOTCD" != "1" ] ; then
66         service fprobe-ulog stop
67     fi
68     chkconfig --del fprobe-ulog
69 fi
70
71
72 %changelog
73 * Fri Jul 08 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.3-3
74 - This changeset makes fprobe compress the data it collects.
75
76 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.3-2
77 - This version uses the new location of the slice id field in /etc/vservers/vserver_name/<slice_id>. Needs Node Manager
78 - 2.0-6 and higher to function.
79
80 * Fri Nov 06 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - fprobe-ulog-1.1.3-1
81 - Proper initscript semantics.
82
83 * Sun Sep 14 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.2-6
84 - Codemux support: react to changes in the xid of a connection to update the corresponding flow record.
85
86 * Wed Sep 10 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.2-5
87 - Bug fix, although not major.
88
89 * Tue Jul 01 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - fprobe-ulog-1.1.2-4
90 - This change is required for PlanetFlow data collection on PLE. It makes fprobe data accessible to non-root users such
91 - as pl[e]_netflow.
92
93 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - fprobe-ulog-1.1.2-3
94
95
96
97 %define module_current_branch 1.1.2