another approach, patch bootstrap on the fly
[gnuradio.git] / gnuradio.spec
index c68fc0c..f8cfc51 100644 (file)
@@ -20,7 +20,6 @@ License: GPLv3
 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
 Group: Productivity/Hamradio/Other
 Source: %{actual_name}.tar.gz
-Source1: bootstrap.wextoolbox
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
@@ -39,7 +38,6 @@ Requires: boost >= 1.35
 gnuradio is a free software radio toolkit
 
 %prep
-
 %setup -q -n %{actual_name}
 
 
@@ -47,12 +45,18 @@ gnuradio is a free software radio toolkit
 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
 # dirty hack to let gnuradio configure find sdcc
 export PATH=$PATH:/usr/libexec/sdcc
-# basically reruns autoconf and automake
+
+########## the bootstrap script basically reruns autoconf and automake
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
-bash -x ./bootstrap.wextoolbox
-%else
-bash -x ./bootstrap
+### the code in bootstrapfs reads
+### aclocal -I config
+# we suppress the -I config so that e.g. the libtool macros used are the ones from the system, 
+# not the one that ships in config/
+sed -i -e "s,aclocal -I config,aclocal," ./bootstrap
 %endif
+
+bash -x ./bootstrap
+
 %configure --disable-doxygen
 make