upgraded from the f12 source rpm
[gnuradio.git] / gnuradio.spec
index f8cfc51..5f0277a 100644 (file)
@@ -19,7 +19,9 @@ Release: %{release}
 License: GPLv3
 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
 Group: Productivity/Hamradio/Other
-Source: %{actual_name}.tar.gz
+Source0: %{actual_name}.tar.gz
+Source1:       10-usrp.rules
+Patch0:                gnuradio-3.2-libtool.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
@@ -39,30 +41,30 @@ gnuradio is a free software radio toolkit
 
 %prep
 %setup -q -n %{actual_name}
+%patch0 -p1 -b .libtool
 
 
 %build
 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
 # dirty hack to let gnuradio configure find sdcc
-export PATH=$PATH:/usr/libexec/sdcc
+export PATH=%{_libexecdir}/sdcc:$PATH
 
 ########## the bootstrap script basically reruns autoconf and automake
 %if "%{distro}" == "Fedora" && %{distrorelease} >= 12
-### the code in bootstrapfs reads
-### aclocal -I config
-# we suppress the -I config so that e.g. the libtool macros used are the ones from the system, 
-# not the one that ships in config/
-sed -i -e "s,aclocal -I config,aclocal," ./bootstrap
-%endif
-
+autoreconf -i
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+%else
 bash -x ./bootstrap
+%endif
 
 %configure --disable-doxygen
-make
+make %{?_smp_mflags}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-mkdir $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+install -D -m0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/10-usrp.rules
 
 #make DESTDIR=$RPM_BUILD_ROOT install
 %makeinstall