use our own bootstrap procedure - on f12 for now
[gnuradio.git] / gnuradio.spec
index cac5fb3..c68fc0c 100644 (file)
@@ -7,9 +7,11 @@
 #
 %define name gnuradio
 %define version 3.2.2
-%define release 2.1
+%define release 21
 %define actual_name %{name}-%{version}
 
+%define module_taglevel_varname release
+
 Name: %{name}
 Summary: GNU software radio
 Version: %{version}
@@ -18,6 +20,7 @@ License: GPLv3
 URL: ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.2.tar.gz
 Group: Productivity/Hamradio/Other
 Source: %{actual_name}.tar.gz
+Source1: bootstrap.wextoolbox
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
@@ -41,13 +44,15 @@ gnuradio is a free software radio toolkit
 
 
 %build
-PKG_CONFIG_PATH="/usr/lib/pkgconfig"
-export PKG_CONFIG_PATH
-# Following export PATH is a dirty hack to let gnuradio configure find sdcc
-PATH=$PATH:/usr/libexec/sdcc
-export PATH
-./bootstrap
-#./configure
+export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
+# dirty hack to let gnuradio configure find sdcc
+export PATH=$PATH:/usr/libexec/sdcc
+# basically reruns autoconf and automake
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
+bash -x ./bootstrap.wextoolbox
+%else
+bash -x ./bootstrap
+%endif
 %configure --disable-doxygen
 make
 
@@ -70,10 +75,6 @@ rm -rf $RPM_BUILD_ROOT
 
 
 
-
-
-
-
 %package -n %{name}-devel
 Summary: gnuradio devel files
 Version: %{version}
@@ -103,8 +104,8 @@ Devel package of gnuradio
 %dir /etc/gnuradio
 %config /etc/gnuradio/*
 %{_libdir}/lib*so*
-%{_libdir}/python2.5/site-packages/
-#%{_datadir}/doc/*
+%{_libdir}/python*/site-packages/
+%{_datadir}/doc/*
 %dir %{_datadir}/gnuradio
 %{_datadir}/gnuradio/*
 %dir %{_datadir}/usrp