another approach, patch bootstrap on the fly
[gnuradio.git] / gnuradio.spec
index 01f1652..f8cfc51 100644 (file)
@@ -38,16 +38,25 @@ Requires: boost >= 1.35
 gnuradio is a free software radio toolkit
 
 %prep
-
 %setup -q -n %{actual_name}
 
 
 %build
 export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
-# Following export PATH is a dirty hack to let gnuradio configure find sdcc
+# dirty hack to let gnuradio configure find sdcc
 export PATH=$PATH:/usr/libexec/sdcc
-./bootstrap
-#./configure
+
+########## the bootstrap script basically reruns autoconf and automake
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
+### the code in bootstrapfs reads
+### aclocal -I config
+# we suppress the -I config so that e.g. the libtool macros used are the ones from the system, 
+# not the one that ships in config/
+sed -i -e "s,aclocal -I config,aclocal," ./bootstrap
+%endif
+
+bash -x ./bootstrap
+
 %configure --disable-doxygen
 make