another approach, patch bootstrap on the fly
[gnuradio.git] / gnuradio.spec
index f4817b6..f8cfc51 100644 (file)
@@ -7,9 +7,11 @@
 #
 %define name gnuradio
 %define version 3.2.2
-%define release 2.1
+%define release 21
 %define actual_name %{name}-%{version}
 
+%define module_taglevel_varname release
+
 Name: %{name}
 Summary: GNU software radio
 Version: %{version}
@@ -36,18 +38,25 @@ Requires: boost >= 1.35
 gnuradio is a free software radio toolkit
 
 %prep
-
 %setup -q -n %{actual_name}
 
 
 %build
-PKG_CONFIG_PATH="/usr/lib/pkgconfig"
-export PKG_CONFIG_PATH
-# Following export PATH is a dirty hack to let gnuradio configure find sdcc
-PATH=$PATH:/usr/libexec/sdcc
-export PATH
-./bootstrap
-#./configure
+export PKG_CONFIG_PATH="/usr/lib/pkgconfig"
+# dirty hack to let gnuradio configure find sdcc
+export PATH=$PATH:/usr/libexec/sdcc
+
+########## the bootstrap script basically reruns autoconf and automake
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
+### the code in bootstrapfs reads
+### aclocal -I config
+# we suppress the -I config so that e.g. the libtool macros used are the ones from the system, 
+# not the one that ships in config/
+sed -i -e "s,aclocal -I config,aclocal," ./bootstrap
+%endif
+
+bash -x ./bootstrap
+
 %configure --disable-doxygen
 make
 
@@ -70,10 +79,6 @@ rm -rf $RPM_BUILD_ROOT
 
 
 
-
-
-
-
 %package -n %{name}-devel
 Summary: gnuradio devel files
 Version: %{version}
@@ -103,7 +108,7 @@ Devel package of gnuradio
 %dir /etc/gnuradio
 %config /etc/gnuradio/*
 %{_libdir}/lib*so*
-%{_libdir}/python2.5/site-packages/
+%{_libdir}/python*/site-packages/
 %{_datadir}/doc/*
 %dir %{_datadir}/gnuradio
 %{_datadir}/gnuradio/*