This repo is obsolete, please see git://git.code.sf.net/p/dummynet/code@master
[ipfw.git] / Makefile.openwrt
index 50dae83..437b32a 100644 (file)
@@ -1,14 +1,14 @@
 # Makefile to build the package in openwrt.
-# goes into package/ipfw2/Makefile
+# goes into package/ipfw3/Makefile
 #
 # Edit IPFW_DIR to point to the directory with the sources for ipfw
 
-IPFW_DIR := $(TOPDIR)/../ipfw_mod
+IPFW_DIR := $(TOPDIR)/../ipfw3
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_NAME:=kmod-ipfw2
+PKG_NAME:=kmod-ipfw3
 PKG_RELEASE:=1
 
 # MV is undefined
@@ -17,20 +17,20 @@ MV ?= mv
 include $(INCLUDE_DIR)/package.mk
 
 # Description for the package.
-# The names KernelPackage/ipfw2 must match the arguments to the
-# call $(eval $(call KernelPackage,ipfw2)) used to build it
+# The names KernelPackage/ipfw3 must match the arguments to the
+# call $(eval $(call KernelPackage,ipfw3)) used to build it
 
 
-define KernelPackage/ipfw2
+define KernelPackage/ipfw3
  SUBMENU:=Other modules
  TITLE:= IPFW and dummynet
  # FILES is what makes up the module, both kernel and userland
  # It must be in the KernelPackage section
- FILES := $(PKG_BUILD_DIR)/dummynet/ipfw_mod.o $(PKG_BUILD_DIR)/ipfw/ipfw
+ FILES := $(PKG_BUILD_DIR)/dummynet2/ipfw_mod.o $(PKG_BUILD_DIR)/ipfw/ipfw
  # AUTOLOAD:=$(call AutoLoad,80,ipfw_mod)
 endef
 
-define KernelPackage/ipfw2/description
+define KernelPackage/ipfw3/description
  This package contains the ipfw and dummynet module
 endef
 
@@ -44,7 +44,8 @@ define Build/Prepare
   # $(warning Preparing ipfw sources)
        mkdir -p $(PKG_BUILD_DIR)
        $(CP) -Rp $(IPFW_DIR)/* $(PKG_BUILD_DIR)/
-       (cd $(PKG_BUILD_DIR)/dummynet && $(MAKE) include_e )
+       (cd $(PKG_BUILD_DIR)/ipfw && $(MAKE) include_e )
+       (cd $(PKG_BUILD_DIR)/dummynet2 && $(MAKE) include_e )
 endef
 
 define Build/Compile
@@ -52,28 +53,28 @@ define Build/Compile
        $(MAKE) -C "$(LINUX_DIR)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
-               SUBDIRS="$(PKG_BUILD_DIR)/dummynet" \
+               SUBDIRS="$(PKG_BUILD_DIR)/dummynet2" \
                VER=openwrt modules
        # compile the userland part for openwrt
        $(MAKE) -C $(PKG_BUILD_DIR)/ipfw \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I./include -include ../glue.h" \
+               CFLAGS="$(TARGET_CFLAGS) -DSYSCTL_NODE -DEMULATE_SYSCTL -I./include_e -I./include -include ../glue.h -DNO_ALTQ" \
                VER=openwrt all
 endef
 
-define Package/ipfw2-userland
+define Package/ipfw3-userland
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE := /sbin/ipfw
   DESCRIPTION := This is the control program for ipfw and dummynet
 endef
 
-define Package/ipfw2-userland/install
+define Package/ipfw3-userland/install
        $(INSTALL_DIR) $(1) /sbin
 endef
 
 # XXX not entirely clear why the install entry for userland works,
-# given that /sbin/ipfw is in KernelPackage/ipfw2
+# given that /sbin/ipfw is in KernelPackage/ipfw3
 
-$(eval $(call Package,ipfw2-userland))
-$(eval $(call KernelPackage,ipfw2))
+$(eval $(call Package,ipfw3-userland))
+$(eval $(call KernelPackage,ipfw3))