Update the work on ipfw tables, reduce diffs.
[ipfw.git] / ipfw.spec
index a3869f1..212efb7 100644 (file)
--- a/ipfw.spec
+++ b/ipfw.spec
@@ -47,7 +47,6 @@ ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
 
 %build
 # clean the rpm build directory
-
 rm -rf $RPM_BUILD_ROOT
 
 # with the new build, we use the kernel-devel rpm for building
@@ -59,8 +58,8 @@ rm -rf $RPM_BUILD_ROOT
 %install
 install -D -m 755 dummynet/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
-install -D -m 755 ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
-install -D -m 755 ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 755 planetlab/ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
+install -D -m 755 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -74,6 +73,10 @@ rm -rf $RPM_BUILD_ROOT
 /usr/bin/ipfw-cleanup
 %{_sysconfdir}/cron.d/ipfw.cron
 
+%postun
+# unload the module if present
+LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
+
 %changelog
 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
 - added missing qsort.c - tag 0.9-6 was broken
@@ -96,5 +99,6 @@ rm -rf $RPM_BUILD_ROOT
 
 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - post installation removed for deployment, moved manpages to the slice package
+
 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - Initial release