Update the work on ipfw tables, reduce diffs.
[ipfw.git] / ipfw.spec
index ae46ba5..212efb7 100644 (file)
--- a/ipfw.spec
+++ b/ipfw.spec
@@ -17,7 +17,7 @@
 
 %define name ipfw
 %define version 0.9
-%define taglevel 5
+%define taglevel 7
 
 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
@@ -47,7 +47,6 @@ ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
 
 %build
 # clean the rpm build directory
-
 rm -rf $RPM_BUILD_ROOT
 
 # with the new build, we use the kernel-devel rpm for building
@@ -59,8 +58,8 @@ rm -rf $RPM_BUILD_ROOT
 %install
 install -D -m 755 dummynet/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
-install -D -m 755 ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
-install -D -m 755 ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 755 planetlab/ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
+install -D -m 755 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -74,9 +73,17 @@ rm -rf $RPM_BUILD_ROOT
 /usr/bin/ipfw-cleanup
 %{_sysconfdir}/cron.d/ipfw.cron
 
+%postun
+# unload the module if present
+LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
+
 %changelog
-* Thu Nov 26 2009 Marta Carbone <marta.carbone@iet.unipi.it> - ipfw-0.9-6
-- removed goto into the main ipfw switch, enabled slice_id matching
+* Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
+- added missing qsort.c - tag 0.9-6 was broken
+
+* Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
+- root: removed goto into the main ipfw switch, enabled slice_id matching
+- slice: completely move netconfig checks into the backend
 
 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
 - additional features on matching packets, including uid match
@@ -92,5 +99,6 @@ rm -rf $RPM_BUILD_ROOT
 
 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - post installation removed for deployment, moved manpages to the slice package
+
 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - Initial release