avoid attempting to run anything at build-time & cleaned up
[ipfw.git] / planetlab / ipfwroot.spec
index f4b3049..30da96e 100644 (file)
@@ -61,18 +61,21 @@ install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
 install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %post
-# load the module
+### this script is also triggered while the node image is being created at build-time
+# some parts of the script do not make sense in this context
+# this is why the build exports PL_BOOTCD=1 in such cases
 depmod -a
-modprobe ipfw_mod
-# clean the old database and initialize the firewall
-echo "super dbcleanup" | /vsys/ipfw-be root
-echo "super init" | /vsys/ipfw-be root
-# add ipfw to chkconfig
 /sbin/chkconfig --add ipfw
+# start the service if not building
+[ -z "$PL_BOOTCD" ] && service ipfw start
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%postun
+# stop the service if not building
+[ -z "$PL_BOOTCD" ] && service ipfw stop
 
 # here there is a list of the final installation directories
 %files
@@ -81,10 +84,7 @@ rm -rf $RPM_BUILD_ROOT
 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 /sbin/ipfw
 %{_sysconfdir}/cron.d/ipfw.cron
-
-%postun
-# unload the module if present
-LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
+/etc/rc.d/init.d/ipfw
 
 %changelog
 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11