Setting tag ipfw-0.9-20
[ipfw.git] / planetlab / ipfwroot.spec
index 507f8ae..31a17e2 100644 (file)
@@ -1,6 +1,4 @@
 #
-# $Id: ipfwroot.spec 16174 2009-12-15 13:38:15Z marta $
-#
 # TODO:
 # restart crond
 #
 
 %define name ipfwroot
 %define version 0.9
-%define taglevel 9
+%define taglevel 20
 
 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
-%define kernel_id %{kernel_version}-%{kernel_release}
+
+# guess which convention is used; k27 and before used dash, k32 uses dot
+%define kernelpath_dash /usr/src/kernels/%{kernel_version}-%{kernel_release}-%{kernel_arch}
+%define kernelpath_dot /usr/src/kernels/%{kernel_version}-%{kernel_release}.%{kernel_arch}
+%define kernelpath %( [ -d %{kernelpath_dot} ] && echo %{kernelpath_dot} || echo %{kernelpath_dash} )
+
+# the k32 kernel currently builds e.g. /lib/modules/2.6.32-0.onelab.2010.12.07-i686
+# the k27 and before does not have the -i686 part
+%define kernel_id_old %{kernel_version}-%{kernel_release}
+%define kernel_id_new %{kernel_version}-%{kernel_release}.%{_target_cpu}
+%define kernel_id %( [ -d %{kernelpath_dot} ] && echo %{kernel_id_new} || echo %{kernel_id_old} )
 
 Summary: ipfw and dummynet for Linux
 Name: %{name}
@@ -32,6 +39,7 @@ Source0: %{name}-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Requires: vixie-cron
 Requires: vsys-scripts
+Obsoletes: ipfw
 
 Vendor: unipi
 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
@@ -49,9 +57,6 @@ ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
 # clean the rpm build directory
 rm -rf $RPM_BUILD_ROOT
 
-# with the new build, we use the kernel-devel rpm for building
-%define kernelpath /usr/src/kernels/%{kernel_id_arch}
-
 %__make KERNELPATH=%kernelpath clean
 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
 
@@ -59,17 +64,23 @@ rm -rf $RPM_BUILD_ROOT
 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-# load the module
+### this script is also triggered while the node image is being created at build-time
+# some parts of the script do not make sense in this context
+# this is why the build exports PL_BOOTCD=1 in such cases
 depmod -a
-modprobe ipfw_mod
-# clean the old database and initialize the firewall
-echo "super dbcleanup" | /vsys/ipfw-be root
-echo "super init" | /vsys/ipfw-be root
+/sbin/chkconfig --add ipfw
+# start the service if not building
+[ -z "$PL_BOOTCD" ] && service ipfw start
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%postun
+# stop the service if not building
+[ -z "$PL_BOOTCD" ] && service ipfw stop
 
 # here there is a list of the final installation directories
 %files
@@ -78,14 +89,35 @@ rm -rf $RPM_BUILD_ROOT
 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 /sbin/ipfw
 %{_sysconfdir}/cron.d/ipfw.cron
-
-%postun
-# unload the module if present
-LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
+/etc/rc.d/init.d/ipfw
 
 %changelog
-* Mon Mar 01 2010 Marta Carbone <marta.carbone@iet.unipi.it>
-- Load the module at installation time
+* Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
+- tweaks for compiling on k32/64 bits
+
+* Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
+- fix detection of kernel conventions
+
+* Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
+- guess conventions for either <=k27 or >=k32
+
+* Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
+- testing git only module-tag
+
+* Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
+- tagging ipfw to test module-tools on (pure) git
+
+* Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
+- tagging for obsoletes
+
+* Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
+- Update to the ipfw3 version of the dummynet code.
+
+* Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
+- add ipfw initialization script to chkconfig
+
+* Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
+- - Load module at installation - Marta
 
 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
 - consistent with vsys-scripts-0.95-13