Added a conflict with the old package name.
[ipfw.git] / planetlab / ipfwroot.spec
index ef64aa0..5e82009 100644 (file)
@@ -16,7 +16,7 @@
 
 %define name ipfwroot
 %define version 0.9
-%define taglevel 8
+%define taglevel 13
 
 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
@@ -32,6 +32,7 @@ Source0: %{name}-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Requires: vixie-cron
 Requires: vsys-scripts
+Conflicts: ipfw
 
 Vendor: unipi
 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
@@ -58,34 +59,50 @@ rm -rf $RPM_BUILD_ROOT
 %install
 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
-install -D -m 755 planetlab/ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
-
-%post
-# load the module
-##modprobe ipfw_mod
-##depmod -a
-# clean the old database and initialize the firewall
-##echo "super dbcleanup" | /vsys/ipfw-be 0
-##echo "super init" | /vsys/ipfw-be 0
+install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+### this script is also triggered while the node image is being created at build-time
+# some parts of the script do not make sense in this context
+# this is why the build exports PL_BOOTCD=1 in such cases
+depmod -a
+/sbin/chkconfig --add ipfw
+# start the service if not building
+[ -z "$PL_BOOTCD" ] && service ipfw start
+
+%postun
+# stop the service if not building
+[ -z "$PL_BOOTCD" ] && service ipfw stop
+
 # here there is a list of the final installation directories
 %files
 %defattr(-,root,root)
 %dir /lib/modules/%{kernel_id}
 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 /sbin/ipfw
-/usr/bin/ipfw-cleanup
 %{_sysconfdir}/cron.d/ipfw.cron
-
-%postun
-# unload the module if present
-LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
+/etc/rc.d/init.d/ipfw
 
 %changelog
+* Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
+- Update to the ipfw3 version of the dummynet code.
+
+* Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
+- add ipfw initialization script to chkconfig
+
+* Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
+- - Load module at installation - Marta
+
+* Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
+- consistent with vsys-scripts-0.95-13
+
+* Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
+- Integrated the ipfw rules cleanup into the backend
+
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits