Added the new version for dummynet.
[ipfw.git] / planetlab / ipfwroot.spec
index 25b418e..68373b9 100644 (file)
@@ -1,11 +1,11 @@
 #
-# $Id$
+# $Id: ipfwroot.spec 16174 2009-12-15 13:38:15Z marta $
 #
 # TODO:
 # restart crond
 # modprobe ipfw_mod.ko (depmod ?)
 #
-%define url $URL: http://onelab1.iet.unipi.it/svn/trunk/ipfw.spec $
+%define url $URL$
 
 # Marta Carbone <marta.carbone@iet.unipi.it>
 # 2009 - Universita` di Pisa
@@ -15,7 +15,7 @@
 # kernel_release : vs2.3.0.29.1.planetlab
 # kernel_version : 2.6.22.14
 
-%define name ipfw
+%define name ipfwroot
 %define version 0.9
 %define taglevel 7
 
@@ -32,6 +32,7 @@ Group: System Environment/Kernel
 Source0: %{name}-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Requires: vixie-cron
+Requires: vsys-scripts
 
 Vendor: unipi
 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
@@ -56,10 +57,10 @@ rm -rf $RPM_BUILD_ROOT
 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
 
 %install
-install -D -m 755 dummynet/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
+install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
 install -D -m 755 planetlab/ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
-install -D -m 755 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -76,8 +77,15 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 # unload the module if present
 LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
+# clean the old database and initialize the firewall
+echo "super dbcleanup" | /vsys/ipfw-be 0
+echo "super init" | /vsys/ipfw-be 0
 
 %changelog
+* Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
+- move to dummynet2, added support for table lookup
+- added the vsys-script dependencies and the ipfw initialization
+
 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - more work on the radix code, added sysctl read/write support