Prepare the code to load the module. (still commented out)
[ipfw.git] / planetlab / ipfwroot.spec
index 0e5e696..b7b08e7 100644 (file)
@@ -3,9 +3,8 @@
 #
 # TODO:
 # restart crond
-# modprobe ipfw_mod.ko (depmod ?)
 #
-%define url $URL:$
+%define url $URL$
 
 # Marta Carbone <marta.carbone@iet.unipi.it>
 # 2009 - Universita` di Pisa
@@ -32,6 +31,7 @@ Group: System Environment/Kernel
 Source0: %{name}-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Requires: vixie-cron
+Requires: vsys-scripts
 
 Vendor: unipi
 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
@@ -56,11 +56,19 @@ rm -rf $RPM_BUILD_ROOT
 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
 
 %install
-install -D -m 755 dummynet/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
+install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
 install -D -m 755 planetlab/ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
 
+%post
+# load the module
+##modprobe ipfw_mod
+##depmod -a
+# clean the old database and initialize the firewall
+##echo "super dbcleanup" | /vsys/ipfw-be 0
+##echo "super init" | /vsys/ipfw-be 0
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -78,6 +86,10 @@ rm -rf $RPM_BUILD_ROOT
 LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
 
 %changelog
+* Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
+- move to dummynet2, added support for table lookup
+- added the vsys-script dependencies and the ipfw initialization
+
 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - more work on the radix code, added sysctl read/write support