Added the ipfw init script.
[ipfw.git] / planetlab / ipfwroot.spec
index 23bb721..ca0eeaa 100644 (file)
@@ -59,6 +59,7 @@ rm -rf $RPM_BUILD_ROOT
 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
 
 %post
 # load the module
@@ -67,6 +68,8 @@ modprobe ipfw_mod
 # clean the old database and initialize the firewall
 echo "super dbcleanup" | /vsys/ipfw-be root
 echo "super init" | /vsys/ipfw-be root
+# add ipfw to chkconfig
+/sbin/chkconfig --add ipfw
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -87,9 +90,6 @@ LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ip
 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
 - - Load module at installation - Marta
 
-* Mon Mar 01 2010 Marta Carbone <marta.carbone@iet.unipi.it>
-- Load the module at installation time
-
 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
 - consistent with vsys-scripts-0.95-13