Added the ipfw init script.
[ipfw.git] / planetlab / ipfwroot.spec
index 25b418e..ca0eeaa 100644 (file)
@@ -1,11 +1,10 @@
 #
-# $Id$
+# $Id: ipfwroot.spec 16174 2009-12-15 13:38:15Z marta $
 #
 # TODO:
 # restart crond
-# modprobe ipfw_mod.ko (depmod ?)
 #
-%define url $URL: http://onelab1.iet.unipi.it/svn/trunk/ipfw.spec $
+%define url $URL$
 
 # Marta Carbone <marta.carbone@iet.unipi.it>
 # 2009 - Universita` di Pisa
@@ -15,9 +14,9 @@
 # kernel_release : vs2.3.0.29.1.planetlab
 # kernel_version : 2.6.22.14
 
-%define name ipfw
+%define name ipfwroot
 %define version 0.9
-%define taglevel 7
+%define taglevel 10
 
 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
@@ -32,6 +31,7 @@ Group: System Environment/Kernel
 Source0: %{name}-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Requires: vixie-cron
+Requires: vsys-scripts
 
 Vendor: unipi
 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
@@ -56,10 +56,20 @@ rm -rf $RPM_BUILD_ROOT
 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
 
 %install
-install -D -m 755 dummynet/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
+install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
-install -D -m 755 planetlab/ipfw-cleanup $RPM_BUILD_ROOT/usr/bin/ipfw-cleanup
-install -D -m 755 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
+
+%post
+# load the module
+depmod -a
+modprobe ipfw_mod
+# clean the old database and initialize the firewall
+echo "super dbcleanup" | /vsys/ipfw-be root
+echo "super init" | /vsys/ipfw-be root
+# add ipfw to chkconfig
+/sbin/chkconfig --add ipfw
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -70,7 +80,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir /lib/modules/%{kernel_id}
 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 /sbin/ipfw
-/usr/bin/ipfw-cleanup
 %{_sysconfdir}/cron.d/ipfw.cron
 
 %postun
@@ -78,6 +87,22 @@ rm -rf $RPM_BUILD_ROOT
 LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
 
 %changelog
+* Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
+- - Load module at installation - Marta
+
+* Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
+- consistent with vsys-scripts-0.95-13
+
+* Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
+- Integrated the ipfw rules cleanup into the backend
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
+- builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
+
+* Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
+- move to dummynet2, added support for table lookup
+- added the vsys-script dependencies and the ipfw initialization
+
 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
 - more work on the radix code, added sysctl read/write support