Added the ipfw init script.
[ipfw.git] / planetlab / ipfwroot.spec
index c533198..ca0eeaa 100644 (file)
@@ -16,7 +16,7 @@
 
 %define name ipfwroot
 %define version 0.9
-%define taglevel 8
+%define taglevel 10
 
 %define release %{kernel_version}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define kernel_id_arch %{kernel_version}-%{kernel_release}-%{kernel_arch}
@@ -59,14 +59,17 @@ rm -rf $RPM_BUILD_ROOT
 install -D -m 755 dummynet2/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
+install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
 
 %post
 # load the module
-##depmod -a
-##modprobe ipfw_mod
+depmod -a
+modprobe ipfw_mod
 # clean the old database and initialize the firewall
-##echo "super dbcleanup" | /vsys/ipfw-be 0
-##echo "super init" | /vsys/ipfw-be 0
+echo "super dbcleanup" | /vsys/ipfw-be root
+echo "super init" | /vsys/ipfw-be root
+# add ipfw to chkconfig
+/sbin/chkconfig --add ipfw
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -84,6 +87,12 @@ rm -rf $RPM_BUILD_ROOT
 LOADED=`cat /proc/modules | grep ^ipfw_mod`; if [ -n "$LOADED" ] ; then rmmod ipfw_mod; fi
 
 %changelog
+* Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
+- - Load module at installation - Marta
+
+* Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
+- consistent with vsys-scripts-0.95-13
+
 * Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
 - Integrated the ipfw rules cleanup into the backend