578554e43fb6f8e2f1ac94e3dd3e833d22f108e2
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.12
3 %define subversion .1
4 %define taglevel 0
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: Tools for managing Linux kernel packet filtering capabilities
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}%{subversion}.tar.bz2
18 Source1: iptables.init
19 Source2: iptables-config
20 Source3: planetlab-config
21 Patch1: copy-xid.patch
22 Group: System Environment/Base
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24 License: GPLv2
25 BuildRequires: libselinux-devel
26 BuildRequires: kernel-headers
27 Conflicts: kernel < 2.4.20
28 Requires(post): chkconfig
29 Requires(post): initscripts
30 Requires(preun): chkconfig
31
32 %description
33 The iptables utility controls the network packet filtering code in the
34 Linux kernel. If you need to set up firewalls and/or IP masquerading,
35 you should install this package.
36
37 %package ipv6
38 Summary: IPv6 support for iptables
39 Group: System Environment/Base
40 Requires: %{name} = %{version}-%{release}
41 Requires(post): chkconfig
42 Requires(preun): chkconfig
43
44 %description ipv6
45 The iptables package contains IPv6 (the next version of the IP
46 protocol) support for iptables. Iptables controls the Linux kernel
47 network packet filtering code, allowing you to set up firewalls and IP
48 masquerading. 
49
50 Install iptables-ipv6 if you need to set up firewalling for your
51 network and you are using ipv6.
52
53 %package devel
54 Summary: Development package for iptables
55 Group: System Environment/Base
56 Requires: %{name} = %{version}-%{release}
57 Requires: pkgconfig
58
59 %description devel
60 iptables development headers and libraries.
61
62 The iptc interface is upstream marked as not public. The interface is not 
63 stable and may change with every new version. It is therefore unsupported.
64
65 %prep
66 %setup -q
67 %patch1 -p1 
68
69 %build
70 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
71 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
72
73 # do not use rpath
74 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
75 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
76
77 make
78
79 %install
80 rm -rf %{buildroot}
81
82 make install DESTDIR=%{buildroot} 
83 # remove la file(s)
84 rm -f %{buildroot}/%{_lib}/*.la
85
86 # install ip*tables.h header files
87 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
88 install -d -m 755 %{buildroot}%{_includedir}/iptables
89 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
90
91 # install ipulog header file
92 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
93 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
94
95 # create symlinks for devel so libs
96 install -d -m 755 %{buildroot}%{_libdir}
97 for i in %{buildroot}/%{_lib}/*.so; do
98     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
99 done
100
101 # move pkgconfig to %{_libdir}
102 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
103
104 # install init scripts and configuration files
105 install -d -m 755 %{buildroot}/etc/rc.d/init.d
106 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
107 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
108 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
109 install -d -m 755 %{buildroot}/etc/sysconfig
110 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
111 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
112 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
113 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
114
115 %clean
116 rm -rf %{buildroot}
117
118 %post
119 /sbin/ldconfig
120 /sbin/chkconfig --add iptables
121 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
122 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
123 [ "$PL_BOOTCD" = "1" ] || service iptables restart
124
125 %postun -p /sbin/ldconfig
126
127 %preun
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del iptables
130 fi
131
132 %post ipv6
133 /sbin/chkconfig --add ip6tables
134
135 %preun ipv6
136 if [ "$1" = 0 ]; then
137         /sbin/chkconfig --del ip6tables
138 fi
139
140 %files
141 %defattr(-,root,root)
142 %doc COPYING INSTALL INCOMPATIBILITIES
143 %attr(0755,root,root) /etc/rc.d/init.d/iptables
144 %config %attr(0600,root,root) /etc/sysconfig/iptables-config
145 %config %attr(0600,root,root) /etc/sysconfig/iptables
146 /sbin/iptables*
147 /bin/iptables-xml
148 %{_mandir}/man8/iptables*
149 %dir /%{_lib}/xtables
150 /%{_lib}/xtables/libipt*
151 /%{_lib}/xtables/libxt*
152 /%{_lib}/libip*tc.so.*
153 /%{_lib}/libipq.so.*
154 /%{_lib}/libxtables.so.*
155
156 %files ipv6
157 %defattr(-,root,root)
158 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
159 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
160 /sbin/ip6tables*
161 %{_mandir}/man8/ip6tables*
162 /%{_lib}/xtables/libip6t*
163
164 %files devel
165 %defattr(-,root,root)
166 %dir %{_includedir}/iptables
167 %{_includedir}/iptables/*.h
168 %{_includedir}/*.h
169 %dir %{_includedir}/libiptc
170 %{_includedir}/libiptc/*.h
171 %dir %{_includedir}/libipulog
172 %{_includedir}/libipulog/*.h
173 %{_mandir}/man3/*
174 /%{_lib}/libip*tc.so
175 /%{_lib}/libipq.so
176 /%{_lib}/libxtables.so
177 %{_libdir}/libip*tc.so
178 %{_libdir}/libipq.so
179 %{_libdir}/libxtables.so
180 %{_libdir}/pkgconfig/libiptc.pc
181 %{_libdir}/pkgconfig/xtables.pc
182
183 %changelog
184 * Tue Aug 09 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - iptables-1.4.10-5
185 - Adding a recently abused (=received experimental traffic from planetlab) node to a global iptables blacklist. I will be
186 - implementing this mechanism more formally
187 - using
188 - iptables in the coming days. Unfortunately, because of the complexity of the recipient network we are unable to
189 - determine a comprehensive set of the slices responsible in this case, so I am adding this temporary hack for now.
190
191 * Thu Mar 24 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-4
192 - Don't start iptables service on build time
193
194 * Wed Feb 23 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-3
195 - Remove ugly hack for config files
196
197 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
198 - Fix the patch
199
200 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
201 - Fix incorrect sha1sum
202
203 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
204 - add requires initscripts in deps
205
206 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
207 - Restart iptables service after package upgrades
208
209 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
210 - Restore iIPTABLES_MODULES list
211
212 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
213 - drop backward compatibility with older iptables versions as new kernels only support v2
214 - remove unused modules from iptables-config file
215
216 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
217 - fixed specfile for duplicate URL
218
219 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
220 - added default values for IPTABLES_STATUS_VERBOSE and
221   IPTABLES_STATUS_LINENUMBERS in init script
222 - added missing lsb keywords Required-Start and Required-Stop to init script
223
224 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
225 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
226   - libip4tc: Add static qualifier to dump_entry()
227   - libipq: build as shared library
228   - recent: reorder cases in code (cosmetic cleanup)
229   - several man page and documentation fixes
230   - policy: fix error message showing wrong option
231   - includes: header updates
232   - Lift restrictions on interface names
233 - fixed license and moved iptables-xml into base package according to review
234
235 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
236 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
237   to /usr/lib[64] for compatibility (rhbz#558796)
238
239 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
240 - new version 1.4.6 with support for all new features of 2.6.32
241   - several man page fixes
242   - Support for nommu arches
243   - realm: remove static initializations
244   - libiptc: remove unused functions
245   - libiptc: avoid strict-aliasing warnings
246   - iprange: do accept non-ranges for xt_iprange v1
247   - iprange: warn on reverse range
248   - iprange: roll address parsing into a loop
249   - iprange: do accept non-ranges for xt_iprange v1 (log)
250   - iprange: warn on reverse range (log)
251   - libiptc: fix wrong maptype of base chain counters on restore
252   - iptables: fix undersized deletion mask creation
253   - style: reduce indent in xtables_check_inverse
254   - libxtables: hand argv to xtables_check_inverse
255   - iptables/extensions: make bundled options work again
256   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
257   - iptables: take masks into consideration for replace command
258   - doc: explain experienced --hitcount limit
259   - doc: name resolution clarification
260   - iptables: expose option to zero packet/byte counters for a specific rule
261   - build: restore --disable-ipv6 functionality on system w/o v6 headers
262   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
263   - DNAT: fix incorrect check during parsing
264   - extensions: add osf extension
265   - conntrack: fix --expires parsing
266
267 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
268 - dropped nf_ext_init remains from cloexec patch
269
270 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
271 - new version 1.4.5 with support for all new features of 2.6.31
272   - libxt_NFQUEUE: add new v1 version with queue-balance option
273   - xt_conntrack: revision 2 for enlarged state_mask member
274   - libxt_helper: fix invalid passed option to check_inverse
275   - libiptc: split v4 and v6
276   - extensions: collapse registration structures
277   - iptables: allow for parse-less extensions
278   - iptables: allow for help-less extensions
279   - extensions: remove empty help and parse functions
280   - xtables: add multi-registration functions
281   - extensions: collapse data variables to use multi-reg calls
282   - xtables: warn of missing version identifier in extensions
283   - multi binary: allow subcommand via argv[1]
284   - iptables: accept multiple IP address specifications for -s, -d
285   - several build fixes
286   - several man page fixes
287 - fixed two leaked file descriptors on sockets (rhbz#521397)
288
289 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
290 - new version 1.4.4 with support for all new features of 2.6.30
291   - several man page fixes
292   - iptables: replace open-coded sizeof by ARRAY_SIZE
293   - libip6t_policy: remove redundant functions
294   - policy: use direct xt_policy_info instead of ipt/ip6t
295   - policy: merge ipv6 and ipv4 variant
296   - extensions: add `cluster' match support
297   - extensions: add const qualifiers in print/save functions
298   - extensions: use NFPROTO_UNSPEC for .family field
299   - extensions: remove redundant casts
300   - iptables: close open file descriptors
301   - fix segfault if incorrect protocol name is used
302   - replace open-coded sizeof by ARRAY_SIZE
303   - do not include v4-only modules in ip6tables manpage
304   - use direct xt_policy_info instead of ipt/ip6t
305   - xtables: fix segfault if incorrect protocol name is used
306   - libxt_connlimit: initialize v6_mask
307   - SNAT/DNAT: add support for persistent multi-range NAT mappings
308
309 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
310 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
311
312 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
313 - new version 1.4.3.2
314 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
315
316 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
317 - new version 1.4.3.1
318   - libiptc is now shared
319   - supports all new features of the 2.6.29 kernel
320 - dropped typo_latter patch
321
322 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
323 - still more review fixes (rhbz#225906)
324   - consistent macro usage
325   - use sed instead of perl for rpath removal
326   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
327
328 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
329 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
330
331 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
332 - new version 1.4.2
333 - removed TOS value mask patch (upstream)
334 - more review fixes (rhbz#225906)
335 - install all header files (rhbz#462207)
336 - dropped nf_ext_init (rhbz#472548)
337
338 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
339 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
340 - two more cloexec fixes
341
342 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
343 - upstream bug fix release 1.4.1.1
344 - dropped extra patch for 1.4.1 - not needed anymore
345
346 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
347 - new version 1.4.1 with new build environment
348 - additional ipv6 network mask patch from Jan Engelhardt
349 - spec file cleanup
350 - removed old patches
351
352 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
353 - use normal kernel headers, not linux/compiler.h
354 - change BuildRequires: kernel-devel to kernel-headers
355 - We need to do this to be able to build for both sparcv9 and sparc64 
356   (there is no kernel-devel.sparcv9)
357
358 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
359 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
360
361 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
362 - use the kernel headers from the build tree for iptables for now to be able to 
363   compile this package, but this makes the package more kernel dependant
364 - use s6_addr32 instead of in6_u.u6_addr32
365
366 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
367 - Autorebuild for GCC 4.3
368
369 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
370 - new version 1.4.0
371 - fixed condrestart (rhbz#428148)
372 - report the module in rmmod_r if there is an error
373 - use nf_ext_init instead of my_init for extension constructors
374
375 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
376 - fixed leaked file descriptor before fork/exec (rhbz#312191)
377 - blacklisting is not working, use "install X /bin/(true|false)" test instead
378 - return private exit code 150 for disabled ipv6 support
379 - use script name for output messages
380
381 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
382 - fixed error code for stopping a already stopped firewall (rhbz#321751)
383 - moved blacklist test into start
384
385 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
386 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
387 - use simpler fix for (rhbz#295611)
388   Thanks to Linus Torvalds for the patch.
389
390 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
391 - fixed IPv6 reject type (rhbz#295181)
392 - fixed init script: start, stop and status
393 - support netfilter compiled into kernel in init script (rhbz#295611)
394 - dropped inversion for limit modules from man pages (rhbz#220780)
395 - fixed typo in ip6tables man page (rhbz#236185)
396
397 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
398 - do not depend on local_fs in lsb header - this delayes start after network
399 - fixed exit code for initscript usage
400
401 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
402 - do not use lock file for condrestart test
403
404 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
405 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
406 - provide iptc interface again, but unsupported (rhbz#216733)
407 - compile all extension, which are supported by the kernel-headers package
408 - review fixes (rhbz#225906)
409
410 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
411 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
412
413 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
414 - New version 1.3.8
415
416 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
417 - fix error when ipv6 support isn't loaded in the kernel (#236888)
418
419 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
420 - fixed installation of secmark modules
421
422 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
423 - new verison 1.3.7
424 - iptc is not a public interface and therefore not installed anymore
425 - dropped upstream secmark patch
426
427 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
428 - added secmark iptables patches (#201573)
429
430 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
431 - rebuild
432
433 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
434 - bump again for double-long bug on ppc(64)
435
436 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
437 - rebuilt for new gcc4.1 snapshot and glibc changes
438
439 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
440 - new version 1.3.5
441 - fixed init script to set policy for raw tables, too (#179094)
442
443 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
444 - added important iptables header files to devel package
445
446 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
447 - rebuilt
448
449 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
450 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
451   replace "_init" with "__attribute((constructor)) my_init"
452
453 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
454 - rebuild due to unresolved symbols in shared libraries
455
456 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
457 - new version 1.3.4
458 - dropped free_opts patch (upstream fixed)
459 - made libipq PIC (#158623)
460 - additional configuration options for iptables startup script (#172929)
461   Thanks to Jan Gruenwald for the patch
462 - spec file cleanup (dropped linux_header define and usage)
463
464 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
465 - new version 1.3.2 with additional patch for the misplaced free_opts call
466   from Marcus Sundberg
467
468 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
469 - new version 1.3.1
470
471 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
472 - Remove unnecessary explicit kernel dep (#146142)
473 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
474   for the patch
475 - Adapted iptables-config to reference to modprobe.conf (#150143)
476 - Remove misleading message (#140154): Thanks to Ulrich Drepper
477   for the patch
478
479 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
480 - new version 1.3.0
481
482 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
483 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
484
485 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
486 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
487 - modified config file to match this change and un-commented variables with
488   default values
489
490 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
491 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
492   for the patch
493
494 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
495 - fixed free bug in iptables (#128322)
496
497 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
498 - new version 1.2.11
499
500 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
501 - new version 1.2.10
502
503 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
504 - rebuilt
505
506 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
507 - rebuilt
508
509 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
510 - fixed iptables-restore -c fault if there are no counters (#116421)
511
512 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
513 - rebuilt
514
515 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
516 - Close File descriptors to prevent SELinux error message
517
518 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
519 - rebuild
520
521 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
522 - vew version 1.2.9
523 - new config options in ipXtables-config:
524   IPTABLES_MODULES_UNLOAD
525 - more documentation in ipXtables-config
526 - fix for netlink security issue in libipq (devel package)
527 - print fix for libipt_icmp (#109546)
528
529 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
530 - marked all messages in iptables init script for translation (#107462)
531 - enabled devel package (#105884, #106101)
532 - bumped build for fedora for libipt_recent.so (#106002)
533
534 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
535 - fixed lost udp port range in ip6tables-save (#104484)
536 - fixed non numeric multiport port output in ipXtables-savs
537
538 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
539 - do not link against -lnsl
540
541 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
542 - made variables in rmmod_r local
543
544 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
545 - fixed permission for init script
546
547 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
548 - fixed save when iptables file is missing and iptables-config permissions
549
550 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
551 - fixes for ip6tables: module unloading, setting policy only for existing 
552   tables
553
554 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
555 - IPTABLES_SAVE_COUNTER defaults to no, now
556 - install config file in /etc/sysconfig
557 - exchange unload of ip_tables and ip_conntrack
558 - fixed start function
559
560 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
561 - new config option IPTABLES_SAVE_ON_RESTART
562 - init script: new status, save and restart
563 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
564
565 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
566 - new config option IPTABLES_STATUS_NUMERIC
567 - cleared IPTABLES_MODULES in iptables-config
568
569 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
570 - new init scripts
571
572 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
573 - remove check for very old kernel versions in init scripts
574 - sync up both init scripts and remove some further ugly things
575 - add some docu into rpm
576
577 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
578 - rebuild
579
580 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
581 - update to 1.2.8
582
583 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
584 - rebuilt
585
586 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
587 - update to 1.2.7a
588 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
589
590 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
591 - Fix multilib
592
593 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
594 - fixed iptables and ip6tables initscript output, based on #70511
595 - check return status of all iptables calls, not just the last one
596   in a 'for' loop.
597
598 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
599 - 1.2.6a (bugfix release, #69747)
600
601 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
602 - automated rebuild
603
604 * Thu May 23 2002 Tim Powers <timp@redhat.com>
605 - automated rebuild
606
607 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
608 - Add some fixes from CVS, fixing bug #60465
609
610 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
611 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
612   #59402
613 - Update URL (#59354)
614 - Use /sbin/chkconfig rather than chkconfig in %%postun script
615
616 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
617 - 1.2.5
618
619 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
620 - automated rebuild
621
622 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
623 - Fix %%preun script
624
625 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
626 - Update to 1.2.4 (various fixes, including security fixes; among others:
627   #42990, #50500, #53325, #54280)
628 - Fix init script (#31133)
629
630 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
631 - 1.2.3 (5 security fixes, some other fixes)
632 - Fix updating (#53032)
633
634 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
635 - Fix #50990
636 - Add some fixes from current CVS; should fix #52620
637
638 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
639 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
640   issues
641
642 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
643 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
644   <mschwendt@yahoo.com>
645
646 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
647 - 1.2.2
648
649 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
650 - 1.2.1a, fixes #28412, #31136, #31460, #31133
651
652 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
653 - Yet another initscript fix (#30173)
654 - Fix the fixes; they fixed some issues but broke more important
655   stuff :/ (#30176)
656
657 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
658 - Fix up initscript (#27962)
659 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
660
661 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
662 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
663
664 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
665 - fix bugzilla #25986 (initscript not marked as config file)
666 - fix bugzilla #25962 (iptables-restore)
667 - mv chkconfig --del from postun to preun
668
669 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
670 - Fix check for ipchains
671
672 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
673 - Some fixes to init scripts
674
675 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
676 - Add some fixes from CVS, fixes among other things Bug #24732
677
678 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
679 - Add missing man pages, fix up init script (Bug #17676)
680
681 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
682 - add init script
683
684 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
685 - 1.2
686 - fix up ipv6 split
687 - add init script
688 - Move the plugins from /usr/lib/iptables to /lib/iptables.
689   This needs to work before /usr is mounted...
690 - Use -O1 on alpha (compiler bug)
691
692 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
693 - 1.1.2
694 - Add IPv6 support (in separate package)
695
696 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
697 - build everywhere
698
699 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
700 - 1.1.1
701
702 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
703 - automatic rebuild
704
705 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
706 - move iptables to /sbin.
707 - excludearch alpha for now, not building there because of compiler bug(?)
708
709 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
710 - don't obsolete ipchains either
711 - update to 1.1.0
712
713 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
714 - remove explicit kernel requirement
715
716 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
717 - initial package