Setting tag iptables-1.4.7-2
[iptables.git] / iptables.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iptables
7 %define version 1.4.7
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Tools for managing Linux kernel packet filtering capabilities
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
22 Source1: iptables.init
23 Source2: iptables-config
24 Source3: planetlab-config
25 Patch1: copy-xid.patch
26 Group: System Environment/Base
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 License: GPLv2
29 BuildRequires: libselinux-devel
30 BuildRequires: kernel-headers
31 Conflicts: kernel < 2.4.20
32 Requires(post): chkconfig
33 Requires(preun): chkconfig
34
35 %description
36 The iptables utility controls the network packet filtering code in the
37 Linux kernel. If you need to set up firewalls and/or IP masquerading,
38 you should install this package.
39
40 %package ipv6
41 Summary: IPv6 support for iptables
42 Group: System Environment/Base
43 Requires: %{name} = %{version}-%{release}
44 Requires(post): chkconfig
45 Requires(preun): chkconfig
46
47 %description ipv6
48 The iptables package contains IPv6 (the next version of the IP
49 protocol) support for iptables. Iptables controls the Linux kernel
50 network packet filtering code, allowing you to set up firewalls and IP
51 masquerading. 
52
53 Install iptables-ipv6 if you need to set up firewalling for your
54 network and you are using ipv6.
55
56 %package devel
57 Summary: Development package for iptables
58 Group: System Environment/Base
59 Requires: %{name} = %{version}-%{release}
60 Requires: pkgconfig
61
62 %description devel
63 iptables development headers and libraries.
64
65 The iptc interface is upstream marked as not public. The interface is not 
66 stable and may change with every new version. It is therefore unsupported.
67
68 %prep
69 %setup -q
70 %patch1 -p1 
71
72 %build
73 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
74 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
75
76 # do not use rpath
77 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79
80 make
81
82 %install
83 rm -rf %{buildroot}
84
85 make install DESTDIR=%{buildroot} 
86 # remove la file(s)
87 rm -f %{buildroot}/%{_lib}/*.la
88
89 # install ip*tables.h header files
90 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
91 install -d -m 755 %{buildroot}%{_includedir}/iptables
92 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
93
94 # install ipulog header file
95 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
96 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
97
98 # create symlinks for devel so libs
99 install -d -m 755 %{buildroot}%{_libdir}
100 for i in %{buildroot}/%{_lib}/*.so; do
101     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
102 done
103
104 # move pkgconfig to %{_libdir}
105 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
106
107 # install init scripts and configuration files
108 install -d -m 755 %{buildroot}/etc/rc.d/init.d
109 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
111 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
112 install -d -m 755 %{buildroot}/etc/sysconfig
113 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
114 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
115 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
116 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
117
118 %clean
119 rm -rf %{buildroot}
120
121 %post
122 /sbin/ldconfig
123 /sbin/chkconfig --add iptables
124
125 %postun -p /sbin/ldconfig
126
127 %preun
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del iptables
130 fi
131
132 %post ipv6
133 /sbin/chkconfig --add ip6tables
134
135 %preun ipv6
136 if [ "$1" = 0 ]; then
137         /sbin/chkconfig --del ip6tables
138 fi
139
140 %files
141 %defattr(-,root,root)
142 %doc COPYING INSTALL INCOMPATIBILITIES
143 %attr(0755,root,root) /etc/rc.d/init.d/iptables
144 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
146 /sbin/iptables*
147 /bin/iptables-xml
148 %{_mandir}/man8/iptables*
149 %dir /%{_lib}/xtables
150 /%{_lib}/xtables/libipt*
151 /%{_lib}/xtables/libxt*
152 /%{_lib}/libip*tc.so.*
153 /%{_lib}/libipq.so.*
154 /%{_lib}/libxtables.so.*
155
156 %files ipv6
157 %defattr(-,root,root)
158 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
159 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
160 /sbin/ip6tables*
161 %{_mandir}/man8/ip6tables*
162 /%{_lib}/xtables/libip6t*
163
164 %files devel
165 %defattr(-,root,root)
166 %dir %{_includedir}/iptables
167 %{_includedir}/iptables/*.h
168 %{_includedir}/*.h
169 %dir %{_includedir}/libiptc
170 %{_includedir}/libiptc/*.h
171 %dir %{_includedir}/libipulog
172 %{_includedir}/libipulog/*.h
173 %{_mandir}/man3/*
174 /%{_lib}/libip*tc.so
175 /%{_lib}/libipq.so
176 /%{_lib}/libxtables.so
177 %{_libdir}/libip*tc.so
178 %{_libdir}/libipq.so
179 %{_libdir}/libxtables.so
180 %{_libdir}/pkgconfig/libiptc.pc
181 %{_libdir}/pkgconfig/xtables.pc
182
183 %changelog
184 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
185 - fixed specfile for duplicate URL
186
187 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
188 - added default values for IPTABLES_STATUS_VERBOSE and
189   IPTABLES_STATUS_LINENUMBERS in init script
190 - added missing lsb keywords Required-Start and Required-Stop to init script
191
192 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
193 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
194   - libip4tc: Add static qualifier to dump_entry()
195   - libipq: build as shared library
196   - recent: reorder cases in code (cosmetic cleanup)
197   - several man page and documentation fixes
198   - policy: fix error message showing wrong option
199   - includes: header updates
200   - Lift restrictions on interface names
201 - fixed license and moved iptables-xml into base package according to review
202
203 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
204 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
205   to /usr/lib[64] for compatibility (rhbz#558796)
206
207 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
208 - new version 1.4.6 with support for all new features of 2.6.32
209   - several man page fixes
210   - Support for nommu arches
211   - realm: remove static initializations
212   - libiptc: remove unused functions
213   - libiptc: avoid strict-aliasing warnings
214   - iprange: do accept non-ranges for xt_iprange v1
215   - iprange: warn on reverse range
216   - iprange: roll address parsing into a loop
217   - iprange: do accept non-ranges for xt_iprange v1 (log)
218   - iprange: warn on reverse range (log)
219   - libiptc: fix wrong maptype of base chain counters on restore
220   - iptables: fix undersized deletion mask creation
221   - style: reduce indent in xtables_check_inverse
222   - libxtables: hand argv to xtables_check_inverse
223   - iptables/extensions: make bundled options work again
224   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
225   - iptables: take masks into consideration for replace command
226   - doc: explain experienced --hitcount limit
227   - doc: name resolution clarification
228   - iptables: expose option to zero packet/byte counters for a specific rule
229   - build: restore --disable-ipv6 functionality on system w/o v6 headers
230   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
231   - DNAT: fix incorrect check during parsing
232   - extensions: add osf extension
233   - conntrack: fix --expires parsing
234
235 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
236 - dropped nf_ext_init remains from cloexec patch
237
238 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
239 - new version 1.4.5 with support for all new features of 2.6.31
240   - libxt_NFQUEUE: add new v1 version with queue-balance option
241   - xt_conntrack: revision 2 for enlarged state_mask member
242   - libxt_helper: fix invalid passed option to check_inverse
243   - libiptc: split v4 and v6
244   - extensions: collapse registration structures
245   - iptables: allow for parse-less extensions
246   - iptables: allow for help-less extensions
247   - extensions: remove empty help and parse functions
248   - xtables: add multi-registration functions
249   - extensions: collapse data variables to use multi-reg calls
250   - xtables: warn of missing version identifier in extensions
251   - multi binary: allow subcommand via argv[1]
252   - iptables: accept multiple IP address specifications for -s, -d
253   - several build fixes
254   - several man page fixes
255 - fixed two leaked file descriptors on sockets (rhbz#521397)
256
257 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
258 - new version 1.4.4 with support for all new features of 2.6.30
259   - several man page fixes
260   - iptables: replace open-coded sizeof by ARRAY_SIZE
261   - libip6t_policy: remove redundant functions
262   - policy: use direct xt_policy_info instead of ipt/ip6t
263   - policy: merge ipv6 and ipv4 variant
264   - extensions: add `cluster' match support
265   - extensions: add const qualifiers in print/save functions
266   - extensions: use NFPROTO_UNSPEC for .family field
267   - extensions: remove redundant casts
268   - iptables: close open file descriptors
269   - fix segfault if incorrect protocol name is used
270   - replace open-coded sizeof by ARRAY_SIZE
271   - do not include v4-only modules in ip6tables manpage
272   - use direct xt_policy_info instead of ipt/ip6t
273   - xtables: fix segfault if incorrect protocol name is used
274   - libxt_connlimit: initialize v6_mask
275   - SNAT/DNAT: add support for persistent multi-range NAT mappings
276
277 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
278 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
279
280 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
281 - new version 1.4.3.2
282 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
283
284 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
285 - new version 1.4.3.1
286   - libiptc is now shared
287   - supports all new features of the 2.6.29 kernel
288 - dropped typo_latter patch
289
290 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
291 - still more review fixes (rhbz#225906)
292   - consistent macro usage
293   - use sed instead of perl for rpath removal
294   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
295
296 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
297 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
298
299 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
300 - new version 1.4.2
301 - removed TOS value mask patch (upstream)
302 - more review fixes (rhbz#225906)
303 - install all header files (rhbz#462207)
304 - dropped nf_ext_init (rhbz#472548)
305
306 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
307 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
308 - two more cloexec fixes
309
310 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
311 - upstream bug fix release 1.4.1.1
312 - dropped extra patch for 1.4.1 - not needed anymore
313
314 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
315 - new version 1.4.1 with new build environment
316 - additional ipv6 network mask patch from Jan Engelhardt
317 - spec file cleanup
318 - removed old patches
319
320 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
321 - use normal kernel headers, not linux/compiler.h
322 - change BuildRequires: kernel-devel to kernel-headers
323 - We need to do this to be able to build for both sparcv9 and sparc64 
324   (there is no kernel-devel.sparcv9)
325
326 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
327 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
328
329 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
330 - use the kernel headers from the build tree for iptables for now to be able to 
331   compile this package, but this makes the package more kernel dependant
332 - use s6_addr32 instead of in6_u.u6_addr32
333
334 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
335 - Autorebuild for GCC 4.3
336
337 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
338 - new version 1.4.0
339 - fixed condrestart (rhbz#428148)
340 - report the module in rmmod_r if there is an error
341 - use nf_ext_init instead of my_init for extension constructors
342
343 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
344 - fixed leaked file descriptor before fork/exec (rhbz#312191)
345 - blacklisting is not working, use "install X /bin/(true|false)" test instead
346 - return private exit code 150 for disabled ipv6 support
347 - use script name for output messages
348
349 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
350 - fixed error code for stopping a already stopped firewall (rhbz#321751)
351 - moved blacklist test into start
352
353 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
354 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
355 - use simpler fix for (rhbz#295611)
356   Thanks to Linus Torvalds for the patch.
357
358 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
359 - fixed IPv6 reject type (rhbz#295181)
360 - fixed init script: start, stop and status
361 - support netfilter compiled into kernel in init script (rhbz#295611)
362 - dropped inversion for limit modules from man pages (rhbz#220780)
363 - fixed typo in ip6tables man page (rhbz#236185)
364
365 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
366 - do not depend on local_fs in lsb header - this delayes start after network
367 - fixed exit code for initscript usage
368
369 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
370 - do not use lock file for condrestart test
371
372 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
373 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
374 - provide iptc interface again, but unsupported (rhbz#216733)
375 - compile all extension, which are supported by the kernel-headers package
376 - review fixes (rhbz#225906)
377
378 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
379 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
380
381 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
382 - New version 1.3.8
383
384 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
385 - fix error when ipv6 support isn't loaded in the kernel (#236888)
386
387 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
388 - fixed installation of secmark modules
389
390 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
391 - new verison 1.3.7
392 - iptc is not a public interface and therefore not installed anymore
393 - dropped upstream secmark patch
394
395 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
396 - added secmark iptables patches (#201573)
397
398 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
399 - rebuild
400
401 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
402 - bump again for double-long bug on ppc(64)
403
404 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
405 - rebuilt for new gcc4.1 snapshot and glibc changes
406
407 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
408 - new version 1.3.5
409 - fixed init script to set policy for raw tables, too (#179094)
410
411 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
412 - added important iptables header files to devel package
413
414 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
415 - rebuilt
416
417 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
418 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
419   replace "_init" with "__attribute((constructor)) my_init"
420
421 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
422 - rebuild due to unresolved symbols in shared libraries
423
424 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
425 - new version 1.3.4
426 - dropped free_opts patch (upstream fixed)
427 - made libipq PIC (#158623)
428 - additional configuration options for iptables startup script (#172929)
429   Thanks to Jan Gruenwald for the patch
430 - spec file cleanup (dropped linux_header define and usage)
431
432 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
433 - new version 1.3.2 with additional patch for the misplaced free_opts call
434   from Marcus Sundberg
435
436 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
437 - new version 1.3.1
438
439 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
440 - Remove unnecessary explicit kernel dep (#146142)
441 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
442   for the patch
443 - Adapted iptables-config to reference to modprobe.conf (#150143)
444 - Remove misleading message (#140154): Thanks to Ulrich Drepper
445   for the patch
446
447 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
448 - new version 1.3.0
449
450 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
451 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
452
453 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
454 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
455 - modified config file to match this change and un-commented variables with
456   default values
457
458 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
459 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
460   for the patch
461
462 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
463 - fixed free bug in iptables (#128322)
464
465 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
466 - new version 1.2.11
467
468 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
469 - new version 1.2.10
470
471 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
472 - rebuilt
473
474 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
475 - rebuilt
476
477 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
478 - fixed iptables-restore -c fault if there are no counters (#116421)
479
480 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
481 - rebuilt
482
483 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
484 - Close File descriptors to prevent SELinux error message
485
486 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
487 - rebuild
488
489 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
490 - vew version 1.2.9
491 - new config options in ipXtables-config:
492   IPTABLES_MODULES_UNLOAD
493 - more documentation in ipXtables-config
494 - fix for netlink security issue in libipq (devel package)
495 - print fix for libipt_icmp (#109546)
496
497 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
498 - marked all messages in iptables init script for translation (#107462)
499 - enabled devel package (#105884, #106101)
500 - bumped build for fedora for libipt_recent.so (#106002)
501
502 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
503 - fixed lost udp port range in ip6tables-save (#104484)
504 - fixed non numeric multiport port output in ipXtables-savs
505
506 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
507 - do not link against -lnsl
508
509 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
510 - made variables in rmmod_r local
511
512 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
513 - fixed permission for init script
514
515 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
516 - fixed save when iptables file is missing and iptables-config permissions
517
518 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
519 - fixes for ip6tables: module unloading, setting policy only for existing 
520   tables
521
522 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
523 - IPTABLES_SAVE_COUNTER defaults to no, now
524 - install config file in /etc/sysconfig
525 - exchange unload of ip_tables and ip_conntrack
526 - fixed start function
527
528 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
529 - new config option IPTABLES_SAVE_ON_RESTART
530 - init script: new status, save and restart
531 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
532
533 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
534 - new config option IPTABLES_STATUS_NUMERIC
535 - cleared IPTABLES_MODULES in iptables-config
536
537 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
538 - new init scripts
539
540 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
541 - remove check for very old kernel versions in init scripts
542 - sync up both init scripts and remove some further ugly things
543 - add some docu into rpm
544
545 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
546 - rebuild
547
548 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
549 - update to 1.2.8
550
551 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
552 - rebuilt
553
554 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
555 - update to 1.2.7a
556 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
557
558 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
559 - Fix multilib
560
561 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
562 - fixed iptables and ip6tables initscript output, based on #70511
563 - check return status of all iptables calls, not just the last one
564   in a 'for' loop.
565
566 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
567 - 1.2.6a (bugfix release, #69747)
568
569 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
570 - automated rebuild
571
572 * Thu May 23 2002 Tim Powers <timp@redhat.com>
573 - automated rebuild
574
575 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
576 - Add some fixes from CVS, fixing bug #60465
577
578 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
579 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
580   #59402
581 - Update URL (#59354)
582 - Use /sbin/chkconfig rather than chkconfig in %%postun script
583
584 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
585 - 1.2.5
586
587 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
588 - automated rebuild
589
590 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
591 - Fix %%preun script
592
593 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
594 - Update to 1.2.4 (various fixes, including security fixes; among others:
595   #42990, #50500, #53325, #54280)
596 - Fix init script (#31133)
597
598 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
599 - 1.2.3 (5 security fixes, some other fixes)
600 - Fix updating (#53032)
601
602 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
603 - Fix #50990
604 - Add some fixes from current CVS; should fix #52620
605
606 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
607 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
608   issues
609
610 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
611 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
612   <mschwendt@yahoo.com>
613
614 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
615 - 1.2.2
616
617 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
618 - 1.2.1a, fixes #28412, #31136, #31460, #31133
619
620 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
621 - Yet another initscript fix (#30173)
622 - Fix the fixes; they fixed some issues but broke more important
623   stuff :/ (#30176)
624
625 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
626 - Fix up initscript (#27962)
627 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
628
629 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
630 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
631
632 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
633 - fix bugzilla #25986 (initscript not marked as config file)
634 - fix bugzilla #25962 (iptables-restore)
635 - mv chkconfig --del from postun to preun
636
637 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
638 - Fix check for ipchains
639
640 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
641 - Some fixes to init scripts
642
643 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
644 - Add some fixes from CVS, fixes among other things Bug #24732
645
646 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
647 - Add missing man pages, fix up init script (Bug #17676)
648
649 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
650 - add init script
651
652 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
653 - 1.2
654 - fix up ipv6 split
655 - add init script
656 - Move the plugins from /usr/lib/iptables to /lib/iptables.
657   This needs to work before /usr is mounted...
658 - Use -O1 on alpha (compiler bug)
659
660 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
661 - 1.1.2
662 - Add IPv6 support (in separate package)
663
664 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
665 - build everywhere
666
667 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
668 - 1.1.1
669
670 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
671 - automatic rebuild
672
673 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
674 - move iptables to /sbin.
675 - excludearch alpha for now, not building there because of compiler bug(?)
676
677 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
678 - don't obsolete ipchains either
679 - update to 1.1.0
680
681 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
682 - remove explicit kernel requirement
683
684 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
685 - initial package