fix conflict
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 service iptables restart
121
122 %postun -p /sbin/ldconfig
123
124 %preun
125 if [ "$1" = 0 ]; then
126         /sbin/chkconfig --del iptables
127 fi
128
129 %post ipv6
130 /sbin/chkconfig --add ip6tables
131
132 %preun ipv6
133 if [ "$1" = 0 ]; then
134         /sbin/chkconfig --del ip6tables
135 fi
136
137 %files
138 %defattr(-,root,root)
139 %doc COPYING INSTALL INCOMPATIBILITIES
140 %attr(0755,root,root) /etc/rc.d/init.d/iptables
141 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
142 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
143 /sbin/iptables*
144 /bin/iptables-xml
145 %{_mandir}/man8/iptables*
146 %dir /%{_lib}/xtables
147 /%{_lib}/xtables/libipt*
148 /%{_lib}/xtables/libxt*
149 /%{_lib}/libip*tc.so.*
150 /%{_lib}/libipq.so.*
151 /%{_lib}/libxtables.so.*
152
153 %files ipv6
154 %defattr(-,root,root)
155 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
156 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
157 /sbin/ip6tables*
158 %{_mandir}/man8/ip6tables*
159 /%{_lib}/xtables/libip6t*
160
161 %files devel
162 %defattr(-,root,root)
163 %dir %{_includedir}/iptables
164 %{_includedir}/iptables/*.h
165 %{_includedir}/*.h
166 %dir %{_includedir}/libiptc
167 %{_includedir}/libiptc/*.h
168 %dir %{_includedir}/libipulog
169 %{_includedir}/libipulog/*.h
170 %{_mandir}/man3/*
171 /%{_lib}/libip*tc.so
172 /%{_lib}/libipq.so
173 /%{_lib}/libxtables.so
174 %{_libdir}/libip*tc.so
175 %{_libdir}/libipq.so
176 %{_libdir}/libxtables.so
177 %{_libdir}/pkgconfig/libiptc.pc
178 %{_libdir}/pkgconfig/xtables.pc
179
180 %changelog
181 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
182 - add requires initscripts in deps
183
184 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
185 - Restart iptables service after package upgrades
186
187 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
188 - Restore iIPTABLES_MODULES list
189
190 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
191 - drop backward compatibility with older iptables versions as new kernels only support v2
192 - remove unused modules from iptables-config file
193
194 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
195 - fixed specfile for duplicate URL
196
197 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
198 - added default values for IPTABLES_STATUS_VERBOSE and
199   IPTABLES_STATUS_LINENUMBERS in init script
200 - added missing lsb keywords Required-Start and Required-Stop to init script
201
202 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
203 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
204   - libip4tc: Add static qualifier to dump_entry()
205   - libipq: build as shared library
206   - recent: reorder cases in code (cosmetic cleanup)
207   - several man page and documentation fixes
208   - policy: fix error message showing wrong option
209   - includes: header updates
210   - Lift restrictions on interface names
211 - fixed license and moved iptables-xml into base package according to review
212
213 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
214 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
215   to /usr/lib[64] for compatibility (rhbz#558796)
216
217 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
218 - new version 1.4.6 with support for all new features of 2.6.32
219   - several man page fixes
220   - Support for nommu arches
221   - realm: remove static initializations
222   - libiptc: remove unused functions
223   - libiptc: avoid strict-aliasing warnings
224   - iprange: do accept non-ranges for xt_iprange v1
225   - iprange: warn on reverse range
226   - iprange: roll address parsing into a loop
227   - iprange: do accept non-ranges for xt_iprange v1 (log)
228   - iprange: warn on reverse range (log)
229   - libiptc: fix wrong maptype of base chain counters on restore
230   - iptables: fix undersized deletion mask creation
231   - style: reduce indent in xtables_check_inverse
232   - libxtables: hand argv to xtables_check_inverse
233   - iptables/extensions: make bundled options work again
234   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
235   - iptables: take masks into consideration for replace command
236   - doc: explain experienced --hitcount limit
237   - doc: name resolution clarification
238   - iptables: expose option to zero packet/byte counters for a specific rule
239   - build: restore --disable-ipv6 functionality on system w/o v6 headers
240   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
241   - DNAT: fix incorrect check during parsing
242   - extensions: add osf extension
243   - conntrack: fix --expires parsing
244
245 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
246 - dropped nf_ext_init remains from cloexec patch
247
248 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
249 - new version 1.4.5 with support for all new features of 2.6.31
250   - libxt_NFQUEUE: add new v1 version with queue-balance option
251   - xt_conntrack: revision 2 for enlarged state_mask member
252   - libxt_helper: fix invalid passed option to check_inverse
253   - libiptc: split v4 and v6
254   - extensions: collapse registration structures
255   - iptables: allow for parse-less extensions
256   - iptables: allow for help-less extensions
257   - extensions: remove empty help and parse functions
258   - xtables: add multi-registration functions
259   - extensions: collapse data variables to use multi-reg calls
260   - xtables: warn of missing version identifier in extensions
261   - multi binary: allow subcommand via argv[1]
262   - iptables: accept multiple IP address specifications for -s, -d
263   - several build fixes
264   - several man page fixes
265 - fixed two leaked file descriptors on sockets (rhbz#521397)
266
267 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
268 - new version 1.4.4 with support for all new features of 2.6.30
269   - several man page fixes
270   - iptables: replace open-coded sizeof by ARRAY_SIZE
271   - libip6t_policy: remove redundant functions
272   - policy: use direct xt_policy_info instead of ipt/ip6t
273   - policy: merge ipv6 and ipv4 variant
274   - extensions: add `cluster' match support
275   - extensions: add const qualifiers in print/save functions
276   - extensions: use NFPROTO_UNSPEC for .family field
277   - extensions: remove redundant casts
278   - iptables: close open file descriptors
279   - fix segfault if incorrect protocol name is used
280   - replace open-coded sizeof by ARRAY_SIZE
281   - do not include v4-only modules in ip6tables manpage
282   - use direct xt_policy_info instead of ipt/ip6t
283   - xtables: fix segfault if incorrect protocol name is used
284   - libxt_connlimit: initialize v6_mask
285   - SNAT/DNAT: add support for persistent multi-range NAT mappings
286
287 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
288 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
289
290 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
291 - new version 1.4.3.2
292 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
293
294 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
295 - new version 1.4.3.1
296   - libiptc is now shared
297   - supports all new features of the 2.6.29 kernel
298 - dropped typo_latter patch
299
300 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
301 - still more review fixes (rhbz#225906)
302   - consistent macro usage
303   - use sed instead of perl for rpath removal
304   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
305
306 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
307 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
308
309 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
310 - new version 1.4.2
311 - removed TOS value mask patch (upstream)
312 - more review fixes (rhbz#225906)
313 - install all header files (rhbz#462207)
314 - dropped nf_ext_init (rhbz#472548)
315
316 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
317 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
318 - two more cloexec fixes
319
320 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
321 - upstream bug fix release 1.4.1.1
322 - dropped extra patch for 1.4.1 - not needed anymore
323
324 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
325 - new version 1.4.1 with new build environment
326 - additional ipv6 network mask patch from Jan Engelhardt
327 - spec file cleanup
328 - removed old patches
329
330 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
331 - use normal kernel headers, not linux/compiler.h
332 - change BuildRequires: kernel-devel to kernel-headers
333 - We need to do this to be able to build for both sparcv9 and sparc64 
334   (there is no kernel-devel.sparcv9)
335
336 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
337 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
338
339 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
340 - use the kernel headers from the build tree for iptables for now to be able to 
341   compile this package, but this makes the package more kernel dependant
342 - use s6_addr32 instead of in6_u.u6_addr32
343
344 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
345 - Autorebuild for GCC 4.3
346
347 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
348 - new version 1.4.0
349 - fixed condrestart (rhbz#428148)
350 - report the module in rmmod_r if there is an error
351 - use nf_ext_init instead of my_init for extension constructors
352
353 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
354 - fixed leaked file descriptor before fork/exec (rhbz#312191)
355 - blacklisting is not working, use "install X /bin/(true|false)" test instead
356 - return private exit code 150 for disabled ipv6 support
357 - use script name for output messages
358
359 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
360 - fixed error code for stopping a already stopped firewall (rhbz#321751)
361 - moved blacklist test into start
362
363 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
364 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
365 - use simpler fix for (rhbz#295611)
366   Thanks to Linus Torvalds for the patch.
367
368 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
369 - fixed IPv6 reject type (rhbz#295181)
370 - fixed init script: start, stop and status
371 - support netfilter compiled into kernel in init script (rhbz#295611)
372 - dropped inversion for limit modules from man pages (rhbz#220780)
373 - fixed typo in ip6tables man page (rhbz#236185)
374
375 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
376 - do not depend on local_fs in lsb header - this delayes start after network
377 - fixed exit code for initscript usage
378
379 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
380 - do not use lock file for condrestart test
381
382 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
383 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
384 - provide iptc interface again, but unsupported (rhbz#216733)
385 - compile all extension, which are supported by the kernel-headers package
386 - review fixes (rhbz#225906)
387
388 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
389 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
390
391 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
392 - New version 1.3.8
393
394 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
395 - fix error when ipv6 support isn't loaded in the kernel (#236888)
396
397 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
398 - fixed installation of secmark modules
399
400 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
401 - new verison 1.3.7
402 - iptc is not a public interface and therefore not installed anymore
403 - dropped upstream secmark patch
404
405 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
406 - added secmark iptables patches (#201573)
407
408 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
409 - rebuild
410
411 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
412 - bump again for double-long bug on ppc(64)
413
414 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
415 - rebuilt for new gcc4.1 snapshot and glibc changes
416
417 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
418 - new version 1.3.5
419 - fixed init script to set policy for raw tables, too (#179094)
420
421 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
422 - added important iptables header files to devel package
423
424 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
425 - rebuilt
426
427 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
428 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
429   replace "_init" with "__attribute((constructor)) my_init"
430
431 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
432 - rebuild due to unresolved symbols in shared libraries
433
434 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
435 - new version 1.3.4
436 - dropped free_opts patch (upstream fixed)
437 - made libipq PIC (#158623)
438 - additional configuration options for iptables startup script (#172929)
439   Thanks to Jan Gruenwald for the patch
440 - spec file cleanup (dropped linux_header define and usage)
441
442 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
443 - new version 1.3.2 with additional patch for the misplaced free_opts call
444   from Marcus Sundberg
445
446 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
447 - new version 1.3.1
448
449 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
450 - Remove unnecessary explicit kernel dep (#146142)
451 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
452   for the patch
453 - Adapted iptables-config to reference to modprobe.conf (#150143)
454 - Remove misleading message (#140154): Thanks to Ulrich Drepper
455   for the patch
456
457 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
458 - new version 1.3.0
459
460 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
461 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
462
463 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
464 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
465 - modified config file to match this change and un-commented variables with
466   default values
467
468 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
469 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
470   for the patch
471
472 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
473 - fixed free bug in iptables (#128322)
474
475 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
476 - new version 1.2.11
477
478 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
479 - new version 1.2.10
480
481 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
482 - rebuilt
483
484 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
485 - rebuilt
486
487 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
488 - fixed iptables-restore -c fault if there are no counters (#116421)
489
490 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
491 - rebuilt
492
493 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
494 - Close File descriptors to prevent SELinux error message
495
496 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
497 - rebuild
498
499 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
500 - vew version 1.2.9
501 - new config options in ipXtables-config:
502   IPTABLES_MODULES_UNLOAD
503 - more documentation in ipXtables-config
504 - fix for netlink security issue in libipq (devel package)
505 - print fix for libipt_icmp (#109546)
506
507 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
508 - marked all messages in iptables init script for translation (#107462)
509 - enabled devel package (#105884, #106101)
510 - bumped build for fedora for libipt_recent.so (#106002)
511
512 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
513 - fixed lost udp port range in ip6tables-save (#104484)
514 - fixed non numeric multiport port output in ipXtables-savs
515
516 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
517 - do not link against -lnsl
518
519 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
520 - made variables in rmmod_r local
521
522 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
523 - fixed permission for init script
524
525 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
526 - fixed save when iptables file is missing and iptables-config permissions
527
528 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
529 - fixes for ip6tables: module unloading, setting policy only for existing 
530   tables
531
532 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
533 - IPTABLES_SAVE_COUNTER defaults to no, now
534 - install config file in /etc/sysconfig
535 - exchange unload of ip_tables and ip_conntrack
536 - fixed start function
537
538 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
539 - new config option IPTABLES_SAVE_ON_RESTART
540 - init script: new status, save and restart
541 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
542
543 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
544 - new config option IPTABLES_STATUS_NUMERIC
545 - cleared IPTABLES_MODULES in iptables-config
546
547 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
548 - new init scripts
549
550 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
551 - remove check for very old kernel versions in init scripts
552 - sync up both init scripts and remove some further ugly things
553 - add some docu into rpm
554
555 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
556 - rebuild
557
558 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
559 - update to 1.2.8
560
561 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
562 - rebuilt
563
564 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
565 - update to 1.2.7a
566 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
567
568 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
569 - Fix multilib
570
571 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
572 - fixed iptables and ip6tables initscript output, based on #70511
573 - check return status of all iptables calls, not just the last one
574   in a 'for' loop.
575
576 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
577 - 1.2.6a (bugfix release, #69747)
578
579 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
580 - automated rebuild
581
582 * Thu May 23 2002 Tim Powers <timp@redhat.com>
583 - automated rebuild
584
585 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
586 - Add some fixes from CVS, fixing bug #60465
587
588 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
589 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
590   #59402
591 - Update URL (#59354)
592 - Use /sbin/chkconfig rather than chkconfig in %%postun script
593
594 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
595 - 1.2.5
596
597 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
598 - automated rebuild
599
600 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
601 - Fix %%preun script
602
603 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
604 - Update to 1.2.4 (various fixes, including security fixes; among others:
605   #42990, #50500, #53325, #54280)
606 - Fix init script (#31133)
607
608 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
609 - 1.2.3 (5 security fixes, some other fixes)
610 - Fix updating (#53032)
611
612 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
613 - Fix #50990
614 - Add some fixes from current CVS; should fix #52620
615
616 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
617 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
618   issues
619
620 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
621 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
622   <mschwendt@yahoo.com>
623
624 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
625 - 1.2.2
626
627 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
628 - 1.2.1a, fixes #28412, #31136, #31460, #31133
629
630 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
631 - Yet another initscript fix (#30173)
632 - Fix the fixes; they fixed some issues but broke more important
633   stuff :/ (#30176)
634
635 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
636 - Fix up initscript (#27962)
637 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
638
639 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
640 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
641
642 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
643 - fix bugzilla #25986 (initscript not marked as config file)
644 - fix bugzilla #25962 (iptables-restore)
645 - mv chkconfig --del from postun to preun
646
647 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
648 - Fix check for ipchains
649
650 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
651 - Some fixes to init scripts
652
653 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
654 - Add some fixes from CVS, fixes among other things Bug #24732
655
656 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
657 - Add missing man pages, fix up init script (Bug #17676)
658
659 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
660 - add init script
661
662 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
663 - 1.2
664 - fix up ipv6 split
665 - add init script
666 - Move the plugins from /usr/lib/iptables to /lib/iptables.
667   This needs to work before /usr is mounted...
668 - Use -O1 on alpha (compiler bug)
669
670 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
671 - 1.1.2
672 - Add IPv6 support (in separate package)
673
674 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
675 - build everywhere
676
677 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
678 - 1.1.1
679
680 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
681 - automatic rebuild
682
683 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
684 - move iptables to /sbin.
685 - excludearch alpha for now, not building there because of compiler bug(?)
686
687 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
688 - don't obsolete ipchains either
689 - update to 1.1.0
690
691 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
692 - remove explicit kernel requirement
693
694 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
695 - initial package