include default rules
[iptables.git] / iptables.spec
1 Name: iptables
2 Summary: Tools for managing Linux kernel packet filtering capabilities
3 Version: 1.4.7
4 Release: 2%{?dist}
5 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
6 Source1: iptables.init
7 Source2: iptables-config
8 Source3: planetlab-config
9 Patch1: copy-xid.patch
10 Group: System Environment/Base
11 URL: http://www.netfilter.org/
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13 License: GPLv2
14 BuildRequires: libselinux-devel
15 BuildRequires: kernel-headers
16 Conflicts: kernel < 2.4.20
17 Requires(post): chkconfig
18 Requires(preun): chkconfig
19
20 %description
21 The iptables utility controls the network packet filtering code in the
22 Linux kernel. If you need to set up firewalls and/or IP masquerading,
23 you should install this package.
24
25 %package ipv6
26 Summary: IPv6 support for iptables
27 Group: System Environment/Base
28 Requires: %{name} = %{version}-%{release}
29 Requires(post): chkconfig
30 Requires(preun): chkconfig
31
32 %description ipv6
33 The iptables package contains IPv6 (the next version of the IP
34 protocol) support for iptables. Iptables controls the Linux kernel
35 network packet filtering code, allowing you to set up firewalls and IP
36 masquerading. 
37
38 Install iptables-ipv6 if you need to set up firewalling for your
39 network and you are using ipv6.
40
41 %package devel
42 Summary: Development package for iptables
43 Group: System Environment/Base
44 Requires: %{name} = %{version}-%{release}
45 Requires: pkgconfig
46
47 %description devel
48 iptables development headers and libraries.
49
50 The iptc interface is upstream marked as not public. The interface is not 
51 stable and may change with every new version. It is therefore unsupported.
52
53 %prep
54 %setup -q
55 %patch1 -p1 
56
57 %build
58 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
59 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
60
61 # do not use rpath
62 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
63 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
64
65 make
66
67 %install
68 rm -rf %{buildroot}
69
70 make install DESTDIR=%{buildroot} 
71 # remove la file(s)
72 rm -f %{buildroot}/%{_lib}/*.la
73
74 # install ip*tables.h header files
75 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
76 install -d -m 755 %{buildroot}%{_includedir}/iptables
77 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
78
79 # install ipulog header file
80 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
81 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
82
83 # create symlinks for devel so libs
84 install -d -m 755 %{buildroot}%{_libdir}
85 for i in %{buildroot}/%{_lib}/*.so; do
86     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
87 done
88
89 # move pkgconfig to %{_libdir}
90 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
91
92 # install init scripts and configuration files
93 install -d -m 755 %{buildroot}/etc/rc.d/init.d
94 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
95 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
96 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
97 install -d -m 755 %{buildroot}/etc/sysconfig
98 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
99 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
100 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
101 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
102
103 %clean
104 rm -rf %{buildroot}
105
106 %post
107 /sbin/ldconfig
108 /sbin/chkconfig --add iptables
109
110 %postun -p /sbin/ldconfig
111
112 %preun
113 if [ "$1" = 0 ]; then
114         /sbin/chkconfig --del iptables
115 fi
116
117 %post ipv6
118 /sbin/chkconfig --add ip6tables
119
120 %preun ipv6
121 if [ "$1" = 0 ]; then
122         /sbin/chkconfig --del ip6tables
123 fi
124
125 %files
126 %defattr(-,root,root)
127 %doc COPYING INSTALL INCOMPATIBILITIES
128 %attr(0755,root,root) /etc/rc.d/init.d/iptables
129 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
130 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
131 /sbin/iptables*
132 /bin/iptables-xml
133 %{_mandir}/man8/iptables*
134 %dir /%{_lib}/xtables
135 /%{_lib}/xtables/libipt*
136 /%{_lib}/xtables/libxt*
137 /%{_lib}/libip*tc.so.*
138 /%{_lib}/libipq.so.*
139 /%{_lib}/libxtables.so.*
140
141 %files ipv6
142 %defattr(-,root,root)
143 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
144 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
145 /sbin/ip6tables*
146 %{_mandir}/man8/ip6tables*
147 /%{_lib}/xtables/libip6t*
148
149 %files devel
150 %defattr(-,root,root)
151 %dir %{_includedir}/iptables
152 %{_includedir}/iptables/*.h
153 %{_includedir}/*.h
154 %dir %{_includedir}/libiptc
155 %{_includedir}/libiptc/*.h
156 %dir %{_includedir}/libipulog
157 %{_includedir}/libipulog/*.h
158 %{_mandir}/man3/*
159 /%{_lib}/libip*tc.so
160 /%{_lib}/libipq.so
161 /%{_lib}/libxtables.so
162 %{_libdir}/libip*tc.so
163 %{_libdir}/libipq.so
164 %{_libdir}/libxtables.so
165 %{_libdir}/pkgconfig/libiptc.pc
166 %{_libdir}/pkgconfig/xtables.pc
167
168 %changelog
169 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
170 - added default values for IPTABLES_STATUS_VERBOSE and
171   IPTABLES_STATUS_LINENUMBERS in init script
172 - added missing lsb keywords Required-Start and Required-Stop to init script
173
174 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
175 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
176   - libip4tc: Add static qualifier to dump_entry()
177   - libipq: build as shared library
178   - recent: reorder cases in code (cosmetic cleanup)
179   - several man page and documentation fixes
180   - policy: fix error message showing wrong option
181   - includes: header updates
182   - Lift restrictions on interface names
183 - fixed license and moved iptables-xml into base package according to review
184
185 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
186 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
187   to /usr/lib[64] for compatibility (rhbz#558796)
188
189 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
190 - new version 1.4.6 with support for all new features of 2.6.32
191   - several man page fixes
192   - Support for nommu arches
193   - realm: remove static initializations
194   - libiptc: remove unused functions
195   - libiptc: avoid strict-aliasing warnings
196   - iprange: do accept non-ranges for xt_iprange v1
197   - iprange: warn on reverse range
198   - iprange: roll address parsing into a loop
199   - iprange: do accept non-ranges for xt_iprange v1 (log)
200   - iprange: warn on reverse range (log)
201   - libiptc: fix wrong maptype of base chain counters on restore
202   - iptables: fix undersized deletion mask creation
203   - style: reduce indent in xtables_check_inverse
204   - libxtables: hand argv to xtables_check_inverse
205   - iptables/extensions: make bundled options work again
206   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
207   - iptables: take masks into consideration for replace command
208   - doc: explain experienced --hitcount limit
209   - doc: name resolution clarification
210   - iptables: expose option to zero packet/byte counters for a specific rule
211   - build: restore --disable-ipv6 functionality on system w/o v6 headers
212   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
213   - DNAT: fix incorrect check during parsing
214   - extensions: add osf extension
215   - conntrack: fix --expires parsing
216
217 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
218 - dropped nf_ext_init remains from cloexec patch
219
220 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
221 - new version 1.4.5 with support for all new features of 2.6.31
222   - libxt_NFQUEUE: add new v1 version with queue-balance option
223   - xt_conntrack: revision 2 for enlarged state_mask member
224   - libxt_helper: fix invalid passed option to check_inverse
225   - libiptc: split v4 and v6
226   - extensions: collapse registration structures
227   - iptables: allow for parse-less extensions
228   - iptables: allow for help-less extensions
229   - extensions: remove empty help and parse functions
230   - xtables: add multi-registration functions
231   - extensions: collapse data variables to use multi-reg calls
232   - xtables: warn of missing version identifier in extensions
233   - multi binary: allow subcommand via argv[1]
234   - iptables: accept multiple IP address specifications for -s, -d
235   - several build fixes
236   - several man page fixes
237 - fixed two leaked file descriptors on sockets (rhbz#521397)
238
239 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
240 - new version 1.4.4 with support for all new features of 2.6.30
241   - several man page fixes
242   - iptables: replace open-coded sizeof by ARRAY_SIZE
243   - libip6t_policy: remove redundant functions
244   - policy: use direct xt_policy_info instead of ipt/ip6t
245   - policy: merge ipv6 and ipv4 variant
246   - extensions: add `cluster' match support
247   - extensions: add const qualifiers in print/save functions
248   - extensions: use NFPROTO_UNSPEC for .family field
249   - extensions: remove redundant casts
250   - iptables: close open file descriptors
251   - fix segfault if incorrect protocol name is used
252   - replace open-coded sizeof by ARRAY_SIZE
253   - do not include v4-only modules in ip6tables manpage
254   - use direct xt_policy_info instead of ipt/ip6t
255   - xtables: fix segfault if incorrect protocol name is used
256   - libxt_connlimit: initialize v6_mask
257   - SNAT/DNAT: add support for persistent multi-range NAT mappings
258
259 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
260 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
261
262 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
263 - new version 1.4.3.2
264 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
265
266 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
267 - new version 1.4.3.1
268   - libiptc is now shared
269   - supports all new features of the 2.6.29 kernel
270 - dropped typo_latter patch
271
272 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
273 - still more review fixes (rhbz#225906)
274   - consistent macro usage
275   - use sed instead of perl for rpath removal
276   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
277
278 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
279 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
280
281 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
282 - new version 1.4.2
283 - removed TOS value mask patch (upstream)
284 - more review fixes (rhbz#225906)
285 - install all header files (rhbz#462207)
286 - dropped nf_ext_init (rhbz#472548)
287
288 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
289 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
290 - two more cloexec fixes
291
292 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
293 - upstream bug fix release 1.4.1.1
294 - dropped extra patch for 1.4.1 - not needed anymore
295
296 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
297 - new version 1.4.1 with new build environment
298 - additional ipv6 network mask patch from Jan Engelhardt
299 - spec file cleanup
300 - removed old patches
301
302 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
303 - use normal kernel headers, not linux/compiler.h
304 - change BuildRequires: kernel-devel to kernel-headers
305 - We need to do this to be able to build for both sparcv9 and sparc64 
306   (there is no kernel-devel.sparcv9)
307
308 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
309 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
310
311 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
312 - use the kernel headers from the build tree for iptables for now to be able to 
313   compile this package, but this makes the package more kernel dependant
314 - use s6_addr32 instead of in6_u.u6_addr32
315
316 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
317 - Autorebuild for GCC 4.3
318
319 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
320 - new version 1.4.0
321 - fixed condrestart (rhbz#428148)
322 - report the module in rmmod_r if there is an error
323 - use nf_ext_init instead of my_init for extension constructors
324
325 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
326 - fixed leaked file descriptor before fork/exec (rhbz#312191)
327 - blacklisting is not working, use "install X /bin/(true|false)" test instead
328 - return private exit code 150 for disabled ipv6 support
329 - use script name for output messages
330
331 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
332 - fixed error code for stopping a already stopped firewall (rhbz#321751)
333 - moved blacklist test into start
334
335 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
336 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
337 - use simpler fix for (rhbz#295611)
338   Thanks to Linus Torvalds for the patch.
339
340 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
341 - fixed IPv6 reject type (rhbz#295181)
342 - fixed init script: start, stop and status
343 - support netfilter compiled into kernel in init script (rhbz#295611)
344 - dropped inversion for limit modules from man pages (rhbz#220780)
345 - fixed typo in ip6tables man page (rhbz#236185)
346
347 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
348 - do not depend on local_fs in lsb header - this delayes start after network
349 - fixed exit code for initscript usage
350
351 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
352 - do not use lock file for condrestart test
353
354 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
355 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
356 - provide iptc interface again, but unsupported (rhbz#216733)
357 - compile all extension, which are supported by the kernel-headers package
358 - review fixes (rhbz#225906)
359
360 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
361 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
362
363 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
364 - New version 1.3.8
365
366 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
367 - fix error when ipv6 support isn't loaded in the kernel (#236888)
368
369 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
370 - fixed installation of secmark modules
371
372 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
373 - new verison 1.3.7
374 - iptc is not a public interface and therefore not installed anymore
375 - dropped upstream secmark patch
376
377 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
378 - added secmark iptables patches (#201573)
379
380 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
381 - rebuild
382
383 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
384 - bump again for double-long bug on ppc(64)
385
386 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
387 - rebuilt for new gcc4.1 snapshot and glibc changes
388
389 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
390 - new version 1.3.5
391 - fixed init script to set policy for raw tables, too (#179094)
392
393 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
394 - added important iptables header files to devel package
395
396 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
397 - rebuilt
398
399 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
400 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
401   replace "_init" with "__attribute((constructor)) my_init"
402
403 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
404 - rebuild due to unresolved symbols in shared libraries
405
406 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
407 - new version 1.3.4
408 - dropped free_opts patch (upstream fixed)
409 - made libipq PIC (#158623)
410 - additional configuration options for iptables startup script (#172929)
411   Thanks to Jan Gruenwald for the patch
412 - spec file cleanup (dropped linux_header define and usage)
413
414 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
415 - new version 1.3.2 with additional patch for the misplaced free_opts call
416   from Marcus Sundberg
417
418 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
419 - new version 1.3.1
420
421 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
422 - Remove unnecessary explicit kernel dep (#146142)
423 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
424   for the patch
425 - Adapted iptables-config to reference to modprobe.conf (#150143)
426 - Remove misleading message (#140154): Thanks to Ulrich Drepper
427   for the patch
428
429 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
430 - new version 1.3.0
431
432 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
433 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
434
435 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
436 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
437 - modified config file to match this change and un-commented variables with
438   default values
439
440 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
441 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
442   for the patch
443
444 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
445 - fixed free bug in iptables (#128322)
446
447 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
448 - new version 1.2.11
449
450 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
451 - new version 1.2.10
452
453 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
454 - rebuilt
455
456 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
457 - rebuilt
458
459 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
460 - fixed iptables-restore -c fault if there are no counters (#116421)
461
462 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
463 - rebuilt
464
465 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
466 - Close File descriptors to prevent SELinux error message
467
468 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
469 - rebuild
470
471 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
472 - vew version 1.2.9
473 - new config options in ipXtables-config:
474   IPTABLES_MODULES_UNLOAD
475 - more documentation in ipXtables-config
476 - fix for netlink security issue in libipq (devel package)
477 - print fix for libipt_icmp (#109546)
478
479 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
480 - marked all messages in iptables init script for translation (#107462)
481 - enabled devel package (#105884, #106101)
482 - bumped build for fedora for libipt_recent.so (#106002)
483
484 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
485 - fixed lost udp port range in ip6tables-save (#104484)
486 - fixed non numeric multiport port output in ipXtables-savs
487
488 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
489 - do not link against -lnsl
490
491 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
492 - made variables in rmmod_r local
493
494 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
495 - fixed permission for init script
496
497 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
498 - fixed save when iptables file is missing and iptables-config permissions
499
500 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
501 - fixes for ip6tables: module unloading, setting policy only for existing 
502   tables
503
504 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
505 - IPTABLES_SAVE_COUNTER defaults to no, now
506 - install config file in /etc/sysconfig
507 - exchange unload of ip_tables and ip_conntrack
508 - fixed start function
509
510 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
511 - new config option IPTABLES_SAVE_ON_RESTART
512 - init script: new status, save and restart
513 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
514
515 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
516 - new config option IPTABLES_STATUS_NUMERIC
517 - cleared IPTABLES_MODULES in iptables-config
518
519 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
520 - new init scripts
521
522 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
523 - remove check for very old kernel versions in init scripts
524 - sync up both init scripts and remove some further ugly things
525 - add some docu into rpm
526
527 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
528 - rebuild
529
530 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
531 - update to 1.2.8
532
533 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
534 - rebuilt
535
536 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
537 - update to 1.2.7a
538 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
539
540 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
541 - Fix multilib
542
543 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
544 - fixed iptables and ip6tables initscript output, based on #70511
545 - check return status of all iptables calls, not just the last one
546   in a 'for' loop.
547
548 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
549 - 1.2.6a (bugfix release, #69747)
550
551 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
552 - automated rebuild
553
554 * Thu May 23 2002 Tim Powers <timp@redhat.com>
555 - automated rebuild
556
557 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
558 - Add some fixes from CVS, fixing bug #60465
559
560 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
561 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
562   #59402
563 - Update URL (#59354)
564 - Use /sbin/chkconfig rather than chkconfig in %%postun script
565
566 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
567 - 1.2.5
568
569 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
570 - automated rebuild
571
572 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
573 - Fix %%preun script
574
575 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
576 - Update to 1.2.4 (various fixes, including security fixes; among others:
577   #42990, #50500, #53325, #54280)
578 - Fix init script (#31133)
579
580 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
581 - 1.2.3 (5 security fixes, some other fixes)
582 - Fix updating (#53032)
583
584 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
585 - Fix #50990
586 - Add some fixes from current CVS; should fix #52620
587
588 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
589 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
590   issues
591
592 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
593 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
594   <mschwendt@yahoo.com>
595
596 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
597 - 1.2.2
598
599 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
600 - 1.2.1a, fixes #28412, #31136, #31460, #31133
601
602 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
603 - Yet another initscript fix (#30173)
604 - Fix the fixes; they fixed some issues but broke more important
605   stuff :/ (#30176)
606
607 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
608 - Fix up initscript (#27962)
609 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
610
611 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
612 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
613
614 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
615 - fix bugzilla #25986 (initscript not marked as config file)
616 - fix bugzilla #25962 (iptables-restore)
617 - mv chkconfig --del from postun to preun
618
619 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
620 - Fix check for ipchains
621
622 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
623 - Some fixes to init scripts
624
625 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
626 - Add some fixes from CVS, fixes among other things Bug #24732
627
628 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
629 - Add missing man pages, fix up init script (Bug #17676)
630
631 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
632 - add init script
633
634 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
635 - 1.2
636 - fix up ipv6 split
637 - add init script
638 - Move the plugins from /usr/lib/iptables to /lib/iptables.
639   This needs to work before /usr is mounted...
640 - Use -O1 on alpha (compiler bug)
641
642 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
643 - 1.1.2
644 - Add IPv6 support (in separate package)
645
646 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
647 - build everywhere
648
649 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
650 - 1.1.1
651
652 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
653 - automatic rebuild
654
655 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
656 - move iptables to /sbin.
657 - excludearch alpha for now, not building there because of compiler bug(?)
658
659 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
660 - don't obsolete ipchains either
661 - update to 1.1.0
662
663 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
664 - remove explicit kernel requirement
665
666 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
667 - initial package