Setting tag iptables-1.4.10-2
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 service iptables restart
121
122 %postun -p /sbin/ldconfig
123
124 %preun
125 if [ "$1" = 0 ]; then
126         /sbin/chkconfig --del iptables
127 fi
128
129 %post ipv6
130 /sbin/chkconfig --add ip6tables
131
132 %preun ipv6
133 if [ "$1" = 0 ]; then
134         /sbin/chkconfig --del ip6tables
135 fi
136
137 %files
138 %defattr(-,root,root)
139 %doc COPYING INSTALL INCOMPATIBILITIES
140 %attr(0755,root,root) /etc/rc.d/init.d/iptables
141 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
142 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
143 /sbin/iptables*
144 /bin/iptables-xml
145 %{_mandir}/man8/iptables*
146 %dir /%{_lib}/xtables
147 /%{_lib}/xtables/libipt*
148 /%{_lib}/xtables/libxt*
149 /%{_lib}/libip*tc.so.*
150 /%{_lib}/libipq.so.*
151 /%{_lib}/libxtables.so.*
152
153 %files ipv6
154 %defattr(-,root,root)
155 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
156 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
157 /sbin/ip6tables*
158 %{_mandir}/man8/ip6tables*
159 /%{_lib}/xtables/libip6t*
160
161 %files devel
162 %defattr(-,root,root)
163 %dir %{_includedir}/iptables
164 %{_includedir}/iptables/*.h
165 %{_includedir}/*.h
166 %dir %{_includedir}/libiptc
167 %{_includedir}/libiptc/*.h
168 %dir %{_includedir}/libipulog
169 %{_includedir}/libipulog/*.h
170 %{_mandir}/man3/*
171 /%{_lib}/libip*tc.so
172 /%{_lib}/libipq.so
173 /%{_lib}/libxtables.so
174 %{_libdir}/libip*tc.so
175 %{_libdir}/libipq.so
176 %{_libdir}/libxtables.so
177 %{_libdir}/pkgconfig/libiptc.pc
178 %{_libdir}/pkgconfig/xtables.pc
179
180 %changelog
181 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
182 - Fix the patch
183
184 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
185 - Fix incorrect sha1sum
186
187 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
188 - add requires initscripts in deps
189
190 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
191 - Restart iptables service after package upgrades
192
193 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
194 - Restore iIPTABLES_MODULES list
195
196 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
197 - drop backward compatibility with older iptables versions as new kernels only support v2
198 - remove unused modules from iptables-config file
199
200 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
201 - fixed specfile for duplicate URL
202
203 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
204 - added default values for IPTABLES_STATUS_VERBOSE and
205   IPTABLES_STATUS_LINENUMBERS in init script
206 - added missing lsb keywords Required-Start and Required-Stop to init script
207
208 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
209 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
210   - libip4tc: Add static qualifier to dump_entry()
211   - libipq: build as shared library
212   - recent: reorder cases in code (cosmetic cleanup)
213   - several man page and documentation fixes
214   - policy: fix error message showing wrong option
215   - includes: header updates
216   - Lift restrictions on interface names
217 - fixed license and moved iptables-xml into base package according to review
218
219 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
220 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
221   to /usr/lib[64] for compatibility (rhbz#558796)
222
223 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
224 - new version 1.4.6 with support for all new features of 2.6.32
225   - several man page fixes
226   - Support for nommu arches
227   - realm: remove static initializations
228   - libiptc: remove unused functions
229   - libiptc: avoid strict-aliasing warnings
230   - iprange: do accept non-ranges for xt_iprange v1
231   - iprange: warn on reverse range
232   - iprange: roll address parsing into a loop
233   - iprange: do accept non-ranges for xt_iprange v1 (log)
234   - iprange: warn on reverse range (log)
235   - libiptc: fix wrong maptype of base chain counters on restore
236   - iptables: fix undersized deletion mask creation
237   - style: reduce indent in xtables_check_inverse
238   - libxtables: hand argv to xtables_check_inverse
239   - iptables/extensions: make bundled options work again
240   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
241   - iptables: take masks into consideration for replace command
242   - doc: explain experienced --hitcount limit
243   - doc: name resolution clarification
244   - iptables: expose option to zero packet/byte counters for a specific rule
245   - build: restore --disable-ipv6 functionality on system w/o v6 headers
246   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
247   - DNAT: fix incorrect check during parsing
248   - extensions: add osf extension
249   - conntrack: fix --expires parsing
250
251 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
252 - dropped nf_ext_init remains from cloexec patch
253
254 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
255 - new version 1.4.5 with support for all new features of 2.6.31
256   - libxt_NFQUEUE: add new v1 version with queue-balance option
257   - xt_conntrack: revision 2 for enlarged state_mask member
258   - libxt_helper: fix invalid passed option to check_inverse
259   - libiptc: split v4 and v6
260   - extensions: collapse registration structures
261   - iptables: allow for parse-less extensions
262   - iptables: allow for help-less extensions
263   - extensions: remove empty help and parse functions
264   - xtables: add multi-registration functions
265   - extensions: collapse data variables to use multi-reg calls
266   - xtables: warn of missing version identifier in extensions
267   - multi binary: allow subcommand via argv[1]
268   - iptables: accept multiple IP address specifications for -s, -d
269   - several build fixes
270   - several man page fixes
271 - fixed two leaked file descriptors on sockets (rhbz#521397)
272
273 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
274 - new version 1.4.4 with support for all new features of 2.6.30
275   - several man page fixes
276   - iptables: replace open-coded sizeof by ARRAY_SIZE
277   - libip6t_policy: remove redundant functions
278   - policy: use direct xt_policy_info instead of ipt/ip6t
279   - policy: merge ipv6 and ipv4 variant
280   - extensions: add `cluster' match support
281   - extensions: add const qualifiers in print/save functions
282   - extensions: use NFPROTO_UNSPEC for .family field
283   - extensions: remove redundant casts
284   - iptables: close open file descriptors
285   - fix segfault if incorrect protocol name is used
286   - replace open-coded sizeof by ARRAY_SIZE
287   - do not include v4-only modules in ip6tables manpage
288   - use direct xt_policy_info instead of ipt/ip6t
289   - xtables: fix segfault if incorrect protocol name is used
290   - libxt_connlimit: initialize v6_mask
291   - SNAT/DNAT: add support for persistent multi-range NAT mappings
292
293 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
294 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
295
296 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
297 - new version 1.4.3.2
298 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
299
300 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
301 - new version 1.4.3.1
302   - libiptc is now shared
303   - supports all new features of the 2.6.29 kernel
304 - dropped typo_latter patch
305
306 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
307 - still more review fixes (rhbz#225906)
308   - consistent macro usage
309   - use sed instead of perl for rpath removal
310   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
311
312 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
313 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
314
315 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
316 - new version 1.4.2
317 - removed TOS value mask patch (upstream)
318 - more review fixes (rhbz#225906)
319 - install all header files (rhbz#462207)
320 - dropped nf_ext_init (rhbz#472548)
321
322 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
323 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
324 - two more cloexec fixes
325
326 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
327 - upstream bug fix release 1.4.1.1
328 - dropped extra patch for 1.4.1 - not needed anymore
329
330 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
331 - new version 1.4.1 with new build environment
332 - additional ipv6 network mask patch from Jan Engelhardt
333 - spec file cleanup
334 - removed old patches
335
336 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
337 - use normal kernel headers, not linux/compiler.h
338 - change BuildRequires: kernel-devel to kernel-headers
339 - We need to do this to be able to build for both sparcv9 and sparc64 
340   (there is no kernel-devel.sparcv9)
341
342 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
343 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
344
345 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
346 - use the kernel headers from the build tree for iptables for now to be able to 
347   compile this package, but this makes the package more kernel dependant
348 - use s6_addr32 instead of in6_u.u6_addr32
349
350 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
351 - Autorebuild for GCC 4.3
352
353 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
354 - new version 1.4.0
355 - fixed condrestart (rhbz#428148)
356 - report the module in rmmod_r if there is an error
357 - use nf_ext_init instead of my_init for extension constructors
358
359 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
360 - fixed leaked file descriptor before fork/exec (rhbz#312191)
361 - blacklisting is not working, use "install X /bin/(true|false)" test instead
362 - return private exit code 150 for disabled ipv6 support
363 - use script name for output messages
364
365 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
366 - fixed error code for stopping a already stopped firewall (rhbz#321751)
367 - moved blacklist test into start
368
369 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
370 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
371 - use simpler fix for (rhbz#295611)
372   Thanks to Linus Torvalds for the patch.
373
374 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
375 - fixed IPv6 reject type (rhbz#295181)
376 - fixed init script: start, stop and status
377 - support netfilter compiled into kernel in init script (rhbz#295611)
378 - dropped inversion for limit modules from man pages (rhbz#220780)
379 - fixed typo in ip6tables man page (rhbz#236185)
380
381 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
382 - do not depend on local_fs in lsb header - this delayes start after network
383 - fixed exit code for initscript usage
384
385 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
386 - do not use lock file for condrestart test
387
388 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
389 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
390 - provide iptc interface again, but unsupported (rhbz#216733)
391 - compile all extension, which are supported by the kernel-headers package
392 - review fixes (rhbz#225906)
393
394 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
395 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
396
397 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
398 - New version 1.3.8
399
400 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
401 - fix error when ipv6 support isn't loaded in the kernel (#236888)
402
403 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
404 - fixed installation of secmark modules
405
406 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
407 - new verison 1.3.7
408 - iptc is not a public interface and therefore not installed anymore
409 - dropped upstream secmark patch
410
411 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
412 - added secmark iptables patches (#201573)
413
414 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
415 - rebuild
416
417 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
418 - bump again for double-long bug on ppc(64)
419
420 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
421 - rebuilt for new gcc4.1 snapshot and glibc changes
422
423 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
424 - new version 1.3.5
425 - fixed init script to set policy for raw tables, too (#179094)
426
427 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
428 - added important iptables header files to devel package
429
430 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
431 - rebuilt
432
433 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
434 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
435   replace "_init" with "__attribute((constructor)) my_init"
436
437 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
438 - rebuild due to unresolved symbols in shared libraries
439
440 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
441 - new version 1.3.4
442 - dropped free_opts patch (upstream fixed)
443 - made libipq PIC (#158623)
444 - additional configuration options for iptables startup script (#172929)
445   Thanks to Jan Gruenwald for the patch
446 - spec file cleanup (dropped linux_header define and usage)
447
448 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
449 - new version 1.3.2 with additional patch for the misplaced free_opts call
450   from Marcus Sundberg
451
452 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
453 - new version 1.3.1
454
455 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
456 - Remove unnecessary explicit kernel dep (#146142)
457 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
458   for the patch
459 - Adapted iptables-config to reference to modprobe.conf (#150143)
460 - Remove misleading message (#140154): Thanks to Ulrich Drepper
461   for the patch
462
463 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
464 - new version 1.3.0
465
466 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
467 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
468
469 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
470 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
471 - modified config file to match this change and un-commented variables with
472   default values
473
474 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
475 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
476   for the patch
477
478 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
479 - fixed free bug in iptables (#128322)
480
481 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
482 - new version 1.2.11
483
484 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
485 - new version 1.2.10
486
487 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
488 - rebuilt
489
490 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
491 - rebuilt
492
493 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
494 - fixed iptables-restore -c fault if there are no counters (#116421)
495
496 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
497 - rebuilt
498
499 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
500 - Close File descriptors to prevent SELinux error message
501
502 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
503 - rebuild
504
505 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
506 - vew version 1.2.9
507 - new config options in ipXtables-config:
508   IPTABLES_MODULES_UNLOAD
509 - more documentation in ipXtables-config
510 - fix for netlink security issue in libipq (devel package)
511 - print fix for libipt_icmp (#109546)
512
513 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
514 - marked all messages in iptables init script for translation (#107462)
515 - enabled devel package (#105884, #106101)
516 - bumped build for fedora for libipt_recent.so (#106002)
517
518 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
519 - fixed lost udp port range in ip6tables-save (#104484)
520 - fixed non numeric multiport port output in ipXtables-savs
521
522 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
523 - do not link against -lnsl
524
525 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
526 - made variables in rmmod_r local
527
528 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
529 - fixed permission for init script
530
531 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
532 - fixed save when iptables file is missing and iptables-config permissions
533
534 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
535 - fixes for ip6tables: module unloading, setting policy only for existing 
536   tables
537
538 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
539 - IPTABLES_SAVE_COUNTER defaults to no, now
540 - install config file in /etc/sysconfig
541 - exchange unload of ip_tables and ip_conntrack
542 - fixed start function
543
544 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
545 - new config option IPTABLES_SAVE_ON_RESTART
546 - init script: new status, save and restart
547 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
548
549 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
550 - new config option IPTABLES_STATUS_NUMERIC
551 - cleared IPTABLES_MODULES in iptables-config
552
553 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
554 - new init scripts
555
556 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
557 - remove check for very old kernel versions in init scripts
558 - sync up both init scripts and remove some further ugly things
559 - add some docu into rpm
560
561 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
562 - rebuild
563
564 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
565 - update to 1.2.8
566
567 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
568 - rebuilt
569
570 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
571 - update to 1.2.7a
572 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
573
574 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
575 - Fix multilib
576
577 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
578 - fixed iptables and ip6tables initscript output, based on #70511
579 - check return status of all iptables calls, not just the last one
580   in a 'for' loop.
581
582 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
583 - 1.2.6a (bugfix release, #69747)
584
585 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
586 - automated rebuild
587
588 * Thu May 23 2002 Tim Powers <timp@redhat.com>
589 - automated rebuild
590
591 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
592 - Add some fixes from CVS, fixing bug #60465
593
594 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
595 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
596   #59402
597 - Update URL (#59354)
598 - Use /sbin/chkconfig rather than chkconfig in %%postun script
599
600 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
601 - 1.2.5
602
603 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
604 - automated rebuild
605
606 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
607 - Fix %%preun script
608
609 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
610 - Update to 1.2.4 (various fixes, including security fixes; among others:
611   #42990, #50500, #53325, #54280)
612 - Fix init script (#31133)
613
614 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
615 - 1.2.3 (5 security fixes, some other fixes)
616 - Fix updating (#53032)
617
618 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
619 - Fix #50990
620 - Add some fixes from current CVS; should fix #52620
621
622 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
623 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
624   issues
625
626 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
627 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
628   <mschwendt@yahoo.com>
629
630 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
631 - 1.2.2
632
633 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
634 - 1.2.1a, fixes #28412, #31136, #31460, #31133
635
636 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
637 - Yet another initscript fix (#30173)
638 - Fix the fixes; they fixed some issues but broke more important
639   stuff :/ (#30176)
640
641 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
642 - Fix up initscript (#27962)
643 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
644
645 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
646 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
647
648 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
649 - fix bugzilla #25986 (initscript not marked as config file)
650 - fix bugzilla #25962 (iptables-restore)
651 - mv chkconfig --del from postun to preun
652
653 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
654 - Fix check for ipchains
655
656 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
657 - Some fixes to init scripts
658
659 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
660 - Add some fixes from CVS, fixes among other things Bug #24732
661
662 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
663 - Add missing man pages, fix up init script (Bug #17676)
664
665 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
666 - add init script
667
668 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
669 - 1.2
670 - fix up ipv6 split
671 - add init script
672 - Move the plugins from /usr/lib/iptables to /lib/iptables.
673   This needs to work before /usr is mounted...
674 - Use -O1 on alpha (compiler bug)
675
676 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
677 - 1.1.2
678 - Add IPv6 support (in separate package)
679
680 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
681 - build everywhere
682
683 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
684 - 1.1.1
685
686 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
687 - automatic rebuild
688
689 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
690 - move iptables to /sbin.
691 - excludearch alpha for now, not building there because of compiler bug(?)
692
693 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
694 - don't obsolete ipchains either
695 - update to 1.1.0
696
697 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
698 - remove explicit kernel requirement
699
700 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
701 - initial package