require 'service' as well as 'chkconfig'
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.9
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): service
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 service iptables restart
121
122 %postun -p /sbin/ldconfig
123
124 %preun
125 if [ "$1" = 0 ]; then
126         /sbin/chkconfig --del iptables
127 fi
128
129 %post ipv6
130 /sbin/chkconfig --add ip6tables
131
132 %preun ipv6
133 if [ "$1" = 0 ]; then
134         /sbin/chkconfig --del ip6tables
135 fi
136
137 %files
138 %defattr(-,root,root)
139 %doc COPYING INSTALL INCOMPATIBILITIES
140 %attr(0755,root,root) /etc/rc.d/init.d/iptables
141 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
142 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
143 /sbin/iptables*
144 /bin/iptables-xml
145 %{_mandir}/man8/iptables*
146 %dir /%{_lib}/xtables
147 /%{_lib}/xtables/libipt*
148 /%{_lib}/xtables/libxt*
149 /%{_lib}/libip*tc.so.*
150 /%{_lib}/libipq.so.*
151 /%{_lib}/libxtables.so.*
152
153 %files ipv6
154 %defattr(-,root,root)
155 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
156 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
157 /sbin/ip6tables*
158 %{_mandir}/man8/ip6tables*
159 /%{_lib}/xtables/libip6t*
160
161 %files devel
162 %defattr(-,root,root)
163 %dir %{_includedir}/iptables
164 %{_includedir}/iptables/*.h
165 %{_includedir}/*.h
166 %dir %{_includedir}/libiptc
167 %{_includedir}/libiptc/*.h
168 %dir %{_includedir}/libipulog
169 %{_includedir}/libipulog/*.h
170 %{_mandir}/man3/*
171 /%{_lib}/libip*tc.so
172 /%{_lib}/libipq.so
173 /%{_lib}/libxtables.so
174 %{_libdir}/libip*tc.so
175 %{_libdir}/libipq.so
176 %{_libdir}/libxtables.so
177 %{_libdir}/pkgconfig/libiptc.pc
178 %{_libdir}/pkgconfig/xtables.pc
179
180 %changelog
181 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
182 - Restart iptables service after package upgrades
183
184 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
185 - Restore iIPTABLES_MODULES list
186
187 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
188 - drop backward compatibility with older iptables versions as new kernels only support v2
189 - remove unused modules from iptables-config file
190
191 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
192 - fixed specfile for duplicate URL
193
194 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
195 - added default values for IPTABLES_STATUS_VERBOSE and
196   IPTABLES_STATUS_LINENUMBERS in init script
197 - added missing lsb keywords Required-Start and Required-Stop to init script
198
199 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
200 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
201   - libip4tc: Add static qualifier to dump_entry()
202   - libipq: build as shared library
203   - recent: reorder cases in code (cosmetic cleanup)
204   - several man page and documentation fixes
205   - policy: fix error message showing wrong option
206   - includes: header updates
207   - Lift restrictions on interface names
208 - fixed license and moved iptables-xml into base package according to review
209
210 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
211 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
212   to /usr/lib[64] for compatibility (rhbz#558796)
213
214 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
215 - new version 1.4.6 with support for all new features of 2.6.32
216   - several man page fixes
217   - Support for nommu arches
218   - realm: remove static initializations
219   - libiptc: remove unused functions
220   - libiptc: avoid strict-aliasing warnings
221   - iprange: do accept non-ranges for xt_iprange v1
222   - iprange: warn on reverse range
223   - iprange: roll address parsing into a loop
224   - iprange: do accept non-ranges for xt_iprange v1 (log)
225   - iprange: warn on reverse range (log)
226   - libiptc: fix wrong maptype of base chain counters on restore
227   - iptables: fix undersized deletion mask creation
228   - style: reduce indent in xtables_check_inverse
229   - libxtables: hand argv to xtables_check_inverse
230   - iptables/extensions: make bundled options work again
231   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
232   - iptables: take masks into consideration for replace command
233   - doc: explain experienced --hitcount limit
234   - doc: name resolution clarification
235   - iptables: expose option to zero packet/byte counters for a specific rule
236   - build: restore --disable-ipv6 functionality on system w/o v6 headers
237   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
238   - DNAT: fix incorrect check during parsing
239   - extensions: add osf extension
240   - conntrack: fix --expires parsing
241
242 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
243 - dropped nf_ext_init remains from cloexec patch
244
245 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
246 - new version 1.4.5 with support for all new features of 2.6.31
247   - libxt_NFQUEUE: add new v1 version with queue-balance option
248   - xt_conntrack: revision 2 for enlarged state_mask member
249   - libxt_helper: fix invalid passed option to check_inverse
250   - libiptc: split v4 and v6
251   - extensions: collapse registration structures
252   - iptables: allow for parse-less extensions
253   - iptables: allow for help-less extensions
254   - extensions: remove empty help and parse functions
255   - xtables: add multi-registration functions
256   - extensions: collapse data variables to use multi-reg calls
257   - xtables: warn of missing version identifier in extensions
258   - multi binary: allow subcommand via argv[1]
259   - iptables: accept multiple IP address specifications for -s, -d
260   - several build fixes
261   - several man page fixes
262 - fixed two leaked file descriptors on sockets (rhbz#521397)
263
264 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
265 - new version 1.4.4 with support for all new features of 2.6.30
266   - several man page fixes
267   - iptables: replace open-coded sizeof by ARRAY_SIZE
268   - libip6t_policy: remove redundant functions
269   - policy: use direct xt_policy_info instead of ipt/ip6t
270   - policy: merge ipv6 and ipv4 variant
271   - extensions: add `cluster' match support
272   - extensions: add const qualifiers in print/save functions
273   - extensions: use NFPROTO_UNSPEC for .family field
274   - extensions: remove redundant casts
275   - iptables: close open file descriptors
276   - fix segfault if incorrect protocol name is used
277   - replace open-coded sizeof by ARRAY_SIZE
278   - do not include v4-only modules in ip6tables manpage
279   - use direct xt_policy_info instead of ipt/ip6t
280   - xtables: fix segfault if incorrect protocol name is used
281   - libxt_connlimit: initialize v6_mask
282   - SNAT/DNAT: add support for persistent multi-range NAT mappings
283
284 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
285 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
286
287 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
288 - new version 1.4.3.2
289 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
290
291 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
292 - new version 1.4.3.1
293   - libiptc is now shared
294   - supports all new features of the 2.6.29 kernel
295 - dropped typo_latter patch
296
297 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
298 - still more review fixes (rhbz#225906)
299   - consistent macro usage
300   - use sed instead of perl for rpath removal
301   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
302
303 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
304 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
305
306 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
307 - new version 1.4.2
308 - removed TOS value mask patch (upstream)
309 - more review fixes (rhbz#225906)
310 - install all header files (rhbz#462207)
311 - dropped nf_ext_init (rhbz#472548)
312
313 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
314 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
315 - two more cloexec fixes
316
317 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
318 - upstream bug fix release 1.4.1.1
319 - dropped extra patch for 1.4.1 - not needed anymore
320
321 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
322 - new version 1.4.1 with new build environment
323 - additional ipv6 network mask patch from Jan Engelhardt
324 - spec file cleanup
325 - removed old patches
326
327 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
328 - use normal kernel headers, not linux/compiler.h
329 - change BuildRequires: kernel-devel to kernel-headers
330 - We need to do this to be able to build for both sparcv9 and sparc64 
331   (there is no kernel-devel.sparcv9)
332
333 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
334 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
335
336 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
337 - use the kernel headers from the build tree for iptables for now to be able to 
338   compile this package, but this makes the package more kernel dependant
339 - use s6_addr32 instead of in6_u.u6_addr32
340
341 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
342 - Autorebuild for GCC 4.3
343
344 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
345 - new version 1.4.0
346 - fixed condrestart (rhbz#428148)
347 - report the module in rmmod_r if there is an error
348 - use nf_ext_init instead of my_init for extension constructors
349
350 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
351 - fixed leaked file descriptor before fork/exec (rhbz#312191)
352 - blacklisting is not working, use "install X /bin/(true|false)" test instead
353 - return private exit code 150 for disabled ipv6 support
354 - use script name for output messages
355
356 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
357 - fixed error code for stopping a already stopped firewall (rhbz#321751)
358 - moved blacklist test into start
359
360 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
361 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
362 - use simpler fix for (rhbz#295611)
363   Thanks to Linus Torvalds for the patch.
364
365 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
366 - fixed IPv6 reject type (rhbz#295181)
367 - fixed init script: start, stop and status
368 - support netfilter compiled into kernel in init script (rhbz#295611)
369 - dropped inversion for limit modules from man pages (rhbz#220780)
370 - fixed typo in ip6tables man page (rhbz#236185)
371
372 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
373 - do not depend on local_fs in lsb header - this delayes start after network
374 - fixed exit code for initscript usage
375
376 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
377 - do not use lock file for condrestart test
378
379 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
380 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
381 - provide iptc interface again, but unsupported (rhbz#216733)
382 - compile all extension, which are supported by the kernel-headers package
383 - review fixes (rhbz#225906)
384
385 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
386 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
387
388 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
389 - New version 1.3.8
390
391 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
392 - fix error when ipv6 support isn't loaded in the kernel (#236888)
393
394 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
395 - fixed installation of secmark modules
396
397 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
398 - new verison 1.3.7
399 - iptc is not a public interface and therefore not installed anymore
400 - dropped upstream secmark patch
401
402 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
403 - added secmark iptables patches (#201573)
404
405 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
406 - rebuild
407
408 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
409 - bump again for double-long bug on ppc(64)
410
411 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
412 - rebuilt for new gcc4.1 snapshot and glibc changes
413
414 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
415 - new version 1.3.5
416 - fixed init script to set policy for raw tables, too (#179094)
417
418 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
419 - added important iptables header files to devel package
420
421 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
422 - rebuilt
423
424 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
425 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
426   replace "_init" with "__attribute((constructor)) my_init"
427
428 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
429 - rebuild due to unresolved symbols in shared libraries
430
431 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
432 - new version 1.3.4
433 - dropped free_opts patch (upstream fixed)
434 - made libipq PIC (#158623)
435 - additional configuration options for iptables startup script (#172929)
436   Thanks to Jan Gruenwald for the patch
437 - spec file cleanup (dropped linux_header define and usage)
438
439 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
440 - new version 1.3.2 with additional patch for the misplaced free_opts call
441   from Marcus Sundberg
442
443 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
444 - new version 1.3.1
445
446 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
447 - Remove unnecessary explicit kernel dep (#146142)
448 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
449   for the patch
450 - Adapted iptables-config to reference to modprobe.conf (#150143)
451 - Remove misleading message (#140154): Thanks to Ulrich Drepper
452   for the patch
453
454 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
455 - new version 1.3.0
456
457 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
458 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
459
460 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
461 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
462 - modified config file to match this change and un-commented variables with
463   default values
464
465 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
466 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
467   for the patch
468
469 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
470 - fixed free bug in iptables (#128322)
471
472 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
473 - new version 1.2.11
474
475 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
476 - new version 1.2.10
477
478 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
479 - rebuilt
480
481 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
482 - rebuilt
483
484 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
485 - fixed iptables-restore -c fault if there are no counters (#116421)
486
487 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
488 - rebuilt
489
490 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
491 - Close File descriptors to prevent SELinux error message
492
493 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
494 - rebuild
495
496 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
497 - vew version 1.2.9
498 - new config options in ipXtables-config:
499   IPTABLES_MODULES_UNLOAD
500 - more documentation in ipXtables-config
501 - fix for netlink security issue in libipq (devel package)
502 - print fix for libipt_icmp (#109546)
503
504 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
505 - marked all messages in iptables init script for translation (#107462)
506 - enabled devel package (#105884, #106101)
507 - bumped build for fedora for libipt_recent.so (#106002)
508
509 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
510 - fixed lost udp port range in ip6tables-save (#104484)
511 - fixed non numeric multiport port output in ipXtables-savs
512
513 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
514 - do not link against -lnsl
515
516 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
517 - made variables in rmmod_r local
518
519 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
520 - fixed permission for init script
521
522 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
523 - fixed save when iptables file is missing and iptables-config permissions
524
525 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
526 - fixes for ip6tables: module unloading, setting policy only for existing 
527   tables
528
529 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
530 - IPTABLES_SAVE_COUNTER defaults to no, now
531 - install config file in /etc/sysconfig
532 - exchange unload of ip_tables and ip_conntrack
533 - fixed start function
534
535 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
536 - new config option IPTABLES_SAVE_ON_RESTART
537 - init script: new status, save and restart
538 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
539
540 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
541 - new config option IPTABLES_STATUS_NUMERIC
542 - cleared IPTABLES_MODULES in iptables-config
543
544 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
545 - new init scripts
546
547 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
548 - remove check for very old kernel versions in init scripts
549 - sync up both init scripts and remove some further ugly things
550 - add some docu into rpm
551
552 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
553 - rebuild
554
555 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
556 - update to 1.2.8
557
558 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
559 - rebuilt
560
561 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
562 - update to 1.2.7a
563 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
564
565 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
566 - Fix multilib
567
568 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
569 - fixed iptables and ip6tables initscript output, based on #70511
570 - check return status of all iptables calls, not just the last one
571   in a 'for' loop.
572
573 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
574 - 1.2.6a (bugfix release, #69747)
575
576 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
577 - automated rebuild
578
579 * Thu May 23 2002 Tim Powers <timp@redhat.com>
580 - automated rebuild
581
582 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
583 - Add some fixes from CVS, fixing bug #60465
584
585 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
586 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
587   #59402
588 - Update URL (#59354)
589 - Use /sbin/chkconfig rather than chkconfig in %%postun script
590
591 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
592 - 1.2.5
593
594 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
595 - automated rebuild
596
597 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
598 - Fix %%preun script
599
600 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
601 - Update to 1.2.4 (various fixes, including security fixes; among others:
602   #42990, #50500, #53325, #54280)
603 - Fix init script (#31133)
604
605 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
606 - 1.2.3 (5 security fixes, some other fixes)
607 - Fix updating (#53032)
608
609 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
610 - Fix #50990
611 - Add some fixes from current CVS; should fix #52620
612
613 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
614 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
615   issues
616
617 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
618 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
619   <mschwendt@yahoo.com>
620
621 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
622 - 1.2.2
623
624 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
625 - 1.2.1a, fixes #28412, #31136, #31460, #31133
626
627 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
628 - Yet another initscript fix (#30173)
629 - Fix the fixes; they fixed some issues but broke more important
630   stuff :/ (#30176)
631
632 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
633 - Fix up initscript (#27962)
634 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
635
636 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
637 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
638
639 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
640 - fix bugzilla #25986 (initscript not marked as config file)
641 - fix bugzilla #25962 (iptables-restore)
642 - mv chkconfig --del from postun to preun
643
644 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
645 - Fix check for ipchains
646
647 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
648 - Some fixes to init scripts
649
650 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
651 - Add some fixes from CVS, fixes among other things Bug #24732
652
653 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
654 - Add missing man pages, fix up init script (Bug #17676)
655
656 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
657 - add init script
658
659 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
660 - 1.2
661 - fix up ipv6 split
662 - add init script
663 - Move the plugins from /usr/lib/iptables to /lib/iptables.
664   This needs to work before /usr is mounted...
665 - Use -O1 on alpha (compiler bug)
666
667 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
668 - 1.1.2
669 - Add IPv6 support (in separate package)
670
671 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
672 - build everywhere
673
674 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
675 - 1.1.1
676
677 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
678 - automatic rebuild
679
680 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
681 - move iptables to /sbin.
682 - excludearch alpha for now, not building there because of compiler bug(?)
683
684 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
685 - don't obsolete ipchains either
686 - update to 1.1.0
687
688 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
689 - remove explicit kernel requirement
690
691 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
692 - initial package