Revert "Temporary measure for blacklisting an abused node."
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
121 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
122 [ "$PL_BOOTCD" = "1" ] || service iptables restart
123
124 %postun -p /sbin/ldconfig
125
126 %preun
127 if [ "$1" = 0 ]; then
128         /sbin/chkconfig --del iptables
129 fi
130
131 %post ipv6
132 /sbin/chkconfig --add ip6tables
133
134 %preun ipv6
135 if [ "$1" = 0 ]; then
136         /sbin/chkconfig --del ip6tables
137 fi
138
139 %files
140 %defattr(-,root,root)
141 %doc COPYING INSTALL INCOMPATIBILITIES
142 %attr(0755,root,root) /etc/rc.d/init.d/iptables
143 %config %attr(0600,root,root) /etc/sysconfig/iptables-config
144 %config %attr(0600,root,root) /etc/sysconfig/iptables
145 /sbin/iptables*
146 /bin/iptables-xml
147 %{_mandir}/man8/iptables*
148 %dir /%{_lib}/xtables
149 /%{_lib}/xtables/libipt*
150 /%{_lib}/xtables/libxt*
151 /%{_lib}/libip*tc.so.*
152 /%{_lib}/libipq.so.*
153 /%{_lib}/libxtables.so.*
154
155 %files ipv6
156 %defattr(-,root,root)
157 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
158 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
159 /sbin/ip6tables*
160 %{_mandir}/man8/ip6tables*
161 /%{_lib}/xtables/libip6t*
162
163 %files devel
164 %defattr(-,root,root)
165 %dir %{_includedir}/iptables
166 %{_includedir}/iptables/*.h
167 %{_includedir}/*.h
168 %dir %{_includedir}/libiptc
169 %{_includedir}/libiptc/*.h
170 %dir %{_includedir}/libipulog
171 %{_includedir}/libipulog/*.h
172 %{_mandir}/man3/*
173 /%{_lib}/libip*tc.so
174 /%{_lib}/libipq.so
175 /%{_lib}/libxtables.so
176 %{_libdir}/libip*tc.so
177 %{_libdir}/libipq.so
178 %{_libdir}/libxtables.so
179 %{_libdir}/pkgconfig/libiptc.pc
180 %{_libdir}/pkgconfig/xtables.pc
181
182 %changelog
183 * Thu Mar 24 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-4
184 - Don't start iptables service on build time
185
186 * Wed Feb 23 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-3
187 - Remove ugly hack for config files
188
189 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
190 - Fix the patch
191
192 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
193 - Fix incorrect sha1sum
194
195 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
196 - add requires initscripts in deps
197
198 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
199 - Restart iptables service after package upgrades
200
201 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
202 - Restore iIPTABLES_MODULES list
203
204 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
205 - drop backward compatibility with older iptables versions as new kernels only support v2
206 - remove unused modules from iptables-config file
207
208 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
209 - fixed specfile for duplicate URL
210
211 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
212 - added default values for IPTABLES_STATUS_VERBOSE and
213   IPTABLES_STATUS_LINENUMBERS in init script
214 - added missing lsb keywords Required-Start and Required-Stop to init script
215
216 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
217 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
218   - libip4tc: Add static qualifier to dump_entry()
219   - libipq: build as shared library
220   - recent: reorder cases in code (cosmetic cleanup)
221   - several man page and documentation fixes
222   - policy: fix error message showing wrong option
223   - includes: header updates
224   - Lift restrictions on interface names
225 - fixed license and moved iptables-xml into base package according to review
226
227 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
228 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
229   to /usr/lib[64] for compatibility (rhbz#558796)
230
231 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
232 - new version 1.4.6 with support for all new features of 2.6.32
233   - several man page fixes
234   - Support for nommu arches
235   - realm: remove static initializations
236   - libiptc: remove unused functions
237   - libiptc: avoid strict-aliasing warnings
238   - iprange: do accept non-ranges for xt_iprange v1
239   - iprange: warn on reverse range
240   - iprange: roll address parsing into a loop
241   - iprange: do accept non-ranges for xt_iprange v1 (log)
242   - iprange: warn on reverse range (log)
243   - libiptc: fix wrong maptype of base chain counters on restore
244   - iptables: fix undersized deletion mask creation
245   - style: reduce indent in xtables_check_inverse
246   - libxtables: hand argv to xtables_check_inverse
247   - iptables/extensions: make bundled options work again
248   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
249   - iptables: take masks into consideration for replace command
250   - doc: explain experienced --hitcount limit
251   - doc: name resolution clarification
252   - iptables: expose option to zero packet/byte counters for a specific rule
253   - build: restore --disable-ipv6 functionality on system w/o v6 headers
254   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
255   - DNAT: fix incorrect check during parsing
256   - extensions: add osf extension
257   - conntrack: fix --expires parsing
258
259 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
260 - dropped nf_ext_init remains from cloexec patch
261
262 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
263 - new version 1.4.5 with support for all new features of 2.6.31
264   - libxt_NFQUEUE: add new v1 version with queue-balance option
265   - xt_conntrack: revision 2 for enlarged state_mask member
266   - libxt_helper: fix invalid passed option to check_inverse
267   - libiptc: split v4 and v6
268   - extensions: collapse registration structures
269   - iptables: allow for parse-less extensions
270   - iptables: allow for help-less extensions
271   - extensions: remove empty help and parse functions
272   - xtables: add multi-registration functions
273   - extensions: collapse data variables to use multi-reg calls
274   - xtables: warn of missing version identifier in extensions
275   - multi binary: allow subcommand via argv[1]
276   - iptables: accept multiple IP address specifications for -s, -d
277   - several build fixes
278   - several man page fixes
279 - fixed two leaked file descriptors on sockets (rhbz#521397)
280
281 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
282 - new version 1.4.4 with support for all new features of 2.6.30
283   - several man page fixes
284   - iptables: replace open-coded sizeof by ARRAY_SIZE
285   - libip6t_policy: remove redundant functions
286   - policy: use direct xt_policy_info instead of ipt/ip6t
287   - policy: merge ipv6 and ipv4 variant
288   - extensions: add `cluster' match support
289   - extensions: add const qualifiers in print/save functions
290   - extensions: use NFPROTO_UNSPEC for .family field
291   - extensions: remove redundant casts
292   - iptables: close open file descriptors
293   - fix segfault if incorrect protocol name is used
294   - replace open-coded sizeof by ARRAY_SIZE
295   - do not include v4-only modules in ip6tables manpage
296   - use direct xt_policy_info instead of ipt/ip6t
297   - xtables: fix segfault if incorrect protocol name is used
298   - libxt_connlimit: initialize v6_mask
299   - SNAT/DNAT: add support for persistent multi-range NAT mappings
300
301 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
302 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
303
304 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
305 - new version 1.4.3.2
306 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
307
308 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
309 - new version 1.4.3.1
310   - libiptc is now shared
311   - supports all new features of the 2.6.29 kernel
312 - dropped typo_latter patch
313
314 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
315 - still more review fixes (rhbz#225906)
316   - consistent macro usage
317   - use sed instead of perl for rpath removal
318   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
319
320 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
321 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
322
323 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
324 - new version 1.4.2
325 - removed TOS value mask patch (upstream)
326 - more review fixes (rhbz#225906)
327 - install all header files (rhbz#462207)
328 - dropped nf_ext_init (rhbz#472548)
329
330 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
331 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
332 - two more cloexec fixes
333
334 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
335 - upstream bug fix release 1.4.1.1
336 - dropped extra patch for 1.4.1 - not needed anymore
337
338 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
339 - new version 1.4.1 with new build environment
340 - additional ipv6 network mask patch from Jan Engelhardt
341 - spec file cleanup
342 - removed old patches
343
344 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
345 - use normal kernel headers, not linux/compiler.h
346 - change BuildRequires: kernel-devel to kernel-headers
347 - We need to do this to be able to build for both sparcv9 and sparc64 
348   (there is no kernel-devel.sparcv9)
349
350 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
351 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
352
353 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
354 - use the kernel headers from the build tree for iptables for now to be able to 
355   compile this package, but this makes the package more kernel dependant
356 - use s6_addr32 instead of in6_u.u6_addr32
357
358 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
359 - Autorebuild for GCC 4.3
360
361 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
362 - new version 1.4.0
363 - fixed condrestart (rhbz#428148)
364 - report the module in rmmod_r if there is an error
365 - use nf_ext_init instead of my_init for extension constructors
366
367 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
368 - fixed leaked file descriptor before fork/exec (rhbz#312191)
369 - blacklisting is not working, use "install X /bin/(true|false)" test instead
370 - return private exit code 150 for disabled ipv6 support
371 - use script name for output messages
372
373 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
374 - fixed error code for stopping a already stopped firewall (rhbz#321751)
375 - moved blacklist test into start
376
377 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
378 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
379 - use simpler fix for (rhbz#295611)
380   Thanks to Linus Torvalds for the patch.
381
382 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
383 - fixed IPv6 reject type (rhbz#295181)
384 - fixed init script: start, stop and status
385 - support netfilter compiled into kernel in init script (rhbz#295611)
386 - dropped inversion for limit modules from man pages (rhbz#220780)
387 - fixed typo in ip6tables man page (rhbz#236185)
388
389 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
390 - do not depend on local_fs in lsb header - this delayes start after network
391 - fixed exit code for initscript usage
392
393 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
394 - do not use lock file for condrestart test
395
396 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
397 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
398 - provide iptc interface again, but unsupported (rhbz#216733)
399 - compile all extension, which are supported by the kernel-headers package
400 - review fixes (rhbz#225906)
401
402 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
403 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
404
405 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
406 - New version 1.3.8
407
408 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
409 - fix error when ipv6 support isn't loaded in the kernel (#236888)
410
411 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
412 - fixed installation of secmark modules
413
414 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
415 - new verison 1.3.7
416 - iptc is not a public interface and therefore not installed anymore
417 - dropped upstream secmark patch
418
419 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
420 - added secmark iptables patches (#201573)
421
422 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
423 - rebuild
424
425 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
426 - bump again for double-long bug on ppc(64)
427
428 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
429 - rebuilt for new gcc4.1 snapshot and glibc changes
430
431 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
432 - new version 1.3.5
433 - fixed init script to set policy for raw tables, too (#179094)
434
435 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
436 - added important iptables header files to devel package
437
438 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
439 - rebuilt
440
441 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
442 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
443   replace "_init" with "__attribute((constructor)) my_init"
444
445 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
446 - rebuild due to unresolved symbols in shared libraries
447
448 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
449 - new version 1.3.4
450 - dropped free_opts patch (upstream fixed)
451 - made libipq PIC (#158623)
452 - additional configuration options for iptables startup script (#172929)
453   Thanks to Jan Gruenwald for the patch
454 - spec file cleanup (dropped linux_header define and usage)
455
456 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
457 - new version 1.3.2 with additional patch for the misplaced free_opts call
458   from Marcus Sundberg
459
460 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
461 - new version 1.3.1
462
463 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
464 - Remove unnecessary explicit kernel dep (#146142)
465 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
466   for the patch
467 - Adapted iptables-config to reference to modprobe.conf (#150143)
468 - Remove misleading message (#140154): Thanks to Ulrich Drepper
469   for the patch
470
471 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
472 - new version 1.3.0
473
474 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
475 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
476
477 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
478 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
479 - modified config file to match this change and un-commented variables with
480   default values
481
482 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
483 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
484   for the patch
485
486 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
487 - fixed free bug in iptables (#128322)
488
489 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
490 - new version 1.2.11
491
492 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
493 - new version 1.2.10
494
495 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
496 - rebuilt
497
498 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
499 - rebuilt
500
501 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
502 - fixed iptables-restore -c fault if there are no counters (#116421)
503
504 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
505 - rebuilt
506
507 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
508 - Close File descriptors to prevent SELinux error message
509
510 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
511 - rebuild
512
513 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
514 - vew version 1.2.9
515 - new config options in ipXtables-config:
516   IPTABLES_MODULES_UNLOAD
517 - more documentation in ipXtables-config
518 - fix for netlink security issue in libipq (devel package)
519 - print fix for libipt_icmp (#109546)
520
521 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
522 - marked all messages in iptables init script for translation (#107462)
523 - enabled devel package (#105884, #106101)
524 - bumped build for fedora for libipt_recent.so (#106002)
525
526 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
527 - fixed lost udp port range in ip6tables-save (#104484)
528 - fixed non numeric multiport port output in ipXtables-savs
529
530 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
531 - do not link against -lnsl
532
533 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
534 - made variables in rmmod_r local
535
536 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
537 - fixed permission for init script
538
539 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
540 - fixed save when iptables file is missing and iptables-config permissions
541
542 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
543 - fixes for ip6tables: module unloading, setting policy only for existing 
544   tables
545
546 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
547 - IPTABLES_SAVE_COUNTER defaults to no, now
548 - install config file in /etc/sysconfig
549 - exchange unload of ip_tables and ip_conntrack
550 - fixed start function
551
552 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
553 - new config option IPTABLES_SAVE_ON_RESTART
554 - init script: new status, save and restart
555 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
556
557 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
558 - new config option IPTABLES_STATUS_NUMERIC
559 - cleared IPTABLES_MODULES in iptables-config
560
561 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
562 - new init scripts
563
564 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
565 - remove check for very old kernel versions in init scripts
566 - sync up both init scripts and remove some further ugly things
567 - add some docu into rpm
568
569 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
570 - rebuild
571
572 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
573 - update to 1.2.8
574
575 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
576 - rebuilt
577
578 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
579 - update to 1.2.7a
580 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
581
582 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
583 - Fix multilib
584
585 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
586 - fixed iptables and ip6tables initscript output, based on #70511
587 - check return status of all iptables calls, not just the last one
588   in a 'for' loop.
589
590 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
591 - 1.2.6a (bugfix release, #69747)
592
593 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
594 - automated rebuild
595
596 * Thu May 23 2002 Tim Powers <timp@redhat.com>
597 - automated rebuild
598
599 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
600 - Add some fixes from CVS, fixing bug #60465
601
602 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
603 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
604   #59402
605 - Update URL (#59354)
606 - Use /sbin/chkconfig rather than chkconfig in %%postun script
607
608 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
609 - 1.2.5
610
611 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
612 - automated rebuild
613
614 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
615 - Fix %%preun script
616
617 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
618 - Update to 1.2.4 (various fixes, including security fixes; among others:
619   #42990, #50500, #53325, #54280)
620 - Fix init script (#31133)
621
622 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
623 - 1.2.3 (5 security fixes, some other fixes)
624 - Fix updating (#53032)
625
626 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
627 - Fix #50990
628 - Add some fixes from current CVS; should fix #52620
629
630 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
631 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
632   issues
633
634 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
635 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
636   <mschwendt@yahoo.com>
637
638 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
639 - 1.2.2
640
641 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
642 - 1.2.1a, fixes #28412, #31136, #31460, #31133
643
644 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
645 - Yet another initscript fix (#30173)
646 - Fix the fixes; they fixed some issues but broke more important
647   stuff :/ (#30176)
648
649 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
650 - Fix up initscript (#27962)
651 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
652
653 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
654 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
655
656 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
657 - fix bugzilla #25986 (initscript not marked as config file)
658 - fix bugzilla #25962 (iptables-restore)
659 - mv chkconfig --del from postun to preun
660
661 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
662 - Fix check for ipchains
663
664 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
665 - Some fixes to init scripts
666
667 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
668 - Add some fixes from CVS, fixes among other things Bug #24732
669
670 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
671 - Add missing man pages, fix up init script (Bug #17676)
672
673 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
674 - add init script
675
676 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
677 - 1.2
678 - fix up ipv6 split
679 - add init script
680 - Move the plugins from /usr/lib/iptables to /lib/iptables.
681   This needs to work before /usr is mounted...
682 - Use -O1 on alpha (compiler bug)
683
684 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
685 - 1.1.2
686 - Add IPv6 support (in separate package)
687
688 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
689 - build everywhere
690
691 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
692 - 1.1.1
693
694 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
695 - automatic rebuild
696
697 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
698 - move iptables to /sbin.
699 - excludearch alpha for now, not building there because of compiler bug(?)
700
701 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
702 - don't obsolete ipchains either
703 - update to 1.1.0
704
705 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
706 - remove explicit kernel requirement
707
708 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
709 - initial package