Setting tag iptables-1.4.10-3
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
121 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
122 service iptables restart
123
124 %postun -p /sbin/ldconfig
125
126 %preun
127 if [ "$1" = 0 ]; then
128         /sbin/chkconfig --del iptables
129 fi
130
131 %post ipv6
132 /sbin/chkconfig --add ip6tables
133
134 %preun ipv6
135 if [ "$1" = 0 ]; then
136         /sbin/chkconfig --del ip6tables
137 fi
138
139 %files
140 %defattr(-,root,root)
141 %doc COPYING INSTALL INCOMPATIBILITIES
142 %attr(0755,root,root) /etc/rc.d/init.d/iptables
143 %config %attr(0600,root,root) /etc/sysconfig/iptables-config
144 %config %attr(0600,root,root) /etc/sysconfig/iptables
145 /sbin/iptables*
146 /bin/iptables-xml
147 %{_mandir}/man8/iptables*
148 %dir /%{_lib}/xtables
149 /%{_lib}/xtables/libipt*
150 /%{_lib}/xtables/libxt*
151 /%{_lib}/libip*tc.so.*
152 /%{_lib}/libipq.so.*
153 /%{_lib}/libxtables.so.*
154
155 %files ipv6
156 %defattr(-,root,root)
157 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
158 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
159 /sbin/ip6tables*
160 %{_mandir}/man8/ip6tables*
161 /%{_lib}/xtables/libip6t*
162
163 %files devel
164 %defattr(-,root,root)
165 %dir %{_includedir}/iptables
166 %{_includedir}/iptables/*.h
167 %{_includedir}/*.h
168 %dir %{_includedir}/libiptc
169 %{_includedir}/libiptc/*.h
170 %dir %{_includedir}/libipulog
171 %{_includedir}/libipulog/*.h
172 %{_mandir}/man3/*
173 /%{_lib}/libip*tc.so
174 /%{_lib}/libipq.so
175 /%{_lib}/libxtables.so
176 %{_libdir}/libip*tc.so
177 %{_libdir}/libipq.so
178 %{_libdir}/libxtables.so
179 %{_libdir}/pkgconfig/libiptc.pc
180 %{_libdir}/pkgconfig/xtables.pc
181
182 %changelog
183 * Wed Feb 23 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-3
184 - Remove ugly hack for config files
185
186 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
187 - Fix the patch
188
189 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
190 - Fix incorrect sha1sum
191
192 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
193 - add requires initscripts in deps
194
195 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
196 - Restart iptables service after package upgrades
197
198 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
199 - Restore iIPTABLES_MODULES list
200
201 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
202 - drop backward compatibility with older iptables versions as new kernels only support v2
203 - remove unused modules from iptables-config file
204
205 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
206 - fixed specfile for duplicate URL
207
208 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
209 - added default values for IPTABLES_STATUS_VERBOSE and
210   IPTABLES_STATUS_LINENUMBERS in init script
211 - added missing lsb keywords Required-Start and Required-Stop to init script
212
213 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
214 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
215   - libip4tc: Add static qualifier to dump_entry()
216   - libipq: build as shared library
217   - recent: reorder cases in code (cosmetic cleanup)
218   - several man page and documentation fixes
219   - policy: fix error message showing wrong option
220   - includes: header updates
221   - Lift restrictions on interface names
222 - fixed license and moved iptables-xml into base package according to review
223
224 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
225 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
226   to /usr/lib[64] for compatibility (rhbz#558796)
227
228 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
229 - new version 1.4.6 with support for all new features of 2.6.32
230   - several man page fixes
231   - Support for nommu arches
232   - realm: remove static initializations
233   - libiptc: remove unused functions
234   - libiptc: avoid strict-aliasing warnings
235   - iprange: do accept non-ranges for xt_iprange v1
236   - iprange: warn on reverse range
237   - iprange: roll address parsing into a loop
238   - iprange: do accept non-ranges for xt_iprange v1 (log)
239   - iprange: warn on reverse range (log)
240   - libiptc: fix wrong maptype of base chain counters on restore
241   - iptables: fix undersized deletion mask creation
242   - style: reduce indent in xtables_check_inverse
243   - libxtables: hand argv to xtables_check_inverse
244   - iptables/extensions: make bundled options work again
245   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
246   - iptables: take masks into consideration for replace command
247   - doc: explain experienced --hitcount limit
248   - doc: name resolution clarification
249   - iptables: expose option to zero packet/byte counters for a specific rule
250   - build: restore --disable-ipv6 functionality on system w/o v6 headers
251   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
252   - DNAT: fix incorrect check during parsing
253   - extensions: add osf extension
254   - conntrack: fix --expires parsing
255
256 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
257 - dropped nf_ext_init remains from cloexec patch
258
259 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
260 - new version 1.4.5 with support for all new features of 2.6.31
261   - libxt_NFQUEUE: add new v1 version with queue-balance option
262   - xt_conntrack: revision 2 for enlarged state_mask member
263   - libxt_helper: fix invalid passed option to check_inverse
264   - libiptc: split v4 and v6
265   - extensions: collapse registration structures
266   - iptables: allow for parse-less extensions
267   - iptables: allow for help-less extensions
268   - extensions: remove empty help and parse functions
269   - xtables: add multi-registration functions
270   - extensions: collapse data variables to use multi-reg calls
271   - xtables: warn of missing version identifier in extensions
272   - multi binary: allow subcommand via argv[1]
273   - iptables: accept multiple IP address specifications for -s, -d
274   - several build fixes
275   - several man page fixes
276 - fixed two leaked file descriptors on sockets (rhbz#521397)
277
278 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
279 - new version 1.4.4 with support for all new features of 2.6.30
280   - several man page fixes
281   - iptables: replace open-coded sizeof by ARRAY_SIZE
282   - libip6t_policy: remove redundant functions
283   - policy: use direct xt_policy_info instead of ipt/ip6t
284   - policy: merge ipv6 and ipv4 variant
285   - extensions: add `cluster' match support
286   - extensions: add const qualifiers in print/save functions
287   - extensions: use NFPROTO_UNSPEC for .family field
288   - extensions: remove redundant casts
289   - iptables: close open file descriptors
290   - fix segfault if incorrect protocol name is used
291   - replace open-coded sizeof by ARRAY_SIZE
292   - do not include v4-only modules in ip6tables manpage
293   - use direct xt_policy_info instead of ipt/ip6t
294   - xtables: fix segfault if incorrect protocol name is used
295   - libxt_connlimit: initialize v6_mask
296   - SNAT/DNAT: add support for persistent multi-range NAT mappings
297
298 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
299 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
300
301 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
302 - new version 1.4.3.2
303 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
304
305 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
306 - new version 1.4.3.1
307   - libiptc is now shared
308   - supports all new features of the 2.6.29 kernel
309 - dropped typo_latter patch
310
311 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
312 - still more review fixes (rhbz#225906)
313   - consistent macro usage
314   - use sed instead of perl for rpath removal
315   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
316
317 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
318 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
319
320 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
321 - new version 1.4.2
322 - removed TOS value mask patch (upstream)
323 - more review fixes (rhbz#225906)
324 - install all header files (rhbz#462207)
325 - dropped nf_ext_init (rhbz#472548)
326
327 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
328 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
329 - two more cloexec fixes
330
331 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
332 - upstream bug fix release 1.4.1.1
333 - dropped extra patch for 1.4.1 - not needed anymore
334
335 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
336 - new version 1.4.1 with new build environment
337 - additional ipv6 network mask patch from Jan Engelhardt
338 - spec file cleanup
339 - removed old patches
340
341 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
342 - use normal kernel headers, not linux/compiler.h
343 - change BuildRequires: kernel-devel to kernel-headers
344 - We need to do this to be able to build for both sparcv9 and sparc64 
345   (there is no kernel-devel.sparcv9)
346
347 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
348 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
349
350 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
351 - use the kernel headers from the build tree for iptables for now to be able to 
352   compile this package, but this makes the package more kernel dependant
353 - use s6_addr32 instead of in6_u.u6_addr32
354
355 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
356 - Autorebuild for GCC 4.3
357
358 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
359 - new version 1.4.0
360 - fixed condrestart (rhbz#428148)
361 - report the module in rmmod_r if there is an error
362 - use nf_ext_init instead of my_init for extension constructors
363
364 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
365 - fixed leaked file descriptor before fork/exec (rhbz#312191)
366 - blacklisting is not working, use "install X /bin/(true|false)" test instead
367 - return private exit code 150 for disabled ipv6 support
368 - use script name for output messages
369
370 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
371 - fixed error code for stopping a already stopped firewall (rhbz#321751)
372 - moved blacklist test into start
373
374 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
375 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
376 - use simpler fix for (rhbz#295611)
377   Thanks to Linus Torvalds for the patch.
378
379 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
380 - fixed IPv6 reject type (rhbz#295181)
381 - fixed init script: start, stop and status
382 - support netfilter compiled into kernel in init script (rhbz#295611)
383 - dropped inversion for limit modules from man pages (rhbz#220780)
384 - fixed typo in ip6tables man page (rhbz#236185)
385
386 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
387 - do not depend on local_fs in lsb header - this delayes start after network
388 - fixed exit code for initscript usage
389
390 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
391 - do not use lock file for condrestart test
392
393 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
394 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
395 - provide iptc interface again, but unsupported (rhbz#216733)
396 - compile all extension, which are supported by the kernel-headers package
397 - review fixes (rhbz#225906)
398
399 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
400 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
401
402 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
403 - New version 1.3.8
404
405 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
406 - fix error when ipv6 support isn't loaded in the kernel (#236888)
407
408 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
409 - fixed installation of secmark modules
410
411 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
412 - new verison 1.3.7
413 - iptc is not a public interface and therefore not installed anymore
414 - dropped upstream secmark patch
415
416 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
417 - added secmark iptables patches (#201573)
418
419 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
420 - rebuild
421
422 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
423 - bump again for double-long bug on ppc(64)
424
425 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
426 - rebuilt for new gcc4.1 snapshot and glibc changes
427
428 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
429 - new version 1.3.5
430 - fixed init script to set policy for raw tables, too (#179094)
431
432 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
433 - added important iptables header files to devel package
434
435 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
436 - rebuilt
437
438 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
439 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
440   replace "_init" with "__attribute((constructor)) my_init"
441
442 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
443 - rebuild due to unresolved symbols in shared libraries
444
445 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
446 - new version 1.3.4
447 - dropped free_opts patch (upstream fixed)
448 - made libipq PIC (#158623)
449 - additional configuration options for iptables startup script (#172929)
450   Thanks to Jan Gruenwald for the patch
451 - spec file cleanup (dropped linux_header define and usage)
452
453 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
454 - new version 1.3.2 with additional patch for the misplaced free_opts call
455   from Marcus Sundberg
456
457 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
458 - new version 1.3.1
459
460 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
461 - Remove unnecessary explicit kernel dep (#146142)
462 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
463   for the patch
464 - Adapted iptables-config to reference to modprobe.conf (#150143)
465 - Remove misleading message (#140154): Thanks to Ulrich Drepper
466   for the patch
467
468 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
469 - new version 1.3.0
470
471 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
472 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
473
474 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
475 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
476 - modified config file to match this change and un-commented variables with
477   default values
478
479 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
480 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
481   for the patch
482
483 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
484 - fixed free bug in iptables (#128322)
485
486 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
487 - new version 1.2.11
488
489 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
490 - new version 1.2.10
491
492 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
493 - rebuilt
494
495 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
496 - rebuilt
497
498 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
499 - fixed iptables-restore -c fault if there are no counters (#116421)
500
501 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
502 - rebuilt
503
504 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
505 - Close File descriptors to prevent SELinux error message
506
507 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
508 - rebuild
509
510 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
511 - vew version 1.2.9
512 - new config options in ipXtables-config:
513   IPTABLES_MODULES_UNLOAD
514 - more documentation in ipXtables-config
515 - fix for netlink security issue in libipq (devel package)
516 - print fix for libipt_icmp (#109546)
517
518 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
519 - marked all messages in iptables init script for translation (#107462)
520 - enabled devel package (#105884, #106101)
521 - bumped build for fedora for libipt_recent.so (#106002)
522
523 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
524 - fixed lost udp port range in ip6tables-save (#104484)
525 - fixed non numeric multiport port output in ipXtables-savs
526
527 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
528 - do not link against -lnsl
529
530 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
531 - made variables in rmmod_r local
532
533 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
534 - fixed permission for init script
535
536 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
537 - fixed save when iptables file is missing and iptables-config permissions
538
539 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
540 - fixes for ip6tables: module unloading, setting policy only for existing 
541   tables
542
543 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
544 - IPTABLES_SAVE_COUNTER defaults to no, now
545 - install config file in /etc/sysconfig
546 - exchange unload of ip_tables and ip_conntrack
547 - fixed start function
548
549 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
550 - new config option IPTABLES_SAVE_ON_RESTART
551 - init script: new status, save and restart
552 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
553
554 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
555 - new config option IPTABLES_STATUS_NUMERIC
556 - cleared IPTABLES_MODULES in iptables-config
557
558 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
559 - new init scripts
560
561 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
562 - remove check for very old kernel versions in init scripts
563 - sync up both init scripts and remove some further ugly things
564 - add some docu into rpm
565
566 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
567 - rebuild
568
569 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
570 - update to 1.2.8
571
572 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
573 - rebuilt
574
575 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
576 - update to 1.2.7a
577 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
578
579 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
580 - Fix multilib
581
582 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
583 - fixed iptables and ip6tables initscript output, based on #70511
584 - check return status of all iptables calls, not just the last one
585   in a 'for' loop.
586
587 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
588 - 1.2.6a (bugfix release, #69747)
589
590 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
591 - automated rebuild
592
593 * Thu May 23 2002 Tim Powers <timp@redhat.com>
594 - automated rebuild
595
596 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
597 - Add some fixes from CVS, fixing bug #60465
598
599 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
600 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
601   #59402
602 - Update URL (#59354)
603 - Use /sbin/chkconfig rather than chkconfig in %%postun script
604
605 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
606 - 1.2.5
607
608 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
609 - automated rebuild
610
611 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
612 - Fix %%preun script
613
614 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
615 - Update to 1.2.4 (various fixes, including security fixes; among others:
616   #42990, #50500, #53325, #54280)
617 - Fix init script (#31133)
618
619 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
620 - 1.2.3 (5 security fixes, some other fixes)
621 - Fix updating (#53032)
622
623 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
624 - Fix #50990
625 - Add some fixes from current CVS; should fix #52620
626
627 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
628 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
629   issues
630
631 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
632 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
633   <mschwendt@yahoo.com>
634
635 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
636 - 1.2.2
637
638 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
639 - 1.2.1a, fixes #28412, #31136, #31460, #31133
640
641 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
642 - Yet another initscript fix (#30173)
643 - Fix the fixes; they fixed some issues but broke more important
644   stuff :/ (#30176)
645
646 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
647 - Fix up initscript (#27962)
648 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
649
650 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
651 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
652
653 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
654 - fix bugzilla #25986 (initscript not marked as config file)
655 - fix bugzilla #25962 (iptables-restore)
656 - mv chkconfig --del from postun to preun
657
658 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
659 - Fix check for ipchains
660
661 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
662 - Some fixes to init scripts
663
664 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
665 - Add some fixes from CVS, fixes among other things Bug #24732
666
667 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
668 - Add missing man pages, fix up init script (Bug #17676)
669
670 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
671 - add init script
672
673 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
674 - 1.2
675 - fix up ipv6 split
676 - add init script
677 - Move the plugins from /usr/lib/iptables to /lib/iptables.
678   This needs to work before /usr is mounted...
679 - Use -O1 on alpha (compiler bug)
680
681 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
682 - 1.1.2
683 - Add IPv6 support (in separate package)
684
685 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
686 - build everywhere
687
688 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
689 - 1.1.1
690
691 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
692 - automatic rebuild
693
694 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
695 - move iptables to /sbin.
696 - excludearch alpha for now, not building there because of compiler bug(?)
697
698 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
699 - don't obsolete ipchains either
700 - update to 1.1.0
701
702 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
703 - remove explicit kernel requirement
704
705 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
706 - initial package