Monitor the default interface, which is not necessarily eth0
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}'
121 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
122 service iptables restart
123
124 %postun -p /sbin/ldconfig
125
126 %preun
127 if [ "$1" = 0 ]; then
128         /sbin/chkconfig --del iptables
129 fi
130
131 %post ipv6
132 /sbin/chkconfig --add ip6tables
133
134 %preun ipv6
135 if [ "$1" = 0 ]; then
136         /sbin/chkconfig --del ip6tables
137 fi
138
139 %files
140 %defattr(-,root,root)
141 %doc COPYING INSTALL INCOMPATIBILITIES
142 %attr(0755,root,root) /etc/rc.d/init.d/iptables
143 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
144 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
145 /sbin/iptables*
146 /bin/iptables-xml
147 %{_mandir}/man8/iptables*
148 %dir /%{_lib}/xtables
149 /%{_lib}/xtables/libipt*
150 /%{_lib}/xtables/libxt*
151 /%{_lib}/libip*tc.so.*
152 /%{_lib}/libipq.so.*
153 /%{_lib}/libxtables.so.*
154
155 %files ipv6
156 %defattr(-,root,root)
157 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
158 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
159 /sbin/ip6tables*
160 %{_mandir}/man8/ip6tables*
161 /%{_lib}/xtables/libip6t*
162
163 %files devel
164 %defattr(-,root,root)
165 %dir %{_includedir}/iptables
166 %{_includedir}/iptables/*.h
167 %{_includedir}/*.h
168 %dir %{_includedir}/libiptc
169 %{_includedir}/libiptc/*.h
170 %dir %{_includedir}/libipulog
171 %{_includedir}/libipulog/*.h
172 %{_mandir}/man3/*
173 /%{_lib}/libip*tc.so
174 /%{_lib}/libipq.so
175 /%{_lib}/libxtables.so
176 %{_libdir}/libip*tc.so
177 %{_libdir}/libipq.so
178 %{_libdir}/libxtables.so
179 %{_libdir}/pkgconfig/libiptc.pc
180 %{_libdir}/pkgconfig/xtables.pc
181
182 %changelog
183 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
184 - Fix the patch
185
186 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
187 - Fix incorrect sha1sum
188
189 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
190 - add requires initscripts in deps
191
192 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
193 - Restart iptables service after package upgrades
194
195 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
196 - Restore iIPTABLES_MODULES list
197
198 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
199 - drop backward compatibility with older iptables versions as new kernels only support v2
200 - remove unused modules from iptables-config file
201
202 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
203 - fixed specfile for duplicate URL
204
205 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
206 - added default values for IPTABLES_STATUS_VERBOSE and
207   IPTABLES_STATUS_LINENUMBERS in init script
208 - added missing lsb keywords Required-Start and Required-Stop to init script
209
210 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
211 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
212   - libip4tc: Add static qualifier to dump_entry()
213   - libipq: build as shared library
214   - recent: reorder cases in code (cosmetic cleanup)
215   - several man page and documentation fixes
216   - policy: fix error message showing wrong option
217   - includes: header updates
218   - Lift restrictions on interface names
219 - fixed license and moved iptables-xml into base package according to review
220
221 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
222 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
223   to /usr/lib[64] for compatibility (rhbz#558796)
224
225 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
226 - new version 1.4.6 with support for all new features of 2.6.32
227   - several man page fixes
228   - Support for nommu arches
229   - realm: remove static initializations
230   - libiptc: remove unused functions
231   - libiptc: avoid strict-aliasing warnings
232   - iprange: do accept non-ranges for xt_iprange v1
233   - iprange: warn on reverse range
234   - iprange: roll address parsing into a loop
235   - iprange: do accept non-ranges for xt_iprange v1 (log)
236   - iprange: warn on reverse range (log)
237   - libiptc: fix wrong maptype of base chain counters on restore
238   - iptables: fix undersized deletion mask creation
239   - style: reduce indent in xtables_check_inverse
240   - libxtables: hand argv to xtables_check_inverse
241   - iptables/extensions: make bundled options work again
242   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
243   - iptables: take masks into consideration for replace command
244   - doc: explain experienced --hitcount limit
245   - doc: name resolution clarification
246   - iptables: expose option to zero packet/byte counters for a specific rule
247   - build: restore --disable-ipv6 functionality on system w/o v6 headers
248   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
249   - DNAT: fix incorrect check during parsing
250   - extensions: add osf extension
251   - conntrack: fix --expires parsing
252
253 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
254 - dropped nf_ext_init remains from cloexec patch
255
256 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
257 - new version 1.4.5 with support for all new features of 2.6.31
258   - libxt_NFQUEUE: add new v1 version with queue-balance option
259   - xt_conntrack: revision 2 for enlarged state_mask member
260   - libxt_helper: fix invalid passed option to check_inverse
261   - libiptc: split v4 and v6
262   - extensions: collapse registration structures
263   - iptables: allow for parse-less extensions
264   - iptables: allow for help-less extensions
265   - extensions: remove empty help and parse functions
266   - xtables: add multi-registration functions
267   - extensions: collapse data variables to use multi-reg calls
268   - xtables: warn of missing version identifier in extensions
269   - multi binary: allow subcommand via argv[1]
270   - iptables: accept multiple IP address specifications for -s, -d
271   - several build fixes
272   - several man page fixes
273 - fixed two leaked file descriptors on sockets (rhbz#521397)
274
275 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
276 - new version 1.4.4 with support for all new features of 2.6.30
277   - several man page fixes
278   - iptables: replace open-coded sizeof by ARRAY_SIZE
279   - libip6t_policy: remove redundant functions
280   - policy: use direct xt_policy_info instead of ipt/ip6t
281   - policy: merge ipv6 and ipv4 variant
282   - extensions: add `cluster' match support
283   - extensions: add const qualifiers in print/save functions
284   - extensions: use NFPROTO_UNSPEC for .family field
285   - extensions: remove redundant casts
286   - iptables: close open file descriptors
287   - fix segfault if incorrect protocol name is used
288   - replace open-coded sizeof by ARRAY_SIZE
289   - do not include v4-only modules in ip6tables manpage
290   - use direct xt_policy_info instead of ipt/ip6t
291   - xtables: fix segfault if incorrect protocol name is used
292   - libxt_connlimit: initialize v6_mask
293   - SNAT/DNAT: add support for persistent multi-range NAT mappings
294
295 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
296 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
297
298 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
299 - new version 1.4.3.2
300 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
301
302 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
303 - new version 1.4.3.1
304   - libiptc is now shared
305   - supports all new features of the 2.6.29 kernel
306 - dropped typo_latter patch
307
308 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
309 - still more review fixes (rhbz#225906)
310   - consistent macro usage
311   - use sed instead of perl for rpath removal
312   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
313
314 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
315 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
316
317 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
318 - new version 1.4.2
319 - removed TOS value mask patch (upstream)
320 - more review fixes (rhbz#225906)
321 - install all header files (rhbz#462207)
322 - dropped nf_ext_init (rhbz#472548)
323
324 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
325 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
326 - two more cloexec fixes
327
328 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
329 - upstream bug fix release 1.4.1.1
330 - dropped extra patch for 1.4.1 - not needed anymore
331
332 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
333 - new version 1.4.1 with new build environment
334 - additional ipv6 network mask patch from Jan Engelhardt
335 - spec file cleanup
336 - removed old patches
337
338 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
339 - use normal kernel headers, not linux/compiler.h
340 - change BuildRequires: kernel-devel to kernel-headers
341 - We need to do this to be able to build for both sparcv9 and sparc64 
342   (there is no kernel-devel.sparcv9)
343
344 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
345 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
346
347 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
348 - use the kernel headers from the build tree for iptables for now to be able to 
349   compile this package, but this makes the package more kernel dependant
350 - use s6_addr32 instead of in6_u.u6_addr32
351
352 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
353 - Autorebuild for GCC 4.3
354
355 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
356 - new version 1.4.0
357 - fixed condrestart (rhbz#428148)
358 - report the module in rmmod_r if there is an error
359 - use nf_ext_init instead of my_init for extension constructors
360
361 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
362 - fixed leaked file descriptor before fork/exec (rhbz#312191)
363 - blacklisting is not working, use "install X /bin/(true|false)" test instead
364 - return private exit code 150 for disabled ipv6 support
365 - use script name for output messages
366
367 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
368 - fixed error code for stopping a already stopped firewall (rhbz#321751)
369 - moved blacklist test into start
370
371 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
372 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
373 - use simpler fix for (rhbz#295611)
374   Thanks to Linus Torvalds for the patch.
375
376 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
377 - fixed IPv6 reject type (rhbz#295181)
378 - fixed init script: start, stop and status
379 - support netfilter compiled into kernel in init script (rhbz#295611)
380 - dropped inversion for limit modules from man pages (rhbz#220780)
381 - fixed typo in ip6tables man page (rhbz#236185)
382
383 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
384 - do not depend on local_fs in lsb header - this delayes start after network
385 - fixed exit code for initscript usage
386
387 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
388 - do not use lock file for condrestart test
389
390 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
391 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
392 - provide iptc interface again, but unsupported (rhbz#216733)
393 - compile all extension, which are supported by the kernel-headers package
394 - review fixes (rhbz#225906)
395
396 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
397 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
398
399 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
400 - New version 1.3.8
401
402 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
403 - fix error when ipv6 support isn't loaded in the kernel (#236888)
404
405 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
406 - fixed installation of secmark modules
407
408 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
409 - new verison 1.3.7
410 - iptc is not a public interface and therefore not installed anymore
411 - dropped upstream secmark patch
412
413 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
414 - added secmark iptables patches (#201573)
415
416 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
417 - rebuild
418
419 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
420 - bump again for double-long bug on ppc(64)
421
422 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
423 - rebuilt for new gcc4.1 snapshot and glibc changes
424
425 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
426 - new version 1.3.5
427 - fixed init script to set policy for raw tables, too (#179094)
428
429 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
430 - added important iptables header files to devel package
431
432 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
433 - rebuilt
434
435 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
436 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
437   replace "_init" with "__attribute((constructor)) my_init"
438
439 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
440 - rebuild due to unresolved symbols in shared libraries
441
442 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
443 - new version 1.3.4
444 - dropped free_opts patch (upstream fixed)
445 - made libipq PIC (#158623)
446 - additional configuration options for iptables startup script (#172929)
447   Thanks to Jan Gruenwald for the patch
448 - spec file cleanup (dropped linux_header define and usage)
449
450 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
451 - new version 1.3.2 with additional patch for the misplaced free_opts call
452   from Marcus Sundberg
453
454 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
455 - new version 1.3.1
456
457 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
458 - Remove unnecessary explicit kernel dep (#146142)
459 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
460   for the patch
461 - Adapted iptables-config to reference to modprobe.conf (#150143)
462 - Remove misleading message (#140154): Thanks to Ulrich Drepper
463   for the patch
464
465 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
466 - new version 1.3.0
467
468 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
469 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
470
471 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
472 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
473 - modified config file to match this change and un-commented variables with
474   default values
475
476 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
477 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
478   for the patch
479
480 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
481 - fixed free bug in iptables (#128322)
482
483 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
484 - new version 1.2.11
485
486 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
487 - new version 1.2.10
488
489 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
490 - rebuilt
491
492 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
493 - rebuilt
494
495 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
496 - fixed iptables-restore -c fault if there are no counters (#116421)
497
498 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
499 - rebuilt
500
501 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
502 - Close File descriptors to prevent SELinux error message
503
504 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
505 - rebuild
506
507 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
508 - vew version 1.2.9
509 - new config options in ipXtables-config:
510   IPTABLES_MODULES_UNLOAD
511 - more documentation in ipXtables-config
512 - fix for netlink security issue in libipq (devel package)
513 - print fix for libipt_icmp (#109546)
514
515 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
516 - marked all messages in iptables init script for translation (#107462)
517 - enabled devel package (#105884, #106101)
518 - bumped build for fedora for libipt_recent.so (#106002)
519
520 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
521 - fixed lost udp port range in ip6tables-save (#104484)
522 - fixed non numeric multiport port output in ipXtables-savs
523
524 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
525 - do not link against -lnsl
526
527 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
528 - made variables in rmmod_r local
529
530 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
531 - fixed permission for init script
532
533 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
534 - fixed save when iptables file is missing and iptables-config permissions
535
536 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
537 - fixes for ip6tables: module unloading, setting policy only for existing 
538   tables
539
540 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
541 - IPTABLES_SAVE_COUNTER defaults to no, now
542 - install config file in /etc/sysconfig
543 - exchange unload of ip_tables and ip_conntrack
544 - fixed start function
545
546 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
547 - new config option IPTABLES_SAVE_ON_RESTART
548 - init script: new status, save and restart
549 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
550
551 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
552 - new config option IPTABLES_STATUS_NUMERIC
553 - cleared IPTABLES_MODULES in iptables-config
554
555 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
556 - new init scripts
557
558 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
559 - remove check for very old kernel versions in init scripts
560 - sync up both init scripts and remove some further ugly things
561 - add some docu into rpm
562
563 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
564 - rebuild
565
566 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
567 - update to 1.2.8
568
569 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
570 - rebuilt
571
572 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
573 - update to 1.2.7a
574 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
575
576 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
577 - Fix multilib
578
579 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
580 - fixed iptables and ip6tables initscript output, based on #70511
581 - check return status of all iptables calls, not just the last one
582   in a 'for' loop.
583
584 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
585 - 1.2.6a (bugfix release, #69747)
586
587 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
588 - automated rebuild
589
590 * Thu May 23 2002 Tim Powers <timp@redhat.com>
591 - automated rebuild
592
593 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
594 - Add some fixes from CVS, fixing bug #60465
595
596 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
597 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
598   #59402
599 - Update URL (#59354)
600 - Use /sbin/chkconfig rather than chkconfig in %%postun script
601
602 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
603 - 1.2.5
604
605 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
606 - automated rebuild
607
608 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
609 - Fix %%preun script
610
611 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
612 - Update to 1.2.4 (various fixes, including security fixes; among others:
613   #42990, #50500, #53325, #54280)
614 - Fix init script (#31133)
615
616 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
617 - 1.2.3 (5 security fixes, some other fixes)
618 - Fix updating (#53032)
619
620 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
621 - Fix #50990
622 - Add some fixes from current CVS; should fix #52620
623
624 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
625 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
626   issues
627
628 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
629 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
630   <mschwendt@yahoo.com>
631
632 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
633 - 1.2.2
634
635 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
636 - 1.2.1a, fixes #28412, #31136, #31460, #31133
637
638 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
639 - Yet another initscript fix (#30173)
640 - Fix the fixes; they fixed some issues but broke more important
641   stuff :/ (#30176)
642
643 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
644 - Fix up initscript (#27962)
645 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
646
647 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
648 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
649
650 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
651 - fix bugzilla #25986 (initscript not marked as config file)
652 - fix bugzilla #25962 (iptables-restore)
653 - mv chkconfig --del from postun to preun
654
655 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
656 - Fix check for ipchains
657
658 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
659 - Some fixes to init scripts
660
661 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
662 - Add some fixes from CVS, fixes among other things Bug #24732
663
664 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
665 - Add missing man pages, fix up init script (Bug #17676)
666
667 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
668 - add init script
669
670 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
671 - 1.2
672 - fix up ipv6 split
673 - add init script
674 - Move the plugins from /usr/lib/iptables to /lib/iptables.
675   This needs to work before /usr is mounted...
676 - Use -O1 on alpha (compiler bug)
677
678 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
679 - 1.1.2
680 - Add IPv6 support (in separate package)
681
682 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
683 - build everywhere
684
685 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
686 - 1.1.1
687
688 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
689 - automatic rebuild
690
691 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
692 - move iptables to /sbin.
693 - excludearch alpha for now, not building there because of compiler bug(?)
694
695 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
696 - don't obsolete ipchains either
697 - update to 1.1.0
698
699 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
700 - remove explicit kernel requirement
701
702 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
703 - initial package