Temporary measure for blacklisting an abused node.
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source: http://ipset.netfilter.org/ipset-4.5.tar.bz2
18 Source1: iptables.init
19 Source2: iptables-config
20 Source3: planetlab-config
21 Patch1: copy-xid.patch
22 Group: System Environment/Base
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24 License: GPLv2
25 BuildRequires: libselinux-devel
26 BuildRequires: kernel-headers
27 Conflicts: kernel < 2.4.20
28 Requires(post): chkconfig
29 Requires(post): initscripts
30 Requires(preun): chkconfig
31
32 %description
33 The iptables utility controls the network packet filtering code in the
34 Linux kernel. If you need to set up firewalls and/or IP masquerading,
35 you should install this package.
36
37 %package ipv6
38 Summary: IPv6 support for iptables
39 Group: System Environment/Base
40 Requires: %{name} = %{version}-%{release}
41 Requires(post): chkconfig
42 Requires(preun): chkconfig
43
44 %description ipv6
45 The iptables package contains IPv6 (the next version of the IP
46 protocol) support for iptables. Iptables controls the Linux kernel
47 network packet filtering code, allowing you to set up firewalls and IP
48 masquerading. 
49
50 Install iptables-ipv6 if you need to set up firewalling for your
51 network and you are using ipv6.
52
53 %package devel
54 Summary: Development package for iptables
55 Group: System Environment/Base
56 Requires: %{name} = %{version}-%{release}
57 Requires: pkgconfig
58
59 %description devel
60 iptables development headers and libraries.
61
62 The iptc interface is upstream marked as not public. The interface is not 
63 stable and may change with every new version. It is therefore unsupported.
64
65 %prep
66 %setup -q
67 %patch1 -p1 
68
69 %build
70 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
71 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
72
73 # do not use rpath
74 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
75 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
76
77 make
78
79 %install
80 rm -rf %{buildroot}
81
82 make install DESTDIR=%{buildroot} 
83 # remove la file(s)
84 rm -f %{buildroot}/%{_lib}/*.la
85
86 # install ip*tables.h header files
87 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
88 install -d -m 755 %{buildroot}%{_includedir}/iptables
89 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
90
91 # install ipulog header file
92 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
93 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
94
95 # create symlinks for devel so libs
96 install -d -m 755 %{buildroot}%{_libdir}
97 for i in %{buildroot}/%{_lib}/*.so; do
98     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
99 done
100
101 # move pkgconfig to %{_libdir}
102 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
103
104 # install init scripts and configuration files
105 install -d -m 755 %{buildroot}/etc/rc.d/init.d
106 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
107 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
108 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
109 install -d -m 755 %{buildroot}/etc/sysconfig
110 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
111 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
112 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
113 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
114
115 %clean
116 rm -rf %{buildroot}
117
118 %post
119 /sbin/ldconfig
120 /sbin/chkconfig --add iptables
121 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
122 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
123 [ "$PL_BOOTCD" = "1" ] || service iptables restart
124
125 %postun -p /sbin/ldconfig
126
127 %preun
128 if [ "$1" = 0 ]; then
129         /sbin/chkconfig --del iptables
130 fi
131
132 %post ipv6
133 /sbin/chkconfig --add ip6tables
134
135 %preun ipv6
136 if [ "$1" = 0 ]; then
137         /sbin/chkconfig --del ip6tables
138 fi
139
140 %files
141 %defattr(-,root,root)
142 %doc COPYING INSTALL INCOMPATIBILITIES
143 %attr(0755,root,root) /etc/rc.d/init.d/iptables
144 %config %attr(0600,root,root) /etc/sysconfig/iptables-config
145 %config %attr(0600,root,root) /etc/sysconfig/iptables
146 /sbin/iptables*
147 /bin/iptables-xml
148 %{_mandir}/man8/iptables*
149 %dir /%{_lib}/xtables
150 /%{_lib}/xtables/libipt*
151 /%{_lib}/xtables/libxt*
152 /%{_lib}/libip*tc.so.*
153 /%{_lib}/libipq.so.*
154 /%{_lib}/libxtables.so.*
155
156 %files ipv6
157 %defattr(-,root,root)
158 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
159 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
160 /sbin/ip6tables*
161 %{_mandir}/man8/ip6tables*
162 /%{_lib}/xtables/libip6t*
163
164 %files devel
165 %defattr(-,root,root)
166 %dir %{_includedir}/iptables
167 %{_includedir}/iptables/*.h
168 %{_includedir}/*.h
169 %dir %{_includedir}/libiptc
170 %{_includedir}/libiptc/*.h
171 %dir %{_includedir}/libipulog
172 %{_includedir}/libipulog/*.h
173 %{_mandir}/man3/*
174 /%{_lib}/libip*tc.so
175 /%{_lib}/libipq.so
176 /%{_lib}/libxtables.so
177 %{_libdir}/libip*tc.so
178 %{_libdir}/libipq.so
179 %{_libdir}/libxtables.so
180 %{_libdir}/pkgconfig/libiptc.pc
181 %{_libdir}/pkgconfig/xtables.pc
182
183 %changelog
184 * Thu Mar 24 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-4
185 - Don't start iptables service on build time
186
187 * Wed Feb 23 2011 S.Çağlar Onur <caglar@verivue.com> - iptables-1.4.10-3
188 - Remove ugly hack for config files
189
190 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
191 - Fix the patch
192
193 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
194 - Fix incorrect sha1sum
195
196 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
197 - add requires initscripts in deps
198
199 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
200 - Restart iptables service after package upgrades
201
202 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
203 - Restore iIPTABLES_MODULES list
204
205 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
206 - drop backward compatibility with older iptables versions as new kernels only support v2
207 - remove unused modules from iptables-config file
208
209 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
210 - fixed specfile for duplicate URL
211
212 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
213 - added default values for IPTABLES_STATUS_VERBOSE and
214   IPTABLES_STATUS_LINENUMBERS in init script
215 - added missing lsb keywords Required-Start and Required-Stop to init script
216
217 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
218 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
219   - libip4tc: Add static qualifier to dump_entry()
220   - libipq: build as shared library
221   - recent: reorder cases in code (cosmetic cleanup)
222   - several man page and documentation fixes
223   - policy: fix error message showing wrong option
224   - includes: header updates
225   - Lift restrictions on interface names
226 - fixed license and moved iptables-xml into base package according to review
227
228 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
229 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
230   to /usr/lib[64] for compatibility (rhbz#558796)
231
232 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
233 - new version 1.4.6 with support for all new features of 2.6.32
234   - several man page fixes
235   - Support for nommu arches
236   - realm: remove static initializations
237   - libiptc: remove unused functions
238   - libiptc: avoid strict-aliasing warnings
239   - iprange: do accept non-ranges for xt_iprange v1
240   - iprange: warn on reverse range
241   - iprange: roll address parsing into a loop
242   - iprange: do accept non-ranges for xt_iprange v1 (log)
243   - iprange: warn on reverse range (log)
244   - libiptc: fix wrong maptype of base chain counters on restore
245   - iptables: fix undersized deletion mask creation
246   - style: reduce indent in xtables_check_inverse
247   - libxtables: hand argv to xtables_check_inverse
248   - iptables/extensions: make bundled options work again
249   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
250   - iptables: take masks into consideration for replace command
251   - doc: explain experienced --hitcount limit
252   - doc: name resolution clarification
253   - iptables: expose option to zero packet/byte counters for a specific rule
254   - build: restore --disable-ipv6 functionality on system w/o v6 headers
255   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
256   - DNAT: fix incorrect check during parsing
257   - extensions: add osf extension
258   - conntrack: fix --expires parsing
259
260 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
261 - dropped nf_ext_init remains from cloexec patch
262
263 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
264 - new version 1.4.5 with support for all new features of 2.6.31
265   - libxt_NFQUEUE: add new v1 version with queue-balance option
266   - xt_conntrack: revision 2 for enlarged state_mask member
267   - libxt_helper: fix invalid passed option to check_inverse
268   - libiptc: split v4 and v6
269   - extensions: collapse registration structures
270   - iptables: allow for parse-less extensions
271   - iptables: allow for help-less extensions
272   - extensions: remove empty help and parse functions
273   - xtables: add multi-registration functions
274   - extensions: collapse data variables to use multi-reg calls
275   - xtables: warn of missing version identifier in extensions
276   - multi binary: allow subcommand via argv[1]
277   - iptables: accept multiple IP address specifications for -s, -d
278   - several build fixes
279   - several man page fixes
280 - fixed two leaked file descriptors on sockets (rhbz#521397)
281
282 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
283 - new version 1.4.4 with support for all new features of 2.6.30
284   - several man page fixes
285   - iptables: replace open-coded sizeof by ARRAY_SIZE
286   - libip6t_policy: remove redundant functions
287   - policy: use direct xt_policy_info instead of ipt/ip6t
288   - policy: merge ipv6 and ipv4 variant
289   - extensions: add `cluster' match support
290   - extensions: add const qualifiers in print/save functions
291   - extensions: use NFPROTO_UNSPEC for .family field
292   - extensions: remove redundant casts
293   - iptables: close open file descriptors
294   - fix segfault if incorrect protocol name is used
295   - replace open-coded sizeof by ARRAY_SIZE
296   - do not include v4-only modules in ip6tables manpage
297   - use direct xt_policy_info instead of ipt/ip6t
298   - xtables: fix segfault if incorrect protocol name is used
299   - libxt_connlimit: initialize v6_mask
300   - SNAT/DNAT: add support for persistent multi-range NAT mappings
301
302 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
303 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
304
305 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
306 - new version 1.4.3.2
307 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
308
309 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
310 - new version 1.4.3.1
311   - libiptc is now shared
312   - supports all new features of the 2.6.29 kernel
313 - dropped typo_latter patch
314
315 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
316 - still more review fixes (rhbz#225906)
317   - consistent macro usage
318   - use sed instead of perl for rpath removal
319   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
320
321 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
322 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
323
324 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
325 - new version 1.4.2
326 - removed TOS value mask patch (upstream)
327 - more review fixes (rhbz#225906)
328 - install all header files (rhbz#462207)
329 - dropped nf_ext_init (rhbz#472548)
330
331 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
332 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
333 - two more cloexec fixes
334
335 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
336 - upstream bug fix release 1.4.1.1
337 - dropped extra patch for 1.4.1 - not needed anymore
338
339 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
340 - new version 1.4.1 with new build environment
341 - additional ipv6 network mask patch from Jan Engelhardt
342 - spec file cleanup
343 - removed old patches
344
345 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
346 - use normal kernel headers, not linux/compiler.h
347 - change BuildRequires: kernel-devel to kernel-headers
348 - We need to do this to be able to build for both sparcv9 and sparc64 
349   (there is no kernel-devel.sparcv9)
350
351 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
352 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
353
354 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
355 - use the kernel headers from the build tree for iptables for now to be able to 
356   compile this package, but this makes the package more kernel dependant
357 - use s6_addr32 instead of in6_u.u6_addr32
358
359 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
360 - Autorebuild for GCC 4.3
361
362 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
363 - new version 1.4.0
364 - fixed condrestart (rhbz#428148)
365 - report the module in rmmod_r if there is an error
366 - use nf_ext_init instead of my_init for extension constructors
367
368 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
369 - fixed leaked file descriptor before fork/exec (rhbz#312191)
370 - blacklisting is not working, use "install X /bin/(true|false)" test instead
371 - return private exit code 150 for disabled ipv6 support
372 - use script name for output messages
373
374 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
375 - fixed error code for stopping a already stopped firewall (rhbz#321751)
376 - moved blacklist test into start
377
378 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
379 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
380 - use simpler fix for (rhbz#295611)
381   Thanks to Linus Torvalds for the patch.
382
383 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
384 - fixed IPv6 reject type (rhbz#295181)
385 - fixed init script: start, stop and status
386 - support netfilter compiled into kernel in init script (rhbz#295611)
387 - dropped inversion for limit modules from man pages (rhbz#220780)
388 - fixed typo in ip6tables man page (rhbz#236185)
389
390 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
391 - do not depend on local_fs in lsb header - this delayes start after network
392 - fixed exit code for initscript usage
393
394 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
395 - do not use lock file for condrestart test
396
397 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
398 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
399 - provide iptc interface again, but unsupported (rhbz#216733)
400 - compile all extension, which are supported by the kernel-headers package
401 - review fixes (rhbz#225906)
402
403 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
404 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
405
406 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
407 - New version 1.3.8
408
409 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
410 - fix error when ipv6 support isn't loaded in the kernel (#236888)
411
412 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
413 - fixed installation of secmark modules
414
415 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
416 - new verison 1.3.7
417 - iptc is not a public interface and therefore not installed anymore
418 - dropped upstream secmark patch
419
420 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
421 - added secmark iptables patches (#201573)
422
423 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
424 - rebuild
425
426 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
427 - bump again for double-long bug on ppc(64)
428
429 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
430 - rebuilt for new gcc4.1 snapshot and glibc changes
431
432 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
433 - new version 1.3.5
434 - fixed init script to set policy for raw tables, too (#179094)
435
436 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
437 - added important iptables header files to devel package
438
439 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
440 - rebuilt
441
442 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
443 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
444   replace "_init" with "__attribute((constructor)) my_init"
445
446 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
447 - rebuild due to unresolved symbols in shared libraries
448
449 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
450 - new version 1.3.4
451 - dropped free_opts patch (upstream fixed)
452 - made libipq PIC (#158623)
453 - additional configuration options for iptables startup script (#172929)
454   Thanks to Jan Gruenwald for the patch
455 - spec file cleanup (dropped linux_header define and usage)
456
457 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
458 - new version 1.3.2 with additional patch for the misplaced free_opts call
459   from Marcus Sundberg
460
461 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
462 - new version 1.3.1
463
464 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
465 - Remove unnecessary explicit kernel dep (#146142)
466 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
467   for the patch
468 - Adapted iptables-config to reference to modprobe.conf (#150143)
469 - Remove misleading message (#140154): Thanks to Ulrich Drepper
470   for the patch
471
472 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
473 - new version 1.3.0
474
475 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
476 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
477
478 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
479 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
480 - modified config file to match this change and un-commented variables with
481   default values
482
483 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
484 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
485   for the patch
486
487 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
488 - fixed free bug in iptables (#128322)
489
490 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
491 - new version 1.2.11
492
493 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
494 - new version 1.2.10
495
496 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
497 - rebuilt
498
499 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
500 - rebuilt
501
502 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
503 - fixed iptables-restore -c fault if there are no counters (#116421)
504
505 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
506 - rebuilt
507
508 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
509 - Close File descriptors to prevent SELinux error message
510
511 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
512 - rebuild
513
514 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
515 - vew version 1.2.9
516 - new config options in ipXtables-config:
517   IPTABLES_MODULES_UNLOAD
518 - more documentation in ipXtables-config
519 - fix for netlink security issue in libipq (devel package)
520 - print fix for libipt_icmp (#109546)
521
522 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
523 - marked all messages in iptables init script for translation (#107462)
524 - enabled devel package (#105884, #106101)
525 - bumped build for fedora for libipt_recent.so (#106002)
526
527 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
528 - fixed lost udp port range in ip6tables-save (#104484)
529 - fixed non numeric multiport port output in ipXtables-savs
530
531 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
532 - do not link against -lnsl
533
534 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
535 - made variables in rmmod_r local
536
537 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
538 - fixed permission for init script
539
540 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
541 - fixed save when iptables file is missing and iptables-config permissions
542
543 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
544 - fixes for ip6tables: module unloading, setting policy only for existing 
545   tables
546
547 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
548 - IPTABLES_SAVE_COUNTER defaults to no, now
549 - install config file in /etc/sysconfig
550 - exchange unload of ip_tables and ip_conntrack
551 - fixed start function
552
553 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
554 - new config option IPTABLES_SAVE_ON_RESTART
555 - init script: new status, save and restart
556 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
557
558 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
559 - new config option IPTABLES_STATUS_NUMERIC
560 - cleared IPTABLES_MODULES in iptables-config
561
562 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
563 - new init scripts
564
565 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
566 - remove check for very old kernel versions in init scripts
567 - sync up both init scripts and remove some further ugly things
568 - add some docu into rpm
569
570 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
571 - rebuild
572
573 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
574 - update to 1.2.8
575
576 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
577 - rebuilt
578
579 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
580 - update to 1.2.7a
581 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
582
583 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
584 - Fix multilib
585
586 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
587 - fixed iptables and ip6tables initscript output, based on #70511
588 - check return status of all iptables calls, not just the last one
589   in a 'for' loop.
590
591 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
592 - 1.2.6a (bugfix release, #69747)
593
594 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
595 - automated rebuild
596
597 * Thu May 23 2002 Tim Powers <timp@redhat.com>
598 - automated rebuild
599
600 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
601 - Add some fixes from CVS, fixing bug #60465
602
603 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
604 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
605   #59402
606 - Update URL (#59354)
607 - Use /sbin/chkconfig rather than chkconfig in %%postun script
608
609 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
610 - 1.2.5
611
612 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
613 - automated rebuild
614
615 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
616 - Fix %%preun script
617
618 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
619 - Update to 1.2.4 (various fixes, including security fixes; among others:
620   #42990, #50500, #53325, #54280)
621 - Fix init script (#31133)
622
623 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
624 - 1.2.3 (5 security fixes, some other fixes)
625 - Fix updating (#53032)
626
627 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
628 - Fix #50990
629 - Add some fixes from current CVS; should fix #52620
630
631 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
632 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
633   issues
634
635 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
636 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
637   <mschwendt@yahoo.com>
638
639 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
640 - 1.2.2
641
642 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
643 - 1.2.1a, fixes #28412, #31136, #31460, #31133
644
645 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
646 - Yet another initscript fix (#30173)
647 - Fix the fixes; they fixed some issues but broke more important
648   stuff :/ (#30176)
649
650 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
651 - Fix up initscript (#27962)
652 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
653
654 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
655 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
656
657 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
658 - fix bugzilla #25986 (initscript not marked as config file)
659 - fix bugzilla #25962 (iptables-restore)
660 - mv chkconfig --del from postun to preun
661
662 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
663 - Fix check for ipchains
664
665 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
666 - Some fixes to init scripts
667
668 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
669 - Add some fixes from CVS, fixes among other things Bug #24732
670
671 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
672 - Add missing man pages, fix up init script (Bug #17676)
673
674 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
675 - add init script
676
677 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
678 - 1.2
679 - fix up ipv6 split
680 - add init script
681 - Move the plugins from /usr/lib/iptables to /lib/iptables.
682   This needs to work before /usr is mounted...
683 - Use -O1 on alpha (compiler bug)
684
685 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
686 - 1.1.2
687 - Add IPv6 support (in separate package)
688
689 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
690 - build everywhere
691
692 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
693 - 1.1.1
694
695 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
696 - automatic rebuild
697
698 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
699 - move iptables to /sbin.
700 - excludearch alpha for now, not building there because of compiler bug(?)
701
702 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
703 - don't obsolete ipchains either
704 - update to 1.1.0
705
706 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
707 - remove explicit kernel requirement
708
709 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
710 - initial package