Setting tag iptables-1.4.10-1
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 service iptables restart
121
122 %postun -p /sbin/ldconfig
123
124 %preun
125 if [ "$1" = 0 ]; then
126         /sbin/chkconfig --del iptables
127 fi
128
129 %post ipv6
130 /sbin/chkconfig --add ip6tables
131
132 %preun ipv6
133 if [ "$1" = 0 ]; then
134         /sbin/chkconfig --del ip6tables
135 fi
136
137 %files
138 %defattr(-,root,root)
139 %doc COPYING INSTALL INCOMPATIBILITIES
140 %attr(0755,root,root) /etc/rc.d/init.d/iptables
141 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
142 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
143 /sbin/iptables*
144 /bin/iptables-xml
145 %{_mandir}/man8/iptables*
146 %dir /%{_lib}/xtables
147 /%{_lib}/xtables/libipt*
148 /%{_lib}/xtables/libxt*
149 /%{_lib}/libip*tc.so.*
150 /%{_lib}/libipq.so.*
151 /%{_lib}/libxtables.so.*
152
153 %files ipv6
154 %defattr(-,root,root)
155 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
156 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
157 /sbin/ip6tables*
158 %{_mandir}/man8/ip6tables*
159 /%{_lib}/xtables/libip6t*
160
161 %files devel
162 %defattr(-,root,root)
163 %dir %{_includedir}/iptables
164 %{_includedir}/iptables/*.h
165 %{_includedir}/*.h
166 %dir %{_includedir}/libiptc
167 %{_includedir}/libiptc/*.h
168 %dir %{_includedir}/libipulog
169 %{_includedir}/libipulog/*.h
170 %{_mandir}/man3/*
171 /%{_lib}/libip*tc.so
172 /%{_lib}/libipq.so
173 /%{_lib}/libxtables.so
174 %{_libdir}/libip*tc.so
175 %{_libdir}/libipq.so
176 %{_libdir}/libxtables.so
177 %{_libdir}/pkgconfig/libiptc.pc
178 %{_libdir}/pkgconfig/xtables.pc
179
180 %changelog
181 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
182 - Fix incorrect sha1sum
183
184 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
185 - add requires initscripts in deps
186
187 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
188 - Restart iptables service after package upgrades
189
190 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
191 - Restore iIPTABLES_MODULES list
192
193 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
194 - drop backward compatibility with older iptables versions as new kernels only support v2
195 - remove unused modules from iptables-config file
196
197 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
198 - fixed specfile for duplicate URL
199
200 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
201 - added default values for IPTABLES_STATUS_VERBOSE and
202   IPTABLES_STATUS_LINENUMBERS in init script
203 - added missing lsb keywords Required-Start and Required-Stop to init script
204
205 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
206 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
207   - libip4tc: Add static qualifier to dump_entry()
208   - libipq: build as shared library
209   - recent: reorder cases in code (cosmetic cleanup)
210   - several man page and documentation fixes
211   - policy: fix error message showing wrong option
212   - includes: header updates
213   - Lift restrictions on interface names
214 - fixed license and moved iptables-xml into base package according to review
215
216 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
217 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
218   to /usr/lib[64] for compatibility (rhbz#558796)
219
220 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
221 - new version 1.4.6 with support for all new features of 2.6.32
222   - several man page fixes
223   - Support for nommu arches
224   - realm: remove static initializations
225   - libiptc: remove unused functions
226   - libiptc: avoid strict-aliasing warnings
227   - iprange: do accept non-ranges for xt_iprange v1
228   - iprange: warn on reverse range
229   - iprange: roll address parsing into a loop
230   - iprange: do accept non-ranges for xt_iprange v1 (log)
231   - iprange: warn on reverse range (log)
232   - libiptc: fix wrong maptype of base chain counters on restore
233   - iptables: fix undersized deletion mask creation
234   - style: reduce indent in xtables_check_inverse
235   - libxtables: hand argv to xtables_check_inverse
236   - iptables/extensions: make bundled options work again
237   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
238   - iptables: take masks into consideration for replace command
239   - doc: explain experienced --hitcount limit
240   - doc: name resolution clarification
241   - iptables: expose option to zero packet/byte counters for a specific rule
242   - build: restore --disable-ipv6 functionality on system w/o v6 headers
243   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
244   - DNAT: fix incorrect check during parsing
245   - extensions: add osf extension
246   - conntrack: fix --expires parsing
247
248 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
249 - dropped nf_ext_init remains from cloexec patch
250
251 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
252 - new version 1.4.5 with support for all new features of 2.6.31
253   - libxt_NFQUEUE: add new v1 version with queue-balance option
254   - xt_conntrack: revision 2 for enlarged state_mask member
255   - libxt_helper: fix invalid passed option to check_inverse
256   - libiptc: split v4 and v6
257   - extensions: collapse registration structures
258   - iptables: allow for parse-less extensions
259   - iptables: allow for help-less extensions
260   - extensions: remove empty help and parse functions
261   - xtables: add multi-registration functions
262   - extensions: collapse data variables to use multi-reg calls
263   - xtables: warn of missing version identifier in extensions
264   - multi binary: allow subcommand via argv[1]
265   - iptables: accept multiple IP address specifications for -s, -d
266   - several build fixes
267   - several man page fixes
268 - fixed two leaked file descriptors on sockets (rhbz#521397)
269
270 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
271 - new version 1.4.4 with support for all new features of 2.6.30
272   - several man page fixes
273   - iptables: replace open-coded sizeof by ARRAY_SIZE
274   - libip6t_policy: remove redundant functions
275   - policy: use direct xt_policy_info instead of ipt/ip6t
276   - policy: merge ipv6 and ipv4 variant
277   - extensions: add `cluster' match support
278   - extensions: add const qualifiers in print/save functions
279   - extensions: use NFPROTO_UNSPEC for .family field
280   - extensions: remove redundant casts
281   - iptables: close open file descriptors
282   - fix segfault if incorrect protocol name is used
283   - replace open-coded sizeof by ARRAY_SIZE
284   - do not include v4-only modules in ip6tables manpage
285   - use direct xt_policy_info instead of ipt/ip6t
286   - xtables: fix segfault if incorrect protocol name is used
287   - libxt_connlimit: initialize v6_mask
288   - SNAT/DNAT: add support for persistent multi-range NAT mappings
289
290 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
291 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
292
293 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
294 - new version 1.4.3.2
295 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
296
297 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
298 - new version 1.4.3.1
299   - libiptc is now shared
300   - supports all new features of the 2.6.29 kernel
301 - dropped typo_latter patch
302
303 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
304 - still more review fixes (rhbz#225906)
305   - consistent macro usage
306   - use sed instead of perl for rpath removal
307   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
308
309 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
310 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
311
312 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
313 - new version 1.4.2
314 - removed TOS value mask patch (upstream)
315 - more review fixes (rhbz#225906)
316 - install all header files (rhbz#462207)
317 - dropped nf_ext_init (rhbz#472548)
318
319 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
320 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
321 - two more cloexec fixes
322
323 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
324 - upstream bug fix release 1.4.1.1
325 - dropped extra patch for 1.4.1 - not needed anymore
326
327 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
328 - new version 1.4.1 with new build environment
329 - additional ipv6 network mask patch from Jan Engelhardt
330 - spec file cleanup
331 - removed old patches
332
333 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
334 - use normal kernel headers, not linux/compiler.h
335 - change BuildRequires: kernel-devel to kernel-headers
336 - We need to do this to be able to build for both sparcv9 and sparc64 
337   (there is no kernel-devel.sparcv9)
338
339 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
340 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
341
342 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
343 - use the kernel headers from the build tree for iptables for now to be able to 
344   compile this package, but this makes the package more kernel dependant
345 - use s6_addr32 instead of in6_u.u6_addr32
346
347 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
348 - Autorebuild for GCC 4.3
349
350 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
351 - new version 1.4.0
352 - fixed condrestart (rhbz#428148)
353 - report the module in rmmod_r if there is an error
354 - use nf_ext_init instead of my_init for extension constructors
355
356 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
357 - fixed leaked file descriptor before fork/exec (rhbz#312191)
358 - blacklisting is not working, use "install X /bin/(true|false)" test instead
359 - return private exit code 150 for disabled ipv6 support
360 - use script name for output messages
361
362 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
363 - fixed error code for stopping a already stopped firewall (rhbz#321751)
364 - moved blacklist test into start
365
366 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
367 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
368 - use simpler fix for (rhbz#295611)
369   Thanks to Linus Torvalds for the patch.
370
371 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
372 - fixed IPv6 reject type (rhbz#295181)
373 - fixed init script: start, stop and status
374 - support netfilter compiled into kernel in init script (rhbz#295611)
375 - dropped inversion for limit modules from man pages (rhbz#220780)
376 - fixed typo in ip6tables man page (rhbz#236185)
377
378 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
379 - do not depend on local_fs in lsb header - this delayes start after network
380 - fixed exit code for initscript usage
381
382 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
383 - do not use lock file for condrestart test
384
385 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
386 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
387 - provide iptc interface again, but unsupported (rhbz#216733)
388 - compile all extension, which are supported by the kernel-headers package
389 - review fixes (rhbz#225906)
390
391 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
392 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
393
394 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
395 - New version 1.3.8
396
397 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
398 - fix error when ipv6 support isn't loaded in the kernel (#236888)
399
400 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
401 - fixed installation of secmark modules
402
403 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
404 - new verison 1.3.7
405 - iptc is not a public interface and therefore not installed anymore
406 - dropped upstream secmark patch
407
408 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
409 - added secmark iptables patches (#201573)
410
411 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
412 - rebuild
413
414 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
415 - bump again for double-long bug on ppc(64)
416
417 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
418 - rebuilt for new gcc4.1 snapshot and glibc changes
419
420 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
421 - new version 1.3.5
422 - fixed init script to set policy for raw tables, too (#179094)
423
424 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
425 - added important iptables header files to devel package
426
427 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
428 - rebuilt
429
430 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
431 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
432   replace "_init" with "__attribute((constructor)) my_init"
433
434 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
435 - rebuild due to unresolved symbols in shared libraries
436
437 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
438 - new version 1.3.4
439 - dropped free_opts patch (upstream fixed)
440 - made libipq PIC (#158623)
441 - additional configuration options for iptables startup script (#172929)
442   Thanks to Jan Gruenwald for the patch
443 - spec file cleanup (dropped linux_header define and usage)
444
445 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
446 - new version 1.3.2 with additional patch for the misplaced free_opts call
447   from Marcus Sundberg
448
449 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
450 - new version 1.3.1
451
452 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
453 - Remove unnecessary explicit kernel dep (#146142)
454 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
455   for the patch
456 - Adapted iptables-config to reference to modprobe.conf (#150143)
457 - Remove misleading message (#140154): Thanks to Ulrich Drepper
458   for the patch
459
460 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
461 - new version 1.3.0
462
463 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
464 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
465
466 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
467 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
468 - modified config file to match this change and un-commented variables with
469   default values
470
471 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
472 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
473   for the patch
474
475 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
476 - fixed free bug in iptables (#128322)
477
478 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
479 - new version 1.2.11
480
481 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
482 - new version 1.2.10
483
484 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
485 - rebuilt
486
487 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
488 - rebuilt
489
490 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
491 - fixed iptables-restore -c fault if there are no counters (#116421)
492
493 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
494 - rebuilt
495
496 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
497 - Close File descriptors to prevent SELinux error message
498
499 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
500 - rebuild
501
502 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
503 - vew version 1.2.9
504 - new config options in ipXtables-config:
505   IPTABLES_MODULES_UNLOAD
506 - more documentation in ipXtables-config
507 - fix for netlink security issue in libipq (devel package)
508 - print fix for libipt_icmp (#109546)
509
510 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
511 - marked all messages in iptables init script for translation (#107462)
512 - enabled devel package (#105884, #106101)
513 - bumped build for fedora for libipt_recent.so (#106002)
514
515 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
516 - fixed lost udp port range in ip6tables-save (#104484)
517 - fixed non numeric multiport port output in ipXtables-savs
518
519 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
520 - do not link against -lnsl
521
522 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
523 - made variables in rmmod_r local
524
525 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
526 - fixed permission for init script
527
528 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
529 - fixed save when iptables file is missing and iptables-config permissions
530
531 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
532 - fixes for ip6tables: module unloading, setting policy only for existing 
533   tables
534
535 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
536 - IPTABLES_SAVE_COUNTER defaults to no, now
537 - install config file in /etc/sysconfig
538 - exchange unload of ip_tables and ip_conntrack
539 - fixed start function
540
541 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
542 - new config option IPTABLES_SAVE_ON_RESTART
543 - init script: new status, save and restart
544 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
545
546 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
547 - new config option IPTABLES_STATUS_NUMERIC
548 - cleared IPTABLES_MODULES in iptables-config
549
550 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
551 - new init scripts
552
553 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
554 - remove check for very old kernel versions in init scripts
555 - sync up both init scripts and remove some further ugly things
556 - add some docu into rpm
557
558 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
559 - rebuild
560
561 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
562 - update to 1.2.8
563
564 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
565 - rebuilt
566
567 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
568 - update to 1.2.7a
569 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
570
571 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
572 - Fix multilib
573
574 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
575 - fixed iptables and ip6tables initscript output, based on #70511
576 - check return status of all iptables calls, not just the last one
577   in a 'for' loop.
578
579 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
580 - 1.2.6a (bugfix release, #69747)
581
582 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
583 - automated rebuild
584
585 * Thu May 23 2002 Tim Powers <timp@redhat.com>
586 - automated rebuild
587
588 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
589 - Add some fixes from CVS, fixing bug #60465
590
591 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
592 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
593   #59402
594 - Update URL (#59354)
595 - Use /sbin/chkconfig rather than chkconfig in %%postun script
596
597 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
598 - 1.2.5
599
600 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
601 - automated rebuild
602
603 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
604 - Fix %%preun script
605
606 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
607 - Update to 1.2.4 (various fixes, including security fixes; among others:
608   #42990, #50500, #53325, #54280)
609 - Fix init script (#31133)
610
611 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
612 - 1.2.3 (5 security fixes, some other fixes)
613 - Fix updating (#53032)
614
615 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
616 - Fix #50990
617 - Add some fixes from current CVS; should fix #52620
618
619 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
620 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
621   issues
622
623 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
624 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
625   <mschwendt@yahoo.com>
626
627 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
628 - 1.2.2
629
630 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
631 - 1.2.1a, fixes #28412, #31136, #31460, #31133
632
633 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
634 - Yet another initscript fix (#30173)
635 - Fix the fixes; they fixed some issues but broke more important
636   stuff :/ (#30176)
637
638 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
639 - Fix up initscript (#27962)
640 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
641
642 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
643 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
644
645 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
646 - fix bugzilla #25986 (initscript not marked as config file)
647 - fix bugzilla #25962 (iptables-restore)
648 - mv chkconfig --del from postun to preun
649
650 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
651 - Fix check for ipchains
652
653 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
654 - Some fixes to init scripts
655
656 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
657 - Add some fixes from CVS, fixes among other things Bug #24732
658
659 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
660 - Add missing man pages, fix up init script (Bug #17676)
661
662 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
663 - add init script
664
665 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
666 - 1.2
667 - fix up ipv6 split
668 - add init script
669 - Move the plugins from /usr/lib/iptables to /lib/iptables.
670   This needs to work before /usr is mounted...
671 - Use -O1 on alpha (compiler bug)
672
673 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
674 - 1.1.2
675 - Add IPv6 support (in separate package)
676
677 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
678 - build everywhere
679
680 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
681 - 1.1.1
682
683 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
684 - automatic rebuild
685
686 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
687 - move iptables to /sbin.
688 - excludearch alpha for now, not building there because of compiler bug(?)
689
690 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
691 - don't obsolete ipchains either
692 - update to 1.1.0
693
694 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
695 - remove explicit kernel requirement
696
697 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
698 - initial package