owerwrite old config
[iptables.git] / iptables.spec
1 %define name iptables
2 %define version 1.4.10
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Vendor: PlanetLab
8 Packager: PlanetLab Central <support@planet-lab.org>
9 Distribution: PlanetLab %{plrelease}
10 URL: %{SCMURL}
11
12 Summary: Tools for managing Linux kernel packet filtering capabilities
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
17 Source1: iptables.init
18 Source2: iptables-config
19 Source3: planetlab-config
20 Patch1: copy-xid.patch
21 Group: System Environment/Base
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 License: GPLv2
24 BuildRequires: libselinux-devel
25 BuildRequires: kernel-headers
26 Conflicts: kernel < 2.4.20
27 Requires(post): chkconfig
28 Requires(post): initscripts
29 Requires(preun): chkconfig
30
31 %description
32 The iptables utility controls the network packet filtering code in the
33 Linux kernel. If you need to set up firewalls and/or IP masquerading,
34 you should install this package.
35
36 %package ipv6
37 Summary: IPv6 support for iptables
38 Group: System Environment/Base
39 Requires: %{name} = %{version}-%{release}
40 Requires(post): chkconfig
41 Requires(preun): chkconfig
42
43 %description ipv6
44 The iptables package contains IPv6 (the next version of the IP
45 protocol) support for iptables. Iptables controls the Linux kernel
46 network packet filtering code, allowing you to set up firewalls and IP
47 masquerading. 
48
49 Install iptables-ipv6 if you need to set up firewalling for your
50 network and you are using ipv6.
51
52 %package devel
53 Summary: Development package for iptables
54 Group: System Environment/Base
55 Requires: %{name} = %{version}-%{release}
56 Requires: pkgconfig
57
58 %description devel
59 iptables development headers and libraries.
60
61 The iptc interface is upstream marked as not public. The interface is not 
62 stable and may change with every new version. It is therefore unsupported.
63
64 %prep
65 %setup -q
66 %patch1 -p1 
67
68 %build
69 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
70 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
71
72 # do not use rpath
73 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76 make
77
78 %install
79 rm -rf %{buildroot}
80
81 make install DESTDIR=%{buildroot} 
82 # remove la file(s)
83 rm -f %{buildroot}/%{_lib}/*.la
84
85 # install ip*tables.h header files
86 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
87 install -d -m 755 %{buildroot}%{_includedir}/iptables
88 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
89
90 # install ipulog header file
91 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
92 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
93
94 # create symlinks for devel so libs
95 install -d -m 755 %{buildroot}%{_libdir}
96 for i in %{buildroot}/%{_lib}/*.so; do
97     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
98 done
99
100 # move pkgconfig to %{_libdir}
101 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
102
103 # install init scripts and configuration files
104 install -d -m 755 %{buildroot}/etc/rc.d/init.d
105 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
106 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
107 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
108 install -d -m 755 %{buildroot}/etc/sysconfig
109 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
110 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
111 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
112 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
113
114 %clean
115 rm -rf %{buildroot}
116
117 %post
118 /sbin/ldconfig
119 /sbin/chkconfig --add iptables
120 DEFAULT_IFACE=$(ip route show default | awk '/default/ {print $5}')
121 sed -i -e "s;__eth;$DEFAULT_IFACE;g" /etc/sysconfig/iptables 
122 mv -f /etc/rc.d/init.d/iptables.rpmsave /etc/rc.d/init.d/iptables
123 mv -f /etc/sysconfig/iptables-config.rpmnew /etc/sysconfig/iptables-config
124 service iptables restart
125
126 %postun -p /sbin/ldconfig
127
128 %preun
129 if [ "$1" = 0 ]; then
130         /sbin/chkconfig --del iptables
131 fi
132
133 %post ipv6
134 /sbin/chkconfig --add ip6tables
135
136 %preun ipv6
137 if [ "$1" = 0 ]; then
138         /sbin/chkconfig --del ip6tables
139 fi
140
141 %files
142 %defattr(-,root,root)
143 %doc COPYING INSTALL INCOMPATIBILITIES
144 %attr(0755,root,root) /etc/rc.d/init.d/iptables
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
146 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
147 /sbin/iptables*
148 /bin/iptables-xml
149 %{_mandir}/man8/iptables*
150 %dir /%{_lib}/xtables
151 /%{_lib}/xtables/libipt*
152 /%{_lib}/xtables/libxt*
153 /%{_lib}/libip*tc.so.*
154 /%{_lib}/libipq.so.*
155 /%{_lib}/libxtables.so.*
156
157 %files ipv6
158 %defattr(-,root,root)
159 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
160 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
161 /sbin/ip6tables*
162 %{_mandir}/man8/ip6tables*
163 /%{_lib}/xtables/libip6t*
164
165 %files devel
166 %defattr(-,root,root)
167 %dir %{_includedir}/iptables
168 %{_includedir}/iptables/*.h
169 %{_includedir}/*.h
170 %dir %{_includedir}/libiptc
171 %{_includedir}/libiptc/*.h
172 %dir %{_includedir}/libipulog
173 %{_includedir}/libipulog/*.h
174 %{_mandir}/man3/*
175 /%{_lib}/libip*tc.so
176 /%{_lib}/libipq.so
177 /%{_lib}/libxtables.so
178 %{_libdir}/libip*tc.so
179 %{_libdir}/libipq.so
180 %{_libdir}/libxtables.so
181 %{_libdir}/pkgconfig/libiptc.pc
182 %{_libdir}/pkgconfig/xtables.pc
183
184 %changelog
185 * Thu Jan 27 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-2
186 - Fix the patch
187
188 * Wed Jan 26 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.10-1
189 - Fix incorrect sha1sum
190
191 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.9-1
192 - add requires initscripts in deps
193
194 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
195 - Restart iptables service after package upgrades
196
197 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
198 - Restore iIPTABLES_MODULES list
199
200 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
201 - drop backward compatibility with older iptables versions as new kernels only support v2
202 - remove unused modules from iptables-config file
203
204 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
205 - fixed specfile for duplicate URL
206
207 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
208 - added default values for IPTABLES_STATUS_VERBOSE and
209   IPTABLES_STATUS_LINENUMBERS in init script
210 - added missing lsb keywords Required-Start and Required-Stop to init script
211
212 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
213 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
214   - libip4tc: Add static qualifier to dump_entry()
215   - libipq: build as shared library
216   - recent: reorder cases in code (cosmetic cleanup)
217   - several man page and documentation fixes
218   - policy: fix error message showing wrong option
219   - includes: header updates
220   - Lift restrictions on interface names
221 - fixed license and moved iptables-xml into base package according to review
222
223 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
224 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
225   to /usr/lib[64] for compatibility (rhbz#558796)
226
227 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
228 - new version 1.4.6 with support for all new features of 2.6.32
229   - several man page fixes
230   - Support for nommu arches
231   - realm: remove static initializations
232   - libiptc: remove unused functions
233   - libiptc: avoid strict-aliasing warnings
234   - iprange: do accept non-ranges for xt_iprange v1
235   - iprange: warn on reverse range
236   - iprange: roll address parsing into a loop
237   - iprange: do accept non-ranges for xt_iprange v1 (log)
238   - iprange: warn on reverse range (log)
239   - libiptc: fix wrong maptype of base chain counters on restore
240   - iptables: fix undersized deletion mask creation
241   - style: reduce indent in xtables_check_inverse
242   - libxtables: hand argv to xtables_check_inverse
243   - iptables/extensions: make bundled options work again
244   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
245   - iptables: take masks into consideration for replace command
246   - doc: explain experienced --hitcount limit
247   - doc: name resolution clarification
248   - iptables: expose option to zero packet/byte counters for a specific rule
249   - build: restore --disable-ipv6 functionality on system w/o v6 headers
250   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
251   - DNAT: fix incorrect check during parsing
252   - extensions: add osf extension
253   - conntrack: fix --expires parsing
254
255 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
256 - dropped nf_ext_init remains from cloexec patch
257
258 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
259 - new version 1.4.5 with support for all new features of 2.6.31
260   - libxt_NFQUEUE: add new v1 version with queue-balance option
261   - xt_conntrack: revision 2 for enlarged state_mask member
262   - libxt_helper: fix invalid passed option to check_inverse
263   - libiptc: split v4 and v6
264   - extensions: collapse registration structures
265   - iptables: allow for parse-less extensions
266   - iptables: allow for help-less extensions
267   - extensions: remove empty help and parse functions
268   - xtables: add multi-registration functions
269   - extensions: collapse data variables to use multi-reg calls
270   - xtables: warn of missing version identifier in extensions
271   - multi binary: allow subcommand via argv[1]
272   - iptables: accept multiple IP address specifications for -s, -d
273   - several build fixes
274   - several man page fixes
275 - fixed two leaked file descriptors on sockets (rhbz#521397)
276
277 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
278 - new version 1.4.4 with support for all new features of 2.6.30
279   - several man page fixes
280   - iptables: replace open-coded sizeof by ARRAY_SIZE
281   - libip6t_policy: remove redundant functions
282   - policy: use direct xt_policy_info instead of ipt/ip6t
283   - policy: merge ipv6 and ipv4 variant
284   - extensions: add `cluster' match support
285   - extensions: add const qualifiers in print/save functions
286   - extensions: use NFPROTO_UNSPEC for .family field
287   - extensions: remove redundant casts
288   - iptables: close open file descriptors
289   - fix segfault if incorrect protocol name is used
290   - replace open-coded sizeof by ARRAY_SIZE
291   - do not include v4-only modules in ip6tables manpage
292   - use direct xt_policy_info instead of ipt/ip6t
293   - xtables: fix segfault if incorrect protocol name is used
294   - libxt_connlimit: initialize v6_mask
295   - SNAT/DNAT: add support for persistent multi-range NAT mappings
296
297 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
298 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
299
300 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
301 - new version 1.4.3.2
302 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
303
304 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
305 - new version 1.4.3.1
306   - libiptc is now shared
307   - supports all new features of the 2.6.29 kernel
308 - dropped typo_latter patch
309
310 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
311 - still more review fixes (rhbz#225906)
312   - consistent macro usage
313   - use sed instead of perl for rpath removal
314   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
315
316 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
317 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
318
319 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
320 - new version 1.4.2
321 - removed TOS value mask patch (upstream)
322 - more review fixes (rhbz#225906)
323 - install all header files (rhbz#462207)
324 - dropped nf_ext_init (rhbz#472548)
325
326 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
327 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
328 - two more cloexec fixes
329
330 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
331 - upstream bug fix release 1.4.1.1
332 - dropped extra patch for 1.4.1 - not needed anymore
333
334 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
335 - new version 1.4.1 with new build environment
336 - additional ipv6 network mask patch from Jan Engelhardt
337 - spec file cleanup
338 - removed old patches
339
340 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
341 - use normal kernel headers, not linux/compiler.h
342 - change BuildRequires: kernel-devel to kernel-headers
343 - We need to do this to be able to build for both sparcv9 and sparc64 
344   (there is no kernel-devel.sparcv9)
345
346 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
347 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
348
349 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
350 - use the kernel headers from the build tree for iptables for now to be able to 
351   compile this package, but this makes the package more kernel dependant
352 - use s6_addr32 instead of in6_u.u6_addr32
353
354 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
355 - Autorebuild for GCC 4.3
356
357 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
358 - new version 1.4.0
359 - fixed condrestart (rhbz#428148)
360 - report the module in rmmod_r if there is an error
361 - use nf_ext_init instead of my_init for extension constructors
362
363 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
364 - fixed leaked file descriptor before fork/exec (rhbz#312191)
365 - blacklisting is not working, use "install X /bin/(true|false)" test instead
366 - return private exit code 150 for disabled ipv6 support
367 - use script name for output messages
368
369 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
370 - fixed error code for stopping a already stopped firewall (rhbz#321751)
371 - moved blacklist test into start
372
373 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
374 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
375 - use simpler fix for (rhbz#295611)
376   Thanks to Linus Torvalds for the patch.
377
378 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
379 - fixed IPv6 reject type (rhbz#295181)
380 - fixed init script: start, stop and status
381 - support netfilter compiled into kernel in init script (rhbz#295611)
382 - dropped inversion for limit modules from man pages (rhbz#220780)
383 - fixed typo in ip6tables man page (rhbz#236185)
384
385 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
386 - do not depend on local_fs in lsb header - this delayes start after network
387 - fixed exit code for initscript usage
388
389 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
390 - do not use lock file for condrestart test
391
392 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
393 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
394 - provide iptc interface again, but unsupported (rhbz#216733)
395 - compile all extension, which are supported by the kernel-headers package
396 - review fixes (rhbz#225906)
397
398 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
399 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
400
401 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
402 - New version 1.3.8
403
404 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
405 - fix error when ipv6 support isn't loaded in the kernel (#236888)
406
407 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
408 - fixed installation of secmark modules
409
410 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
411 - new verison 1.3.7
412 - iptc is not a public interface and therefore not installed anymore
413 - dropped upstream secmark patch
414
415 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
416 - added secmark iptables patches (#201573)
417
418 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
419 - rebuild
420
421 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
422 - bump again for double-long bug on ppc(64)
423
424 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
425 - rebuilt for new gcc4.1 snapshot and glibc changes
426
427 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
428 - new version 1.3.5
429 - fixed init script to set policy for raw tables, too (#179094)
430
431 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
432 - added important iptables header files to devel package
433
434 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
435 - rebuilt
436
437 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
438 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
439   replace "_init" with "__attribute((constructor)) my_init"
440
441 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
442 - rebuild due to unresolved symbols in shared libraries
443
444 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
445 - new version 1.3.4
446 - dropped free_opts patch (upstream fixed)
447 - made libipq PIC (#158623)
448 - additional configuration options for iptables startup script (#172929)
449   Thanks to Jan Gruenwald for the patch
450 - spec file cleanup (dropped linux_header define and usage)
451
452 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
453 - new version 1.3.2 with additional patch for the misplaced free_opts call
454   from Marcus Sundberg
455
456 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
457 - new version 1.3.1
458
459 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
460 - Remove unnecessary explicit kernel dep (#146142)
461 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
462   for the patch
463 - Adapted iptables-config to reference to modprobe.conf (#150143)
464 - Remove misleading message (#140154): Thanks to Ulrich Drepper
465   for the patch
466
467 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
468 - new version 1.3.0
469
470 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
471 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
472
473 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
474 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
475 - modified config file to match this change and un-commented variables with
476   default values
477
478 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
479 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
480   for the patch
481
482 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
483 - fixed free bug in iptables (#128322)
484
485 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
486 - new version 1.2.11
487
488 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
489 - new version 1.2.10
490
491 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
492 - rebuilt
493
494 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
495 - rebuilt
496
497 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
498 - fixed iptables-restore -c fault if there are no counters (#116421)
499
500 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
501 - rebuilt
502
503 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
504 - Close File descriptors to prevent SELinux error message
505
506 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
507 - rebuild
508
509 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
510 - vew version 1.2.9
511 - new config options in ipXtables-config:
512   IPTABLES_MODULES_UNLOAD
513 - more documentation in ipXtables-config
514 - fix for netlink security issue in libipq (devel package)
515 - print fix for libipt_icmp (#109546)
516
517 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
518 - marked all messages in iptables init script for translation (#107462)
519 - enabled devel package (#105884, #106101)
520 - bumped build for fedora for libipt_recent.so (#106002)
521
522 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
523 - fixed lost udp port range in ip6tables-save (#104484)
524 - fixed non numeric multiport port output in ipXtables-savs
525
526 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
527 - do not link against -lnsl
528
529 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
530 - made variables in rmmod_r local
531
532 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
533 - fixed permission for init script
534
535 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
536 - fixed save when iptables file is missing and iptables-config permissions
537
538 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
539 - fixes for ip6tables: module unloading, setting policy only for existing 
540   tables
541
542 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
543 - IPTABLES_SAVE_COUNTER defaults to no, now
544 - install config file in /etc/sysconfig
545 - exchange unload of ip_tables and ip_conntrack
546 - fixed start function
547
548 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
549 - new config option IPTABLES_SAVE_ON_RESTART
550 - init script: new status, save and restart
551 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
552
553 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
554 - new config option IPTABLES_STATUS_NUMERIC
555 - cleared IPTABLES_MODULES in iptables-config
556
557 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
558 - new init scripts
559
560 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
561 - remove check for very old kernel versions in init scripts
562 - sync up both init scripts and remove some further ugly things
563 - add some docu into rpm
564
565 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
566 - rebuild
567
568 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
569 - update to 1.2.8
570
571 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
572 - rebuilt
573
574 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
575 - update to 1.2.7a
576 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
577
578 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
579 - Fix multilib
580
581 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
582 - fixed iptables and ip6tables initscript output, based on #70511
583 - check return status of all iptables calls, not just the last one
584   in a 'for' loop.
585
586 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
587 - 1.2.6a (bugfix release, #69747)
588
589 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
590 - automated rebuild
591
592 * Thu May 23 2002 Tim Powers <timp@redhat.com>
593 - automated rebuild
594
595 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
596 - Add some fixes from CVS, fixing bug #60465
597
598 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
599 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
600   #59402
601 - Update URL (#59354)
602 - Use /sbin/chkconfig rather than chkconfig in %%postun script
603
604 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
605 - 1.2.5
606
607 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
608 - automated rebuild
609
610 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
611 - Fix %%preun script
612
613 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
614 - Update to 1.2.4 (various fixes, including security fixes; among others:
615   #42990, #50500, #53325, #54280)
616 - Fix init script (#31133)
617
618 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
619 - 1.2.3 (5 security fixes, some other fixes)
620 - Fix updating (#53032)
621
622 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
623 - Fix #50990
624 - Add some fixes from current CVS; should fix #52620
625
626 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
627 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
628   issues
629
630 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
631 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
632   <mschwendt@yahoo.com>
633
634 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
635 - 1.2.2
636
637 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
638 - 1.2.1a, fixes #28412, #31136, #31460, #31133
639
640 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
641 - Yet another initscript fix (#30173)
642 - Fix the fixes; they fixed some issues but broke more important
643   stuff :/ (#30176)
644
645 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
646 - Fix up initscript (#27962)
647 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
648
649 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
650 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
651
652 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
653 - fix bugzilla #25986 (initscript not marked as config file)
654 - fix bugzilla #25962 (iptables-restore)
655 - mv chkconfig --del from postun to preun
656
657 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
658 - Fix check for ipchains
659
660 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
661 - Some fixes to init scripts
662
663 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
664 - Add some fixes from CVS, fixes among other things Bug #24732
665
666 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
667 - Add missing man pages, fix up init script (Bug #17676)
668
669 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
670 - add init script
671
672 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
673 - 1.2
674 - fix up ipv6 split
675 - add init script
676 - Move the plugins from /usr/lib/iptables to /lib/iptables.
677   This needs to work before /usr is mounted...
678 - Use -O1 on alpha (compiler bug)
679
680 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
681 - 1.1.2
682 - Add IPv6 support (in separate package)
683
684 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
685 - build everywhere
686
687 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
688 - 1.1.1
689
690 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
691 - automatic rebuild
692
693 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
694 - move iptables to /sbin.
695 - excludearch alpha for now, not building there because of compiler bug(?)
696
697 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
698 - don't obsolete ipchains either
699 - update to 1.1.0
700
701 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
702 - remove explicit kernel requirement
703
704 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
705 - initial package