restart the iptables service after upgrades
[iptables.git] / iptables.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iptables
7 %define version 1.4.7
8 %define taglevel 4
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Tools for managing Linux kernel packet filtering capabilities
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
22 Source1: iptables.init
23 Source2: iptables-config
24 Source3: planetlab-config
25 Patch1: copy-xid.patch
26 Group: System Environment/Base
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 License: GPLv2
29 BuildRequires: libselinux-devel
30 BuildRequires: kernel-headers
31 Conflicts: kernel < 2.4.20
32 Requires(post): chkconfig
33 Requires(preun): chkconfig
34
35 %description
36 The iptables utility controls the network packet filtering code in the
37 Linux kernel. If you need to set up firewalls and/or IP masquerading,
38 you should install this package.
39
40 %package ipv6
41 Summary: IPv6 support for iptables
42 Group: System Environment/Base
43 Requires: %{name} = %{version}-%{release}
44 Requires(post): chkconfig
45 Requires(preun): chkconfig
46
47 %description ipv6
48 The iptables package contains IPv6 (the next version of the IP
49 protocol) support for iptables. Iptables controls the Linux kernel
50 network packet filtering code, allowing you to set up firewalls and IP
51 masquerading. 
52
53 Install iptables-ipv6 if you need to set up firewalling for your
54 network and you are using ipv6.
55
56 %package devel
57 Summary: Development package for iptables
58 Group: System Environment/Base
59 Requires: %{name} = %{version}-%{release}
60 Requires: pkgconfig
61
62 %description devel
63 iptables development headers and libraries.
64
65 The iptc interface is upstream marked as not public. The interface is not 
66 stable and may change with every new version. It is therefore unsupported.
67
68 %prep
69 %setup -q
70 %patch1 -p1 
71
72 %build
73 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
74 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
75
76 # do not use rpath
77 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79
80 make
81
82 %install
83 rm -rf %{buildroot}
84
85 make install DESTDIR=%{buildroot} 
86 # remove la file(s)
87 rm -f %{buildroot}/%{_lib}/*.la
88
89 # install ip*tables.h header files
90 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
91 install -d -m 755 %{buildroot}%{_includedir}/iptables
92 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
93
94 # install ipulog header file
95 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
96 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
97
98 # create symlinks for devel so libs
99 install -d -m 755 %{buildroot}%{_libdir}
100 for i in %{buildroot}/%{_lib}/*.so; do
101     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
102 done
103
104 # move pkgconfig to %{_libdir}
105 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
106
107 # install init scripts and configuration files
108 install -d -m 755 %{buildroot}/etc/rc.d/init.d
109 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
111 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
112 install -d -m 755 %{buildroot}/etc/sysconfig
113 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
114 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
115 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
116 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
117
118 %clean
119 rm -rf %{buildroot}
120
121 %post
122 /sbin/ldconfig
123 /sbin/chkconfig --add iptables
124 service iptables restart
125
126 %postun -p /sbin/ldconfig
127
128 %preun
129 if [ "$1" = 0 ]; then
130         /sbin/chkconfig --del iptables
131 fi
132
133 %post ipv6
134 /sbin/chkconfig --add ip6tables
135
136 %preun ipv6
137 if [ "$1" = 0 ]; then
138         /sbin/chkconfig --del ip6tables
139 fi
140
141 %files
142 %defattr(-,root,root)
143 %doc COPYING INSTALL INCOMPATIBILITIES
144 %attr(0755,root,root) /etc/rc.d/init.d/iptables
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
146 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
147 /sbin/iptables*
148 /bin/iptables-xml
149 %{_mandir}/man8/iptables*
150 %dir /%{_lib}/xtables
151 /%{_lib}/xtables/libipt*
152 /%{_lib}/xtables/libxt*
153 /%{_lib}/libip*tc.so.*
154 /%{_lib}/libipq.so.*
155 /%{_lib}/libxtables.so.*
156
157 %files ipv6
158 %defattr(-,root,root)
159 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
160 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
161 /sbin/ip6tables*
162 %{_mandir}/man8/ip6tables*
163 /%{_lib}/xtables/libip6t*
164
165 %files devel
166 %defattr(-,root,root)
167 %dir %{_includedir}/iptables
168 %{_includedir}/iptables/*.h
169 %{_includedir}/*.h
170 %dir %{_includedir}/libiptc
171 %{_includedir}/libiptc/*.h
172 %dir %{_includedir}/libipulog
173 %{_includedir}/libipulog/*.h
174 %{_mandir}/man3/*
175 /%{_lib}/libip*tc.so
176 /%{_lib}/libipq.so
177 /%{_lib}/libxtables.so
178 %{_libdir}/libip*tc.so
179 %{_libdir}/libipq.so
180 %{_libdir}/libxtables.so
181 %{_libdir}/pkgconfig/libiptc.pc
182 %{_libdir}/pkgconfig/xtables.pc
183
184 %changelog
185 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
186 - Restore iIPTABLES_MODULES list
187
188 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
189 - drop backward compatibility with older iptables versions as new kernels only support v2
190 - remove unused modules from iptables-config file
191
192 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
193 - fixed specfile for duplicate URL
194
195 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
196 - added default values for IPTABLES_STATUS_VERBOSE and
197   IPTABLES_STATUS_LINENUMBERS in init script
198 - added missing lsb keywords Required-Start and Required-Stop to init script
199
200 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
201 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
202   - libip4tc: Add static qualifier to dump_entry()
203   - libipq: build as shared library
204   - recent: reorder cases in code (cosmetic cleanup)
205   - several man page and documentation fixes
206   - policy: fix error message showing wrong option
207   - includes: header updates
208   - Lift restrictions on interface names
209 - fixed license and moved iptables-xml into base package according to review
210
211 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
212 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
213   to /usr/lib[64] for compatibility (rhbz#558796)
214
215 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
216 - new version 1.4.6 with support for all new features of 2.6.32
217   - several man page fixes
218   - Support for nommu arches
219   - realm: remove static initializations
220   - libiptc: remove unused functions
221   - libiptc: avoid strict-aliasing warnings
222   - iprange: do accept non-ranges for xt_iprange v1
223   - iprange: warn on reverse range
224   - iprange: roll address parsing into a loop
225   - iprange: do accept non-ranges for xt_iprange v1 (log)
226   - iprange: warn on reverse range (log)
227   - libiptc: fix wrong maptype of base chain counters on restore
228   - iptables: fix undersized deletion mask creation
229   - style: reduce indent in xtables_check_inverse
230   - libxtables: hand argv to xtables_check_inverse
231   - iptables/extensions: make bundled options work again
232   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
233   - iptables: take masks into consideration for replace command
234   - doc: explain experienced --hitcount limit
235   - doc: name resolution clarification
236   - iptables: expose option to zero packet/byte counters for a specific rule
237   - build: restore --disable-ipv6 functionality on system w/o v6 headers
238   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
239   - DNAT: fix incorrect check during parsing
240   - extensions: add osf extension
241   - conntrack: fix --expires parsing
242
243 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
244 - dropped nf_ext_init remains from cloexec patch
245
246 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
247 - new version 1.4.5 with support for all new features of 2.6.31
248   - libxt_NFQUEUE: add new v1 version with queue-balance option
249   - xt_conntrack: revision 2 for enlarged state_mask member
250   - libxt_helper: fix invalid passed option to check_inverse
251   - libiptc: split v4 and v6
252   - extensions: collapse registration structures
253   - iptables: allow for parse-less extensions
254   - iptables: allow for help-less extensions
255   - extensions: remove empty help and parse functions
256   - xtables: add multi-registration functions
257   - extensions: collapse data variables to use multi-reg calls
258   - xtables: warn of missing version identifier in extensions
259   - multi binary: allow subcommand via argv[1]
260   - iptables: accept multiple IP address specifications for -s, -d
261   - several build fixes
262   - several man page fixes
263 - fixed two leaked file descriptors on sockets (rhbz#521397)
264
265 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
266 - new version 1.4.4 with support for all new features of 2.6.30
267   - several man page fixes
268   - iptables: replace open-coded sizeof by ARRAY_SIZE
269   - libip6t_policy: remove redundant functions
270   - policy: use direct xt_policy_info instead of ipt/ip6t
271   - policy: merge ipv6 and ipv4 variant
272   - extensions: add `cluster' match support
273   - extensions: add const qualifiers in print/save functions
274   - extensions: use NFPROTO_UNSPEC for .family field
275   - extensions: remove redundant casts
276   - iptables: close open file descriptors
277   - fix segfault if incorrect protocol name is used
278   - replace open-coded sizeof by ARRAY_SIZE
279   - do not include v4-only modules in ip6tables manpage
280   - use direct xt_policy_info instead of ipt/ip6t
281   - xtables: fix segfault if incorrect protocol name is used
282   - libxt_connlimit: initialize v6_mask
283   - SNAT/DNAT: add support for persistent multi-range NAT mappings
284
285 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
286 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
287
288 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
289 - new version 1.4.3.2
290 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
291
292 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
293 - new version 1.4.3.1
294   - libiptc is now shared
295   - supports all new features of the 2.6.29 kernel
296 - dropped typo_latter patch
297
298 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
299 - still more review fixes (rhbz#225906)
300   - consistent macro usage
301   - use sed instead of perl for rpath removal
302   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
303
304 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
305 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
306
307 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
308 - new version 1.4.2
309 - removed TOS value mask patch (upstream)
310 - more review fixes (rhbz#225906)
311 - install all header files (rhbz#462207)
312 - dropped nf_ext_init (rhbz#472548)
313
314 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
315 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
316 - two more cloexec fixes
317
318 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
319 - upstream bug fix release 1.4.1.1
320 - dropped extra patch for 1.4.1 - not needed anymore
321
322 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
323 - new version 1.4.1 with new build environment
324 - additional ipv6 network mask patch from Jan Engelhardt
325 - spec file cleanup
326 - removed old patches
327
328 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
329 - use normal kernel headers, not linux/compiler.h
330 - change BuildRequires: kernel-devel to kernel-headers
331 - We need to do this to be able to build for both sparcv9 and sparc64 
332   (there is no kernel-devel.sparcv9)
333
334 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
335 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
336
337 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
338 - use the kernel headers from the build tree for iptables for now to be able to 
339   compile this package, but this makes the package more kernel dependant
340 - use s6_addr32 instead of in6_u.u6_addr32
341
342 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
343 - Autorebuild for GCC 4.3
344
345 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
346 - new version 1.4.0
347 - fixed condrestart (rhbz#428148)
348 - report the module in rmmod_r if there is an error
349 - use nf_ext_init instead of my_init for extension constructors
350
351 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
352 - fixed leaked file descriptor before fork/exec (rhbz#312191)
353 - blacklisting is not working, use "install X /bin/(true|false)" test instead
354 - return private exit code 150 for disabled ipv6 support
355 - use script name for output messages
356
357 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
358 - fixed error code for stopping a already stopped firewall (rhbz#321751)
359 - moved blacklist test into start
360
361 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
362 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
363 - use simpler fix for (rhbz#295611)
364   Thanks to Linus Torvalds for the patch.
365
366 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
367 - fixed IPv6 reject type (rhbz#295181)
368 - fixed init script: start, stop and status
369 - support netfilter compiled into kernel in init script (rhbz#295611)
370 - dropped inversion for limit modules from man pages (rhbz#220780)
371 - fixed typo in ip6tables man page (rhbz#236185)
372
373 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
374 - do not depend on local_fs in lsb header - this delayes start after network
375 - fixed exit code for initscript usage
376
377 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
378 - do not use lock file for condrestart test
379
380 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
381 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
382 - provide iptc interface again, but unsupported (rhbz#216733)
383 - compile all extension, which are supported by the kernel-headers package
384 - review fixes (rhbz#225906)
385
386 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
387 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
388
389 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
390 - New version 1.3.8
391
392 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
393 - fix error when ipv6 support isn't loaded in the kernel (#236888)
394
395 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
396 - fixed installation of secmark modules
397
398 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
399 - new verison 1.3.7
400 - iptc is not a public interface and therefore not installed anymore
401 - dropped upstream secmark patch
402
403 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
404 - added secmark iptables patches (#201573)
405
406 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
407 - rebuild
408
409 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
410 - bump again for double-long bug on ppc(64)
411
412 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
413 - rebuilt for new gcc4.1 snapshot and glibc changes
414
415 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
416 - new version 1.3.5
417 - fixed init script to set policy for raw tables, too (#179094)
418
419 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
420 - added important iptables header files to devel package
421
422 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
423 - rebuilt
424
425 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
426 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
427   replace "_init" with "__attribute((constructor)) my_init"
428
429 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
430 - rebuild due to unresolved symbols in shared libraries
431
432 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
433 - new version 1.3.4
434 - dropped free_opts patch (upstream fixed)
435 - made libipq PIC (#158623)
436 - additional configuration options for iptables startup script (#172929)
437   Thanks to Jan Gruenwald for the patch
438 - spec file cleanup (dropped linux_header define and usage)
439
440 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
441 - new version 1.3.2 with additional patch for the misplaced free_opts call
442   from Marcus Sundberg
443
444 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
445 - new version 1.3.1
446
447 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
448 - Remove unnecessary explicit kernel dep (#146142)
449 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
450   for the patch
451 - Adapted iptables-config to reference to modprobe.conf (#150143)
452 - Remove misleading message (#140154): Thanks to Ulrich Drepper
453   for the patch
454
455 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
456 - new version 1.3.0
457
458 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
459 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
460
461 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
462 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
463 - modified config file to match this change and un-commented variables with
464   default values
465
466 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
467 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
468   for the patch
469
470 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
471 - fixed free bug in iptables (#128322)
472
473 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
474 - new version 1.2.11
475
476 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
477 - new version 1.2.10
478
479 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
480 - rebuilt
481
482 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
483 - rebuilt
484
485 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
486 - fixed iptables-restore -c fault if there are no counters (#116421)
487
488 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
489 - rebuilt
490
491 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
492 - Close File descriptors to prevent SELinux error message
493
494 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
495 - rebuild
496
497 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
498 - vew version 1.2.9
499 - new config options in ipXtables-config:
500   IPTABLES_MODULES_UNLOAD
501 - more documentation in ipXtables-config
502 - fix for netlink security issue in libipq (devel package)
503 - print fix for libipt_icmp (#109546)
504
505 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
506 - marked all messages in iptables init script for translation (#107462)
507 - enabled devel package (#105884, #106101)
508 - bumped build for fedora for libipt_recent.so (#106002)
509
510 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
511 - fixed lost udp port range in ip6tables-save (#104484)
512 - fixed non numeric multiport port output in ipXtables-savs
513
514 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
515 - do not link against -lnsl
516
517 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
518 - made variables in rmmod_r local
519
520 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
521 - fixed permission for init script
522
523 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
524 - fixed save when iptables file is missing and iptables-config permissions
525
526 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
527 - fixes for ip6tables: module unloading, setting policy only for existing 
528   tables
529
530 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
531 - IPTABLES_SAVE_COUNTER defaults to no, now
532 - install config file in /etc/sysconfig
533 - exchange unload of ip_tables and ip_conntrack
534 - fixed start function
535
536 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
537 - new config option IPTABLES_SAVE_ON_RESTART
538 - init script: new status, save and restart
539 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
540
541 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
542 - new config option IPTABLES_STATUS_NUMERIC
543 - cleared IPTABLES_MODULES in iptables-config
544
545 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
546 - new init scripts
547
548 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
549 - remove check for very old kernel versions in init scripts
550 - sync up both init scripts and remove some further ugly things
551 - add some docu into rpm
552
553 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
554 - rebuild
555
556 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
557 - update to 1.2.8
558
559 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
560 - rebuilt
561
562 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
563 - update to 1.2.7a
564 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
565
566 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
567 - Fix multilib
568
569 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
570 - fixed iptables and ip6tables initscript output, based on #70511
571 - check return status of all iptables calls, not just the last one
572   in a 'for' loop.
573
574 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
575 - 1.2.6a (bugfix release, #69747)
576
577 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
578 - automated rebuild
579
580 * Thu May 23 2002 Tim Powers <timp@redhat.com>
581 - automated rebuild
582
583 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
584 - Add some fixes from CVS, fixing bug #60465
585
586 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
587 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
588   #59402
589 - Update URL (#59354)
590 - Use /sbin/chkconfig rather than chkconfig in %%postun script
591
592 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
593 - 1.2.5
594
595 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
596 - automated rebuild
597
598 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
599 - Fix %%preun script
600
601 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
602 - Update to 1.2.4 (various fixes, including security fixes; among others:
603   #42990, #50500, #53325, #54280)
604 - Fix init script (#31133)
605
606 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
607 - 1.2.3 (5 security fixes, some other fixes)
608 - Fix updating (#53032)
609
610 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
611 - Fix #50990
612 - Add some fixes from current CVS; should fix #52620
613
614 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
615 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
616   issues
617
618 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
619 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
620   <mschwendt@yahoo.com>
621
622 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
623 - 1.2.2
624
625 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
626 - 1.2.1a, fixes #28412, #31136, #31460, #31133
627
628 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
629 - Yet another initscript fix (#30173)
630 - Fix the fixes; they fixed some issues but broke more important
631   stuff :/ (#30176)
632
633 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
634 - Fix up initscript (#27962)
635 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
636
637 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
638 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
639
640 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
641 - fix bugzilla #25986 (initscript not marked as config file)
642 - fix bugzilla #25962 (iptables-restore)
643 - mv chkconfig --del from postun to preun
644
645 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
646 - Fix check for ipchains
647
648 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
649 - Some fixes to init scripts
650
651 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
652 - Add some fixes from CVS, fixes among other things Bug #24732
653
654 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
655 - Add missing man pages, fix up init script (Bug #17676)
656
657 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
658 - add init script
659
660 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
661 - 1.2
662 - fix up ipv6 split
663 - add init script
664 - Move the plugins from /usr/lib/iptables to /lib/iptables.
665   This needs to work before /usr is mounted...
666 - Use -O1 on alpha (compiler bug)
667
668 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
669 - 1.1.2
670 - Add IPv6 support (in separate package)
671
672 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
673 - build everywhere
674
675 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
676 - 1.1.1
677
678 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
679 - automatic rebuild
680
681 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
682 - move iptables to /sbin.
683 - excludearch alpha for now, not building there because of compiler bug(?)
684
685 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
686 - don't obsolete ipchains either
687 - update to 1.1.0
688
689 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
690 - remove explicit kernel requirement
691
692 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
693 - initial package