bump to 1.4.10
[iptables.git] / iptables.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name iptables
7 %define version 1.4.10
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: Tools for managing Linux kernel packet filtering capabilities
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
22 Source1: iptables.init
23 Source2: iptables-config
24 Source3: planetlab-config
25 Patch1: copy-xid.patch
26 Group: System Environment/Base
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 License: GPLv2
29 BuildRequires: libselinux-devel
30 BuildRequires: kernel-headers
31 Conflicts: kernel < 2.4.20
32 Requires(post): chkconfig
33 Requires(preun): chkconfig
34
35 %description
36 The iptables utility controls the network packet filtering code in the
37 Linux kernel. If you need to set up firewalls and/or IP masquerading,
38 you should install this package.
39
40 %package ipv6
41 Summary: IPv6 support for iptables
42 Group: System Environment/Base
43 Requires: %{name} = %{version}-%{release}
44 Requires(post): chkconfig
45 Requires(preun): chkconfig
46
47 %description ipv6
48 The iptables package contains IPv6 (the next version of the IP
49 protocol) support for iptables. Iptables controls the Linux kernel
50 network packet filtering code, allowing you to set up firewalls and IP
51 masquerading. 
52
53 Install iptables-ipv6 if you need to set up firewalling for your
54 network and you are using ipv6.
55
56 %package devel
57 Summary: Development package for iptables
58 Group: System Environment/Base
59 Requires: %{name} = %{version}-%{release}
60 Requires: pkgconfig
61
62 %description devel
63 iptables development headers and libraries.
64
65 The iptc interface is upstream marked as not public. The interface is not 
66 stable and may change with every new version. It is therefore unsupported.
67
68 %prep
69 %setup -q
70 %patch1 -p1 
71
72 %build
73 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
74 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
75
76 # do not use rpath
77 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
78 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
79
80 make
81
82 %install
83 rm -rf %{buildroot}
84
85 make install DESTDIR=%{buildroot} 
86 # remove la file(s)
87 rm -f %{buildroot}/%{_lib}/*.la
88
89 # install ip*tables.h header files
90 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
91 install -d -m 755 %{buildroot}%{_includedir}/iptables
92 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
93
94 # install ipulog header file
95 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
96 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
97
98 # create symlinks for devel so libs
99 install -d -m 755 %{buildroot}%{_libdir}
100 for i in %{buildroot}/%{_lib}/*.so; do
101     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
102 done
103
104 # move pkgconfig to %{_libdir}
105 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
106
107 # install init scripts and configuration files
108 install -d -m 755 %{buildroot}/etc/rc.d/init.d
109 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
110 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
111 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
112 install -d -m 755 %{buildroot}/etc/sysconfig
113 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
114 install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
115 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
116 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
117
118 %clean
119 rm -rf %{buildroot}
120
121 %post
122 /sbin/ldconfig
123 /sbin/chkconfig --add iptables
124 service iptables restart
125
126 %postun -p /sbin/ldconfig
127
128 %preun
129 if [ "$1" = 0 ]; then
130         /sbin/chkconfig --del iptables
131 fi
132
133 %post ipv6
134 /sbin/chkconfig --add ip6tables
135
136 %preun ipv6
137 if [ "$1" = 0 ]; then
138         /sbin/chkconfig --del ip6tables
139 fi
140
141 %files
142 %defattr(-,root,root)
143 %doc COPYING INSTALL INCOMPATIBILITIES
144 %attr(0755,root,root) /etc/rc.d/init.d/iptables
145 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
146 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
147 /sbin/iptables*
148 /bin/iptables-xml
149 %{_mandir}/man8/iptables*
150 %dir /%{_lib}/xtables
151 /%{_lib}/xtables/libipt*
152 /%{_lib}/xtables/libxt*
153 /%{_lib}/libip*tc.so.*
154 /%{_lib}/libipq.so.*
155 /%{_lib}/libxtables.so.*
156
157 %files ipv6
158 %defattr(-,root,root)
159 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
160 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
161 /sbin/ip6tables*
162 %{_mandir}/man8/ip6tables*
163 /%{_lib}/xtables/libip6t*
164
165 %files devel
166 %defattr(-,root,root)
167 %dir %{_includedir}/iptables
168 %{_includedir}/iptables/*.h
169 %{_includedir}/*.h
170 %dir %{_includedir}/libiptc
171 %{_includedir}/libiptc/*.h
172 %dir %{_includedir}/libipulog
173 %{_includedir}/libipulog/*.h
174 %{_mandir}/man3/*
175 /%{_lib}/libip*tc.so
176 /%{_lib}/libipq.so
177 /%{_lib}/libxtables.so
178 %{_libdir}/libip*tc.so
179 %{_libdir}/libipq.so
180 %{_libdir}/libxtables.so
181 %{_libdir}/pkgconfig/libiptc.pc
182 %{_libdir}/pkgconfig/xtables.pc
183
184 %changelog
185 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
186 - Restart iptables service after package upgrades
187
188 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
189 - Restore iIPTABLES_MODULES list
190
191 * Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
192 - drop backward compatibility with older iptables versions as new kernels only support v2
193 - remove unused modules from iptables-config file
194
195 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
196 - fixed specfile for duplicate URL
197
198 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
199 - added default values for IPTABLES_STATUS_VERBOSE and
200   IPTABLES_STATUS_LINENUMBERS in init script
201 - added missing lsb keywords Required-Start and Required-Stop to init script
202
203 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
204 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
205   - libip4tc: Add static qualifier to dump_entry()
206   - libipq: build as shared library
207   - recent: reorder cases in code (cosmetic cleanup)
208   - several man page and documentation fixes
209   - policy: fix error message showing wrong option
210   - includes: header updates
211   - Lift restrictions on interface names
212 - fixed license and moved iptables-xml into base package according to review
213
214 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
215 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
216   to /usr/lib[64] for compatibility (rhbz#558796)
217
218 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
219 - new version 1.4.6 with support for all new features of 2.6.32
220   - several man page fixes
221   - Support for nommu arches
222   - realm: remove static initializations
223   - libiptc: remove unused functions
224   - libiptc: avoid strict-aliasing warnings
225   - iprange: do accept non-ranges for xt_iprange v1
226   - iprange: warn on reverse range
227   - iprange: roll address parsing into a loop
228   - iprange: do accept non-ranges for xt_iprange v1 (log)
229   - iprange: warn on reverse range (log)
230   - libiptc: fix wrong maptype of base chain counters on restore
231   - iptables: fix undersized deletion mask creation
232   - style: reduce indent in xtables_check_inverse
233   - libxtables: hand argv to xtables_check_inverse
234   - iptables/extensions: make bundled options work again
235   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
236   - iptables: take masks into consideration for replace command
237   - doc: explain experienced --hitcount limit
238   - doc: name resolution clarification
239   - iptables: expose option to zero packet/byte counters for a specific rule
240   - build: restore --disable-ipv6 functionality on system w/o v6 headers
241   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
242   - DNAT: fix incorrect check during parsing
243   - extensions: add osf extension
244   - conntrack: fix --expires parsing
245
246 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
247 - dropped nf_ext_init remains from cloexec patch
248
249 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
250 - new version 1.4.5 with support for all new features of 2.6.31
251   - libxt_NFQUEUE: add new v1 version with queue-balance option
252   - xt_conntrack: revision 2 for enlarged state_mask member
253   - libxt_helper: fix invalid passed option to check_inverse
254   - libiptc: split v4 and v6
255   - extensions: collapse registration structures
256   - iptables: allow for parse-less extensions
257   - iptables: allow for help-less extensions
258   - extensions: remove empty help and parse functions
259   - xtables: add multi-registration functions
260   - extensions: collapse data variables to use multi-reg calls
261   - xtables: warn of missing version identifier in extensions
262   - multi binary: allow subcommand via argv[1]
263   - iptables: accept multiple IP address specifications for -s, -d
264   - several build fixes
265   - several man page fixes
266 - fixed two leaked file descriptors on sockets (rhbz#521397)
267
268 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
269 - new version 1.4.4 with support for all new features of 2.6.30
270   - several man page fixes
271   - iptables: replace open-coded sizeof by ARRAY_SIZE
272   - libip6t_policy: remove redundant functions
273   - policy: use direct xt_policy_info instead of ipt/ip6t
274   - policy: merge ipv6 and ipv4 variant
275   - extensions: add `cluster' match support
276   - extensions: add const qualifiers in print/save functions
277   - extensions: use NFPROTO_UNSPEC for .family field
278   - extensions: remove redundant casts
279   - iptables: close open file descriptors
280   - fix segfault if incorrect protocol name is used
281   - replace open-coded sizeof by ARRAY_SIZE
282   - do not include v4-only modules in ip6tables manpage
283   - use direct xt_policy_info instead of ipt/ip6t
284   - xtables: fix segfault if incorrect protocol name is used
285   - libxt_connlimit: initialize v6_mask
286   - SNAT/DNAT: add support for persistent multi-range NAT mappings
287
288 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
289 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
290
291 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
292 - new version 1.4.3.2
293 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
294
295 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
296 - new version 1.4.3.1
297   - libiptc is now shared
298   - supports all new features of the 2.6.29 kernel
299 - dropped typo_latter patch
300
301 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
302 - still more review fixes (rhbz#225906)
303   - consistent macro usage
304   - use sed instead of perl for rpath removal
305   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
306
307 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
308 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
309
310 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
311 - new version 1.4.2
312 - removed TOS value mask patch (upstream)
313 - more review fixes (rhbz#225906)
314 - install all header files (rhbz#462207)
315 - dropped nf_ext_init (rhbz#472548)
316
317 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
318 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
319 - two more cloexec fixes
320
321 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
322 - upstream bug fix release 1.4.1.1
323 - dropped extra patch for 1.4.1 - not needed anymore
324
325 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
326 - new version 1.4.1 with new build environment
327 - additional ipv6 network mask patch from Jan Engelhardt
328 - spec file cleanup
329 - removed old patches
330
331 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
332 - use normal kernel headers, not linux/compiler.h
333 - change BuildRequires: kernel-devel to kernel-headers
334 - We need to do this to be able to build for both sparcv9 and sparc64 
335   (there is no kernel-devel.sparcv9)
336
337 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
338 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
339
340 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
341 - use the kernel headers from the build tree for iptables for now to be able to 
342   compile this package, but this makes the package more kernel dependant
343 - use s6_addr32 instead of in6_u.u6_addr32
344
345 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
346 - Autorebuild for GCC 4.3
347
348 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
349 - new version 1.4.0
350 - fixed condrestart (rhbz#428148)
351 - report the module in rmmod_r if there is an error
352 - use nf_ext_init instead of my_init for extension constructors
353
354 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
355 - fixed leaked file descriptor before fork/exec (rhbz#312191)
356 - blacklisting is not working, use "install X /bin/(true|false)" test instead
357 - return private exit code 150 for disabled ipv6 support
358 - use script name for output messages
359
360 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
361 - fixed error code for stopping a already stopped firewall (rhbz#321751)
362 - moved blacklist test into start
363
364 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
365 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
366 - use simpler fix for (rhbz#295611)
367   Thanks to Linus Torvalds for the patch.
368
369 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
370 - fixed IPv6 reject type (rhbz#295181)
371 - fixed init script: start, stop and status
372 - support netfilter compiled into kernel in init script (rhbz#295611)
373 - dropped inversion for limit modules from man pages (rhbz#220780)
374 - fixed typo in ip6tables man page (rhbz#236185)
375
376 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
377 - do not depend on local_fs in lsb header - this delayes start after network
378 - fixed exit code for initscript usage
379
380 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
381 - do not use lock file for condrestart test
382
383 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
384 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
385 - provide iptc interface again, but unsupported (rhbz#216733)
386 - compile all extension, which are supported by the kernel-headers package
387 - review fixes (rhbz#225906)
388
389 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
390 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
391
392 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
393 - New version 1.3.8
394
395 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
396 - fix error when ipv6 support isn't loaded in the kernel (#236888)
397
398 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
399 - fixed installation of secmark modules
400
401 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
402 - new verison 1.3.7
403 - iptc is not a public interface and therefore not installed anymore
404 - dropped upstream secmark patch
405
406 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
407 - added secmark iptables patches (#201573)
408
409 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
410 - rebuild
411
412 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
413 - bump again for double-long bug on ppc(64)
414
415 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
416 - rebuilt for new gcc4.1 snapshot and glibc changes
417
418 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
419 - new version 1.3.5
420 - fixed init script to set policy for raw tables, too (#179094)
421
422 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
423 - added important iptables header files to devel package
424
425 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
426 - rebuilt
427
428 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
429 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
430   replace "_init" with "__attribute((constructor)) my_init"
431
432 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
433 - rebuild due to unresolved symbols in shared libraries
434
435 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
436 - new version 1.3.4
437 - dropped free_opts patch (upstream fixed)
438 - made libipq PIC (#158623)
439 - additional configuration options for iptables startup script (#172929)
440   Thanks to Jan Gruenwald for the patch
441 - spec file cleanup (dropped linux_header define and usage)
442
443 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
444 - new version 1.3.2 with additional patch for the misplaced free_opts call
445   from Marcus Sundberg
446
447 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
448 - new version 1.3.1
449
450 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
451 - Remove unnecessary explicit kernel dep (#146142)
452 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
453   for the patch
454 - Adapted iptables-config to reference to modprobe.conf (#150143)
455 - Remove misleading message (#140154): Thanks to Ulrich Drepper
456   for the patch
457
458 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
459 - new version 1.3.0
460
461 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
462 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
463
464 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
465 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
466 - modified config file to match this change and un-commented variables with
467   default values
468
469 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
470 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
471   for the patch
472
473 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
474 - fixed free bug in iptables (#128322)
475
476 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
477 - new version 1.2.11
478
479 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
480 - new version 1.2.10
481
482 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
483 - rebuilt
484
485 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
486 - rebuilt
487
488 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
489 - fixed iptables-restore -c fault if there are no counters (#116421)
490
491 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
492 - rebuilt
493
494 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
495 - Close File descriptors to prevent SELinux error message
496
497 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
498 - rebuild
499
500 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
501 - vew version 1.2.9
502 - new config options in ipXtables-config:
503   IPTABLES_MODULES_UNLOAD
504 - more documentation in ipXtables-config
505 - fix for netlink security issue in libipq (devel package)
506 - print fix for libipt_icmp (#109546)
507
508 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
509 - marked all messages in iptables init script for translation (#107462)
510 - enabled devel package (#105884, #106101)
511 - bumped build for fedora for libipt_recent.so (#106002)
512
513 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
514 - fixed lost udp port range in ip6tables-save (#104484)
515 - fixed non numeric multiport port output in ipXtables-savs
516
517 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
518 - do not link against -lnsl
519
520 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
521 - made variables in rmmod_r local
522
523 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
524 - fixed permission for init script
525
526 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
527 - fixed save when iptables file is missing and iptables-config permissions
528
529 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
530 - fixes for ip6tables: module unloading, setting policy only for existing 
531   tables
532
533 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
534 - IPTABLES_SAVE_COUNTER defaults to no, now
535 - install config file in /etc/sysconfig
536 - exchange unload of ip_tables and ip_conntrack
537 - fixed start function
538
539 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
540 - new config option IPTABLES_SAVE_ON_RESTART
541 - init script: new status, save and restart
542 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
543
544 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
545 - new config option IPTABLES_STATUS_NUMERIC
546 - cleared IPTABLES_MODULES in iptables-config
547
548 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
549 - new init scripts
550
551 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
552 - remove check for very old kernel versions in init scripts
553 - sync up both init scripts and remove some further ugly things
554 - add some docu into rpm
555
556 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
557 - rebuild
558
559 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
560 - update to 1.2.8
561
562 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
563 - rebuilt
564
565 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
566 - update to 1.2.7a
567 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
568
569 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
570 - Fix multilib
571
572 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
573 - fixed iptables and ip6tables initscript output, based on #70511
574 - check return status of all iptables calls, not just the last one
575   in a 'for' loop.
576
577 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
578 - 1.2.6a (bugfix release, #69747)
579
580 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
581 - automated rebuild
582
583 * Thu May 23 2002 Tim Powers <timp@redhat.com>
584 - automated rebuild
585
586 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
587 - Add some fixes from CVS, fixing bug #60465
588
589 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
590 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
591   #59402
592 - Update URL (#59354)
593 - Use /sbin/chkconfig rather than chkconfig in %%postun script
594
595 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
596 - 1.2.5
597
598 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
599 - automated rebuild
600
601 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
602 - Fix %%preun script
603
604 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
605 - Update to 1.2.4 (various fixes, including security fixes; among others:
606   #42990, #50500, #53325, #54280)
607 - Fix init script (#31133)
608
609 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
610 - 1.2.3 (5 security fixes, some other fixes)
611 - Fix updating (#53032)
612
613 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
614 - Fix #50990
615 - Add some fixes from current CVS; should fix #52620
616
617 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
618 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
619   issues
620
621 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
622 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
623   <mschwendt@yahoo.com>
624
625 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
626 - 1.2.2
627
628 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
629 - 1.2.1a, fixes #28412, #31136, #31460, #31133
630
631 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
632 - Yet another initscript fix (#30173)
633 - Fix the fixes; they fixed some issues but broke more important
634   stuff :/ (#30176)
635
636 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
637 - Fix up initscript (#27962)
638 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
639
640 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
641 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
642
643 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
644 - fix bugzilla #25986 (initscript not marked as config file)
645 - fix bugzilla #25962 (iptables-restore)
646 - mv chkconfig --del from postun to preun
647
648 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
649 - Fix check for ipchains
650
651 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
652 - Some fixes to init scripts
653
654 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
655 - Add some fixes from CVS, fixes among other things Bug #24732
656
657 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
658 - Add missing man pages, fix up init script (Bug #17676)
659
660 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
661 - add init script
662
663 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
664 - 1.2
665 - fix up ipv6 split
666 - add init script
667 - Move the plugins from /usr/lib/iptables to /lib/iptables.
668   This needs to work before /usr is mounted...
669 - Use -O1 on alpha (compiler bug)
670
671 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
672 - 1.1.2
673 - Add IPv6 support (in separate package)
674
675 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
676 - build everywhere
677
678 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
679 - 1.1.1
680
681 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
682 - automatic rebuild
683
684 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
685 - move iptables to /sbin.
686 - excludearch alpha for now, not building there because of compiler bug(?)
687
688 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
689 - don't obsolete ipchains either
690 - update to 1.1.0
691
692 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
693 - remove explicit kernel requirement
694
695 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
696 - initial package