update to 1.4.7 and change repositoyry layout as this is easier to maintain
[iptables.git] / iptables.spec
1 Name: iptables
2 Summary: Tools for managing Linux kernel packet filtering capabilities
3 Version: 1.4.7
4 Release: 2%{?dist}
5 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
6 Source1: iptables.init
7 Source2: iptables-config
8 Source3: planetlab-config
9 Patch1: copy-xid.patch
10 Group: System Environment/Base
11 URL: http://www.netfilter.org/
12 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
13 License: GPLv2
14 BuildRequires: libselinux-devel
15 BuildRequires: kernel-headers
16 Conflicts: kernel < 2.4.20
17 Requires(post): chkconfig
18 Requires(preun): chkconfig
19
20 %description
21 The iptables utility controls the network packet filtering code in the
22 Linux kernel. If you need to set up firewalls and/or IP masquerading,
23 you should install this package.
24
25 %package ipv6
26 Summary: IPv6 support for iptables
27 Group: System Environment/Base
28 Requires: %{name} = %{version}-%{release}
29 Requires(post): chkconfig
30 Requires(preun): chkconfig
31
32 %description ipv6
33 The iptables package contains IPv6 (the next version of the IP
34 protocol) support for iptables. Iptables controls the Linux kernel
35 network packet filtering code, allowing you to set up firewalls and IP
36 masquerading. 
37
38 Install iptables-ipv6 if you need to set up firewalling for your
39 network and you are using ipv6.
40
41 %package devel
42 Summary: Development package for iptables
43 Group: System Environment/Base
44 Requires: %{name} = %{version}-%{release}
45 Requires: pkgconfig
46
47 %description devel
48 iptables development headers and libraries.
49
50 The iptc interface is upstream marked as not public. The interface is not 
51 stable and may change with every new version. It is therefore unsupported.
52
53 %prep
54 %setup -q
55 %patch1 -p1 
56
57 %build
58 CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
59 ./configure --enable-devel --enable-libipq --bindir=/bin --sbindir=/sbin --sysconfdir=/etc --libdir=/%{_lib} --libexecdir=/%{_lib} --mandir=%{_mandir} --includedir=%{_includedir} --with-kernel=/usr --with-kbuild=/usr --with-ksource=/usr
60
61 # do not use rpath
62 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
63 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
64
65 make
66
67 %install
68 rm -rf %{buildroot}
69
70 make install DESTDIR=%{buildroot} 
71 # remove la file(s)
72 rm -f %{buildroot}/%{_lib}/*.la
73
74 # install ip*tables.h header files
75 install -m 644 include/ip*tables.h %{buildroot}%{_includedir}/
76 install -d -m 755 %{buildroot}%{_includedir}/iptables
77 install -m 644 include/iptables/internal.h %{buildroot}%{_includedir}/iptables/
78
79 # install ipulog header file
80 install -d -m 755 %{buildroot}%{_includedir}/libipulog/
81 install -m 644 include/libipulog/*.h %{buildroot}%{_includedir}/libipulog/
82
83 # create symlinks for devel so libs
84 install -d -m 755 %{buildroot}%{_libdir}
85 for i in %{buildroot}/%{_lib}/*.so; do
86     ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
87 done
88
89 # move pkgconfig to %{_libdir}
90 mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
91
92 # install init scripts and configuration files
93 install -d -m 755 %{buildroot}/etc/rc.d/init.d
94 install -c -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/iptables
95 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6tables.init
96 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
97 install -d -m 755 %{buildroot}/etc/sysconfig
98 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
99 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
100 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
101
102 %clean
103 rm -rf %{buildroot}
104
105 %post
106 /sbin/ldconfig
107 /sbin/chkconfig --add iptables
108
109 %postun -p /sbin/ldconfig
110
111 %preun
112 if [ "$1" = 0 ]; then
113         /sbin/chkconfig --del iptables
114 fi
115
116 %post ipv6
117 /sbin/chkconfig --add ip6tables
118
119 %preun ipv6
120 if [ "$1" = 0 ]; then
121         /sbin/chkconfig --del ip6tables
122 fi
123
124 %files
125 %defattr(-,root,root)
126 %doc COPYING INSTALL INCOMPATIBILITIES
127 %attr(0755,root,root) /etc/rc.d/init.d/iptables
128 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
129 /sbin/iptables*
130 /bin/iptables-xml
131 %{_mandir}/man8/iptables*
132 %dir /%{_lib}/xtables
133 /%{_lib}/xtables/libipt*
134 /%{_lib}/xtables/libxt*
135 /%{_lib}/libip*tc.so.*
136 /%{_lib}/libipq.so.*
137 /%{_lib}/libxtables.so.*
138
139 %files ipv6
140 %defattr(-,root,root)
141 %attr(0755,root,root) /etc/rc.d/init.d/ip6tables
142 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/ip6tables-config
143 /sbin/ip6tables*
144 %{_mandir}/man8/ip6tables*
145 /%{_lib}/xtables/libip6t*
146
147 %files devel
148 %defattr(-,root,root)
149 %dir %{_includedir}/iptables
150 %{_includedir}/iptables/*.h
151 %{_includedir}/*.h
152 %dir %{_includedir}/libiptc
153 %{_includedir}/libiptc/*.h
154 %dir %{_includedir}/libipulog
155 %{_includedir}/libipulog/*.h
156 %{_mandir}/man3/*
157 /%{_lib}/libip*tc.so
158 /%{_lib}/libipq.so
159 /%{_lib}/libxtables.so
160 %{_libdir}/libip*tc.so
161 %{_libdir}/libipq.so
162 %{_libdir}/libxtables.so
163 %{_libdir}/pkgconfig/libiptc.pc
164 %{_libdir}/pkgconfig/xtables.pc
165
166 %changelog
167 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
168 - added default values for IPTABLES_STATUS_VERBOSE and
169   IPTABLES_STATUS_LINENUMBERS in init script
170 - added missing lsb keywords Required-Start and Required-Stop to init script
171
172 * Fri Mar  5 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-1
173 - new version 1.4.7 with support for all new features of 2.6.33 (rhbz#570767)
174   - libip4tc: Add static qualifier to dump_entry()
175   - libipq: build as shared library
176   - recent: reorder cases in code (cosmetic cleanup)
177   - several man page and documentation fixes
178   - policy: fix error message showing wrong option
179   - includes: header updates
180   - Lift restrictions on interface names
181 - fixed license and moved iptables-xml into base package according to review
182
183 * Wed Jan 27 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-2
184 - moved libip*tc and libxtables libs to /lib[64], added symlinks for .so libs
185   to /usr/lib[64] for compatibility (rhbz#558796)
186
187 * Wed Jan 13 2010 Thomas Woerner <twoerner@redhat.com> 1.4.6-1
188 - new version 1.4.6 with support for all new features of 2.6.32
189   - several man page fixes
190   - Support for nommu arches
191   - realm: remove static initializations
192   - libiptc: remove unused functions
193   - libiptc: avoid strict-aliasing warnings
194   - iprange: do accept non-ranges for xt_iprange v1
195   - iprange: warn on reverse range
196   - iprange: roll address parsing into a loop
197   - iprange: do accept non-ranges for xt_iprange v1 (log)
198   - iprange: warn on reverse range (log)
199   - libiptc: fix wrong maptype of base chain counters on restore
200   - iptables: fix undersized deletion mask creation
201   - style: reduce indent in xtables_check_inverse
202   - libxtables: hand argv to xtables_check_inverse
203   - iptables/extensions: make bundled options work again
204   - CONNMARK: print mark rules with mask 0xffffffff as set instead of xset
205   - iptables: take masks into consideration for replace command
206   - doc: explain experienced --hitcount limit
207   - doc: name resolution clarification
208   - iptables: expose option to zero packet/byte counters for a specific rule
209   - build: restore --disable-ipv6 functionality on system w/o v6 headers
210   - MARK: print mark rules with mask 0xffffffff as --set-mark instead of --set-xmark
211   - DNAT: fix incorrect check during parsing
212   - extensions: add osf extension
213   - conntrack: fix --expires parsing
214
215 * Thu Dec 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-2
216 - dropped nf_ext_init remains from cloexec patch
217
218 * Thu Sep 17 2009 Thomas Woerner <twoerner@redhat.com> 1.4.5-1
219 - new version 1.4.5 with support for all new features of 2.6.31
220   - libxt_NFQUEUE: add new v1 version with queue-balance option
221   - xt_conntrack: revision 2 for enlarged state_mask member
222   - libxt_helper: fix invalid passed option to check_inverse
223   - libiptc: split v4 and v6
224   - extensions: collapse registration structures
225   - iptables: allow for parse-less extensions
226   - iptables: allow for help-less extensions
227   - extensions: remove empty help and parse functions
228   - xtables: add multi-registration functions
229   - extensions: collapse data variables to use multi-reg calls
230   - xtables: warn of missing version identifier in extensions
231   - multi binary: allow subcommand via argv[1]
232   - iptables: accept multiple IP address specifications for -s, -d
233   - several build fixes
234   - several man page fixes
235 - fixed two leaked file descriptors on sockets (rhbz#521397)
236
237 * Mon Aug 24 2009 Thomas Woerner <twoerner@redhat.com> 1.4.4-1
238 - new version 1.4.4 with support for all new features of 2.6.30
239   - several man page fixes
240   - iptables: replace open-coded sizeof by ARRAY_SIZE
241   - libip6t_policy: remove redundant functions
242   - policy: use direct xt_policy_info instead of ipt/ip6t
243   - policy: merge ipv6 and ipv4 variant
244   - extensions: add `cluster' match support
245   - extensions: add const qualifiers in print/save functions
246   - extensions: use NFPROTO_UNSPEC for .family field
247   - extensions: remove redundant casts
248   - iptables: close open file descriptors
249   - fix segfault if incorrect protocol name is used
250   - replace open-coded sizeof by ARRAY_SIZE
251   - do not include v4-only modules in ip6tables manpage
252   - use direct xt_policy_info instead of ipt/ip6t
253   - xtables: fix segfault if incorrect protocol name is used
254   - libxt_connlimit: initialize v6_mask
255   - SNAT/DNAT: add support for persistent multi-range NAT mappings
256
257 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3.2-2
258 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
259
260 * Wed Apr 15 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.2-1
261 - new version 1.4.3.2
262 - also install iptables/internal.h, needed for iptables.h and ip6tables.h
263
264 * Mon Mar 30 2009 Thomas Woerner <twoerner@redhat.com> 1.4.3.1-1
265 - new version 1.4.3.1
266   - libiptc is now shared
267   - supports all new features of the 2.6.29 kernel
268 - dropped typo_latter patch
269
270 * Thu Mar  5 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-3
271 - still more review fixes (rhbz#225906)
272   - consistent macro usage
273   - use sed instead of perl for rpath removal
274   - use standard RPM CFLAGS, but also -fno-strict-aliasing (needed for libiptc*)
275
276 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.2-2
277 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
278
279 * Fri Feb 20 2009 Thomas Woerner <twoerner@redhat.com> 1.4.2-1
280 - new version 1.4.2
281 - removed TOS value mask patch (upstream)
282 - more review fixes (rhbz#225906)
283 - install all header files (rhbz#462207)
284 - dropped nf_ext_init (rhbz#472548)
285
286 * Tue Jul 22 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-2
287 - fixed TOS value mask problem (rhbz#456244) (upstream patch)
288 - two more cloexec fixes
289
290 * Tue Jul  1 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1.1-1
291 - upstream bug fix release 1.4.1.1
292 - dropped extra patch for 1.4.1 - not needed anymore
293
294 * Tue Jun 10 2008 Thomas Woerner <twoerner@redhat.com> 1.4.1-1
295 - new version 1.4.1 with new build environment
296 - additional ipv6 network mask patch from Jan Engelhardt
297 - spec file cleanup
298 - removed old patches
299
300 * Fri Jun  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4.0-5
301 - use normal kernel headers, not linux/compiler.h
302 - change BuildRequires: kernel-devel to kernel-headers
303 - We need to do this to be able to build for both sparcv9 and sparc64 
304   (there is no kernel-devel.sparcv9)
305
306 * Thu Mar 20 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-4
307 - use O_CLOEXEC for all opened files in all applications (rhbz#438189)
308
309 * Mon Mar  3 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-3
310 - use the kernel headers from the build tree for iptables for now to be able to 
311   compile this package, but this makes the package more kernel dependant
312 - use s6_addr32 instead of in6_u.u6_addr32
313
314 * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.0-2
315 - Autorebuild for GCC 4.3
316
317 * Mon Feb 11 2008 Thomas Woerner <twoerner@redhat.com> 1.4.0-1
318 - new version 1.4.0
319 - fixed condrestart (rhbz#428148)
320 - report the module in rmmod_r if there is an error
321 - use nf_ext_init instead of my_init for extension constructors
322
323 * Mon Nov  5 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-6
324 - fixed leaked file descriptor before fork/exec (rhbz#312191)
325 - blacklisting is not working, use "install X /bin/(true|false)" test instead
326 - return private exit code 150 for disabled ipv6 support
327 - use script name for output messages
328
329 * Tue Oct 16 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-5
330 - fixed error code for stopping a already stopped firewall (rhbz#321751)
331 - moved blacklist test into start
332
333 * Wed Sep 26 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4.1
334 - do not start ip6tables if ipv6 is blacklisted (rhbz#236888)
335 - use simpler fix for (rhbz#295611)
336   Thanks to Linus Torvalds for the patch.
337
338 * Mon Sep 24 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-4
339 - fixed IPv6 reject type (rhbz#295181)
340 - fixed init script: start, stop and status
341 - support netfilter compiled into kernel in init script (rhbz#295611)
342 - dropped inversion for limit modules from man pages (rhbz#220780)
343 - fixed typo in ip6tables man page (rhbz#236185)
344
345 * Wed Sep 19 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-3
346 - do not depend on local_fs in lsb header - this delayes start after network
347 - fixed exit code for initscript usage
348
349 * Mon Sep 17 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2.1
350 - do not use lock file for condrestart test
351
352 * Thu Aug 23 2007 Thomas Woerner <twoerner@redhat.com> 1.3.8-2
353 - fixed initscript for LSB conformance (rhbz#246953, rhbz#242459)
354 - provide iptc interface again, but unsupported (rhbz#216733)
355 - compile all extension, which are supported by the kernel-headers package
356 - review fixes (rhbz#225906)
357
358 * Tue Jul 31 2007 Thomas Woerner <twoerner@redhat.com>
359 - reverted ipv6 fix, because it disables the ipv6 at all (rhbz#236888)
360
361 * Fri Jul 13 2007 Steve Conklin <sconklin@redhat.com> - 1.3.8-1
362 - New version 1.3.8
363
364 * Mon Apr 23 2007 Jeremy Katz <katzj@redhat.com> - 1.3.7-2
365 - fix error when ipv6 support isn't loaded in the kernel (#236888)
366
367 * Wed Jan 10 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1.1
368 - fixed installation of secmark modules
369
370 * Tue Jan  9 2007 Thomas Woerner <twoerner@redhat.com> 1.3.7-1
371 - new verison 1.3.7
372 - iptc is not a public interface and therefore not installed anymore
373 - dropped upstream secmark patch
374
375 * Thu Sep 19 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-2
376 - added secmark iptables patches (#201573)
377
378 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2.1
379 - rebuild
380
381 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.2
382 - bump again for double-long bug on ppc(64)
383
384 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.5-1.1
385 - rebuilt for new gcc4.1 snapshot and glibc changes
386
387 * Thu Feb  2 2006 Thomas Woerner <twoerner@redhat.com> 1.3.5-1
388 - new version 1.3.5
389 - fixed init script to set policy for raw tables, too (#179094)
390
391 * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 1.3.4-3
392 - added important iptables header files to devel package
393
394 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
395 - rebuilt
396
397 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-2
398 - fix for plugin problem: link with "gcc -shared" instead of "ld -shared" and 
399   replace "_init" with "__attribute((constructor)) my_init"
400
401 * Fri Nov 25 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1.1
402 - rebuild due to unresolved symbols in shared libraries
403
404 * Fri Nov 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.4-1
405 - new version 1.3.4
406 - dropped free_opts patch (upstream fixed)
407 - made libipq PIC (#158623)
408 - additional configuration options for iptables startup script (#172929)
409   Thanks to Jan Gruenwald for the patch
410 - spec file cleanup (dropped linux_header define and usage)
411
412 * Mon Jul 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.2-1
413 - new version 1.3.2 with additional patch for the misplaced free_opts call
414   from Marcus Sundberg
415
416 * Wed May 11 2005 Thomas Woerner <twoerner@redhat.com> 1.3.1-1
417 - new version 1.3.1
418
419 * Fri Mar 18 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-2
420 - Remove unnecessary explicit kernel dep (#146142)
421 - Fixed out of bounds accesses (#131848): Thanks to Steve Grubb
422   for the patch
423 - Adapted iptables-config to reference to modprobe.conf (#150143)
424 - Remove misleading message (#140154): Thanks to Ulrich Drepper
425   for the patch
426
427 * Mon Feb 21 2005 Thomas Woerner <twoerner@redhat.com> 1.3.0-1
428 - new version 1.3.0
429
430 * Thu Nov 11 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.2
431 - fixed autoload problem in iptables and ip6tables (CAN-2004-0986)
432
433 * Fri Sep 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3.1
434 - changed default behaviour for IPTABLES_STATUS_NUMERIC to "yes" (#129731)
435 - modified config file to match this change and un-commented variables with
436   default values
437
438 * Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-3
439 - applied second part of cleanup patch from (#131848): thanks to Steve Grubb
440   for the patch
441
442 * Wed Aug 25 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-2
443 - fixed free bug in iptables (#128322)
444
445 * Tue Jun 22 2004 Thomas Woerner <twoerner@redhat.com> 1.2.11-1
446 - new version 1.2.11
447
448 * Thu Jun 17 2004 Thomas Woerner <twoerner@redhat.com> 1.2.10-1
449 - new version 1.2.10
450
451 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
452 - rebuilt
453
454 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
455 - rebuilt
456
457 * Thu Feb 26 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-2.3
458 - fixed iptables-restore -c fault if there are no counters (#116421)
459
460 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
461 - rebuilt
462
463 * Sun Jan  25 2004 Dan Walsh <dwalsh@redhat.com> 1.2.9-1.2
464 - Close File descriptors to prevent SELinux error message
465
466 * Wed Jan  7 2004 Thomas Woerner <twoerner@redhat.com> 1.2.9-1.1
467 - rebuild
468
469 * Wed Dec 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.9-1
470 - vew version 1.2.9
471 - new config options in ipXtables-config:
472   IPTABLES_MODULES_UNLOAD
473 - more documentation in ipXtables-config
474 - fix for netlink security issue in libipq (devel package)
475 - print fix for libipt_icmp (#109546)
476
477 * Thu Oct 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-13
478 - marked all messages in iptables init script for translation (#107462)
479 - enabled devel package (#105884, #106101)
480 - bumped build for fedora for libipt_recent.so (#106002)
481
482 * Tue Sep 23 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-12.1
483 - fixed lost udp port range in ip6tables-save (#104484)
484 - fixed non numeric multiport port output in ipXtables-savs
485
486 * Mon Sep 22 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.2.8-11
487 - do not link against -lnsl
488
489 * Wed Sep 17 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-10
490 - made variables in rmmod_r local
491
492 * Tue Jul 22 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-9
493 - fixed permission for init script
494
495 * Sat Jul 19 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-8
496 - fixed save when iptables file is missing and iptables-config permissions
497
498 * Tue Jul  8 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-7
499 - fixes for ip6tables: module unloading, setting policy only for existing 
500   tables
501
502 * Thu Jul  3 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-6
503 - IPTABLES_SAVE_COUNTER defaults to no, now
504 - install config file in /etc/sysconfig
505 - exchange unload of ip_tables and ip_conntrack
506 - fixed start function
507
508 * Wed Jul  2 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-5
509 - new config option IPTABLES_SAVE_ON_RESTART
510 - init script: new status, save and restart
511 - fixes #44905, #65389, #80785, #82860, #91040, #91560 and #91374
512
513 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-4
514 - new config option IPTABLES_STATUS_NUMERIC
515 - cleared IPTABLES_MODULES in iptables-config
516
517 * Mon Jun 30 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-3
518 - new init scripts
519
520 * Sat Jun 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
521 - remove check for very old kernel versions in init scripts
522 - sync up both init scripts and remove some further ugly things
523 - add some docu into rpm
524
525 * Thu Jun 26  2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-2
526 - rebuild
527
528 * Mon Jun 16 2003 Thomas Woerner <twoerner@redhat.com> 1.2.8-1
529 - update to 1.2.8
530
531 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
532 - rebuilt
533
534 * Mon Jan 13 2003 Bill Nottingham <notting@redhat.com> 1.2.7a-1
535 - update to 1.2.7a
536 - add a plethora of bugfixes courtesy Michael Schwendt <mschewndt@yahoo.com>
537
538 * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.2.6a-3
539 - Fix multilib
540
541 * Wed Aug 07 2002 Karsten Hopp <karsten@redhat.de>
542 - fixed iptables and ip6tables initscript output, based on #70511
543 - check return status of all iptables calls, not just the last one
544   in a 'for' loop.
545
546 * Mon Jul 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.6a-1
547 - 1.2.6a (bugfix release, #69747)
548
549 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
550 - automated rebuild
551
552 * Thu May 23 2002 Tim Powers <timp@redhat.com>
553 - automated rebuild
554
555 * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-3
556 - Add some fixes from CVS, fixing bug #60465
557
558 * Tue Feb 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-2
559 - Merge ip6tables improvements from Ian Prowell <iprowell@prowell.org>
560   #59402
561 - Update URL (#59354)
562 - Use /sbin/chkconfig rather than chkconfig in %%postun script
563
564 * Fri Jan 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.5-1
565 - 1.2.5
566
567 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
568 - automated rebuild
569
570 * Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-2
571 - Fix %%preun script
572
573 * Tue Oct 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.4-1
574 - Update to 1.2.4 (various fixes, including security fixes; among others:
575   #42990, #50500, #53325, #54280)
576 - Fix init script (#31133)
577
578 * Mon Sep  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.3-1
579 - 1.2.3 (5 security fixes, some other fixes)
580 - Fix updating (#53032)
581
582 * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-4
583 - Fix #50990
584 - Add some fixes from current CVS; should fix #52620
585
586 * Mon Jul 16 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-3
587 - Add some fixes from the current CVS tree; fixes #49154 and some IPv6
588   issues
589
590 * Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-2
591 - Fix iptables-save reject-with (#45632), Patch from Michael Schwendt
592   <mschwendt@yahoo.com>
593
594 * Tue May  8 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.2-1
595 - 1.2.2
596
597 * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
598 - 1.2.1a, fixes #28412, #31136, #31460, #31133
599
600 * Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
601 - Yet another initscript fix (#30173)
602 - Fix the fixes; they fixed some issues but broke more important
603   stuff :/ (#30176)
604
605 * Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
606 - Fix up initscript (#27962)
607 - Add fixes from CVS to iptables-{restore,save}, fixing #28412
608
609 * Fri Feb 09 2001 Karsten Hopp <karsten@redhat.de>
610 - create /etc/sysconfig/iptables mode 600 (same problem as #24245)
611
612 * Mon Feb 05 2001 Karsten Hopp <karsten@redhat.de>
613 - fix bugzilla #25986 (initscript not marked as config file)
614 - fix bugzilla #25962 (iptables-restore)
615 - mv chkconfig --del from postun to preun
616
617 * Thu Feb  1 2001 Trond Eivind Glomsrød <teg@redhat.com>
618 - Fix check for ipchains
619
620 * Mon Jan 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
621 - Some fixes to init scripts
622
623 * Wed Jan 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
624 - Add some fixes from CVS, fixes among other things Bug #24732
625
626 * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
627 - Add missing man pages, fix up init script (Bug #17676)
628
629 * Mon Jan 15 2001 Bill Nottingham <notting@redhat.com>
630 - add init script
631
632 * Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
633 - 1.2
634 - fix up ipv6 split
635 - add init script
636 - Move the plugins from /usr/lib/iptables to /lib/iptables.
637   This needs to work before /usr is mounted...
638 - Use -O1 on alpha (compiler bug)
639
640 * Sat Jan  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
641 - 1.1.2
642 - Add IPv6 support (in separate package)
643
644 * Thu Aug 17 2000 Bill Nottingham <notting@redhat.com>
645 - build everywhere
646
647 * Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
648 - 1.1.1
649
650 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
651 - automatic rebuild
652
653 * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
654 - move iptables to /sbin.
655 - excludearch alpha for now, not building there because of compiler bug(?)
656
657 * Fri Jun  9 2000 Bill Nottingham <notting@redhat.com>
658 - don't obsolete ipchains either
659 - update to 1.1.0
660
661 * Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
662 - remove explicit kernel requirement
663
664 * Tue May  2 2000 Bernhard Rosenkränzer <bero@redhat.com>
665 - initial package