bump to 1.4.10
[iptables.git] / iptables.spec
index 88f2281..aaf5d03 100644 (file)
@@ -1,15 +1,30 @@
-Name: iptables
+#
+# $Id$
+#
+%define url $URL$
+
+%define name iptables
+%define version 1.4.10
+%define taglevel 0
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+
 Summary: Tools for managing Linux kernel packet filtering capabilities
-Version: 1.4.7
-Release: 2%{?dist}
+Name: %{name}
+Version: %{version}
+Release: %{release}
 Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
 Source1: iptables.init
 Source2: iptables-config
 Source3: planetlab-config
 Patch1: copy-xid.patch
 Group: System Environment/Base
-URL: http://www.netfilter.org/
-BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 License: GPLv2
 BuildRequires: libselinux-devel
 BuildRequires: kernel-headers
@@ -96,6 +111,7 @@ sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE1} > ip6ta
 install -c -m 755 ip6tables.init %{buildroot}/etc/rc.d/init.d/ip6tables
 install -d -m 755 %{buildroot}/etc/sysconfig
 install -c -m 755 %{SOURCE2} %{buildroot}/etc/sysconfig/iptables-config
+install -c -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/iptables
 sed -e 's;iptables;ip6tables;g' -e 's;IPTABLES;IP6TABLES;g' < %{SOURCE2} > ip6tables-config
 install -c -m 755 ip6tables-config %{buildroot}/etc/sysconfig/ip6tables-config
 
@@ -105,6 +121,7 @@ rm -rf %{buildroot}
 %post
 /sbin/ldconfig
 /sbin/chkconfig --add iptables
+service iptables restart
 
 %postun -p /sbin/ldconfig
 
@@ -126,6 +143,7 @@ fi
 %doc COPYING INSTALL INCOMPATIBILITIES
 %attr(0755,root,root) /etc/rc.d/init.d/iptables
 %config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables-config
+%config(noreplace) %attr(0600,root,root) /etc/sysconfig/iptables
 /sbin/iptables*
 /bin/iptables-xml
 %{_mandir}/man8/iptables*
@@ -164,6 +182,19 @@ fi
 %{_libdir}/pkgconfig/xtables.pc
 
 %changelog
+* Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-5
+- Restart iptables service after package upgrades
+
+* Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-4
+- Restore iIPTABLES_MODULES list
+
+* Mon May 03 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iptables-1.4.7-3
+- drop backward compatibility with older iptables versions as new kernels only support v2
+- remove unused modules from iptables-config file
+
+* Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iptables-1.4.7-2
+- fixed specfile for duplicate URL
+
 * Wed Mar 24 2010 Thomas Woerner <twoerner@redhat.com> 1.4.7-2
 - added default values for IPTABLES_STATUS_VERBOSE and
   IPTABLES_STATUS_LINENUMBERS in init script