patch for centos
[libnl.git] / libnl.spec
1 Summary: Convenience library for kernel netlink sockets
2 Group: Development/Libraries
3 License: LGPL
4 Name: libnl
5 Version: 1.1
6 Release: 1%{?dist}
7 URL: http://people.suug.ch/~tgr/libnl/
8 Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10 BuildRequires: doxygen
11 Patch1: libnl-1.0-pre5-static.patch
12 Patch2: libnl-1.0-pre5-debuginfo.patch
13 Patch3: libnl-1.0-pre8-use-vasprintf-retval.patch
14 Patch4: libnl-1.0-pre8-more-build-output.patch
15 Patch5: libnl-1.0-missing-declaration.patch
16
17 %description
18 This package contains a convenience library to simplify
19 using the Linux kernel's netlink sockets interface for
20 network manipulation
21
22 %package devel
23 Summary: Libraries and headers for using libnl
24 Group: Development/Libraries
25 Requires: %{name} = %{version}-%{release}
26 Requires: kernel-headers
27
28 %description devel
29 This package contains various headers for using libnl
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34 %patch1 -p1 -b .build-static
35 %patch2 -p1 -b .debuginfo
36 %patch3 -p1 -b .use-vasprintf-retval
37 %patch4 -p1 -b .more-build-output
38 %patch5 -p1 -b .missing-declaration
39
40 %build
41 %configure
42 make
43
44 %install
45 %{__rm} -rf $RPM_BUILD_ROOT
46 make install DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 %{__rm} -rf $RPM_BUILD_ROOT
50
51 %post -p /sbin/ldconfig
52 %postun -p /sbin/ldconfig
53
54 %files
55 %defattr(-,root,root)
56 %{_libdir}/%{name}.so.*
57 %doc COPYING
58
59 %files devel
60 %defattr(-,root,root,0755)
61 %{_includedir}/netlink/
62 %doc doc/*
63 %{_libdir}/%{name}.so
64 %{_libdir}/%{name}.a
65 %{_libdir}/pkgconfig/%{name}-1.pc
66
67 %changelog
68 * Mon Feb 11 2008 Dan Williams <dcbw@redhat.com> - 1.1-1
69 - Update to version 1.1
70
71 * Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.15.pre8.git20071218
72 - Handle removal of include/linux/ip_mp_alg.h in 2.6.24
73
74 * Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.14.pre8.git20071217
75 - devel package should require kernel-headers
76
77 * Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.13.pre8.git20071217
78 - Add dist tag to revision 
79
80 * Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.12.pre8.git20071217
81 - Update to -pre8 + fixes (rh #401761)
82
83 * Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
84 - Fix nl_recv() for ppc64
85
86 * Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.10.pre5.3
87 - unbreak the pkgconfig file
88
89 * Wed Jul 26 2006 Matthias Clasen <mclasen@redhat.com> - 1.0-0.10.pre5.2
90 - Fix the pkgconfig file on 64-bit systems (#197176)
91
92 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.10.pre5.1
93 - rebuild
94
95 * Thu Jun 15 2006 Peter Jones <pjones@redhat.com> 1.0-0.10.pre5
96 - Fix debuginfo generation.
97
98 * Fri May 26 2006 Jason Vas Dias <jvdias@redhat.com> 1.0-0.9.pre5
99 - Allow build to succeed with new gcc / glibc-kernheaders
100   (compile failed on __u64 redefinition on x86_64).
101 - Add a static %{_libdir}/libnl.a library to libnl-devel for
102   programs that might need to do a static link to libnl.
103   Added after consultation with Christopher Aillon.
104
105 * Tue Feb 12 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.8.pre5
106 - Rebuild
107
108 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0-0.7.pre5.1
109 - rebuilt for new gcc4.1 snapshot and glibc changes
110
111 * Mon Jan 16 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.7.pre5
112 - Add patch to not chown files to root.root during make install; it
113   happens normally.
114
115 * Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.6.pre5
116 - Correctly install the pkgconfig file
117
118 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
119 - rebuilt
120
121 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.5.pre5
122 - Fix 64bit LIBDIR issue; use $LIBDIR instead of $PREFIX/lib
123
124 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.4.pre5
125 - Update to 1.0-pre5
126
127 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.3.pre4
128 - Update to 1.0-pre4
129
130 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.2.pre3
131 - Minor specfile cleanup
132
133 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.1.pre3
134 - Split into main and devel packages
135
136 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.0.pre3
137 - initial build