0b7fe81a487323cb3cca52d1ea6f0554038704ff
[libnl.git] / libnl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name libnl
7 %define version 1.0
8 %define taglevel 11
9 %define preversion pre6
10
11 %define release %{taglevel}.%{preversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: Convenience library for kernel netlink sockets
14 Group: Development/Libraries
15 Version: %{version}
16 Release: %{release}
17 License: LGPL
18 Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}-%{preversion}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25 #URL: http://people.suug.ch/~tgr/libnl/
26
27 BuildRequires: doxygen
28 #Patch3: libnl-1.0-pre6-static.patch
29 #Patch4: libnl-1.0-pre5-__u64_x86_64.patch
30 #Patch5: libnl-1.0-pre6-debuginfo.patch
31
32 %description
33 This package contains a convenience library to simplify
34 using the Linux kernel's netlink sockets interface for
35 network manipulation
36
37 %package devel
38 Summary: Libraries and headers for using libnl
39 Group: Development/Libraries
40 Requires: %{name} = %{version}-%{release}
41
42 %description devel
43 This package contains various headers for using libnl
44
45
46 %prep
47 %setup -q -n libnl-%{version}-%{preversion}
48 #%patch3 -p1
49 #%patch4 -p1
50 #%patch5 -p1
51
52 %build
53 %configure
54 make
55
56 %install
57 %{__rm} -rf $RPM_BUILD_ROOT
58 make install DESTDIR=$RPM_BUILD_ROOT
59
60 %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
61 cat >libnl-1.pc <<EOF
62 prefix=%{_prefix}
63 exec_prefix=%{_prefix}
64 libdir=%{_libdir}
65 includedir=%{_includedir}
66
67 Name: libnl
68 Description: Convenience library for netlink sockets
69 Version: %{version}-%{release}
70 Libs: -L%{_libdir} -lnl
71 Cflags:
72 EOF
73
74 %{__install} -m 644 libnl-1.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
75
76 %clean
77 %{__rm} -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(-,root,root)
84 %{_libdir}/%{name}.so.*
85 %doc COPYING
86
87 %files devel
88 %defattr(-,root,root,0755)
89 %{_includedir}/netlink/
90 %doc doc/*
91 %{_libdir}/%{name}.so
92 %{_libdir}/%{name}.a
93 %{_libdir}/pkgconfig/%{name}-1.pc
94
95 %changelog
96 * Thu Jul 26 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 1.0-0.11.pre6
97 - Upgrade to pre6
98
99 * Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
100 - Fix nl_recv() for ppc64
101
102 * Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.10.pre5.3
103 - unbreak the pkgconfig file
104
105 * Wed Jul 26 2006 Matthias Clasen <mclasen@redhat.com> - 1.0-0.10.pre5.2
106 - Fix the pkgconfig file on 64-bit systems (#197176)
107
108 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.10.pre5.1
109 - rebuild
110
111 * Thu Jun 15 2006 Peter Jones <pjones@redhat.com> 1.0-0.10.pre5
112 - Fix debuginfo generation.
113
114 * Fri May 26 2006 Jason Vas Dias <jvdias@redhat.com> 1.0-0.9.pre5
115 - Allow build to succeed with new gcc / glibc-kernheaders
116   (compile failed on __u64 redefinition on x86_64).
117 - Add a static %{_libdir}/libnl.a library to libnl-devel for
118   programs that might need to do a static link to libnl.
119   Added after consultation with Christopher Aillon.
120
121 * Tue Feb 12 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.8.pre5
122 - Rebuild
123
124 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0-0.7.pre5.1
125 - rebuilt for new gcc4.1 snapshot and glibc changes
126
127 * Mon Jan 16 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.7.pre5
128 - Add patch to not chown files to root.root during make install; it
129   happens normally.
130
131 * Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.6.pre5
132 - Correctly install the pkgconfig file
133
134 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
135 - rebuilt
136
137 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.5.pre5
138 - Fix 64bit LIBDIR issue; use $LIBDIR instead of $PREFIX/lib
139
140 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.4.pre5
141 - Update to 1.0-pre5
142
143 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.3.pre4
144 - Update to 1.0-pre4
145
146 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.2.pre3
147 - Minor specfile cleanup
148
149 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.1.pre3
150 - Split into main and devel packages
151
152 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.0.pre3
153 - initial build