This commit was generated by cvs2svn to compensate for changes in r786,
[libnl.git] / libnl.spec
1 %define preversion pre6
2
3 Summary: Convenience library for kernel netlink sockets
4 Group: Development/Libraries
5 License: LGPL
6 Name: libnl
7 Version: 1.0
8 Release: 0.11.%{preversion}
9 URL: http://people.suug.ch/~tgr/libnl/
10 Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}-%{preversion}.tar.gz
11 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12 BuildRequires: doxygen
13 #Patch3: libnl-1.0-pre6-static.patch
14 #Patch4: libnl-1.0-pre5-__u64_x86_64.patch
15 #Patch5: libnl-1.0-pre6-debuginfo.patch
16
17 %description
18 This package contains a convenience library to simplify
19 using the Linux kernel's netlink sockets interface for
20 network manipulation
21
22 %package devel
23 Summary: Libraries and headers for using libnl
24 Group: Development/Libraries
25 Requires: %{name} = %{version}-%{release}
26
27 %description devel
28 This package contains various headers for using libnl
29
30
31 %prep
32 %setup -q -n libnl-%{version}-%{preversion}
33 #%patch3 -p1
34 #%patch4 -p1
35 #%patch5 -p1
36
37 %build
38 %configure
39 make
40
41 %install
42 %{__rm} -rf $RPM_BUILD_ROOT
43 make install DESTDIR=$RPM_BUILD_ROOT
44
45 %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
46 cat >libnl-1.pc <<EOF
47 prefix=%{_prefix}
48 exec_prefix=%{_prefix}
49 libdir=%{_libdir}
50 includedir=%{_includedir}
51
52 Name: libnl
53 Description: Convenience library for netlink sockets
54 Version: %{version}-%{release}
55 Libs: -L%{_libdir} -lnl
56 Cflags:
57 EOF
58
59 %{__install} -m 644 libnl-1.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
60
61 %clean
62 %{__rm} -rf $RPM_BUILD_ROOT
63
64 %post -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(-,root,root)
69 %{_libdir}/%{name}.so.*
70 %doc COPYING
71
72 %files devel
73 %defattr(-,root,root,0755)
74 %{_includedir}/netlink/
75 %doc doc/*
76 %{_libdir}/%{name}.so
77 %{_libdir}/%{name}.a
78 %{_libdir}/pkgconfig/%{name}-1.pc
79
80 %changelog
81 * Thu Jul 26 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 1.0-0.11.pre6
82 - Upgrade to pre6
83
84 * Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
85 - Fix nl_recv() for ppc64
86
87 * Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.10.pre5.3
88 - unbreak the pkgconfig file
89
90 * Wed Jul 26 2006 Matthias Clasen <mclasen@redhat.com> - 1.0-0.10.pre5.2
91 - Fix the pkgconfig file on 64-bit systems (#197176)
92
93 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.10.pre5.1
94 - rebuild
95
96 * Thu Jun 15 2006 Peter Jones <pjones@redhat.com> 1.0-0.10.pre5
97 - Fix debuginfo generation.
98
99 * Fri May 26 2006 Jason Vas Dias <jvdias@redhat.com> 1.0-0.9.pre5
100 - Allow build to succeed with new gcc / glibc-kernheaders
101   (compile failed on __u64 redefinition on x86_64).
102 - Add a static %{_libdir}/libnl.a library to libnl-devel for
103   programs that might need to do a static link to libnl.
104   Added after consultation with Christopher Aillon.
105
106 * Tue Feb 12 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.8.pre5
107 - Rebuild
108
109 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0-0.7.pre5.1
110 - rebuilt for new gcc4.1 snapshot and glibc changes
111
112 * Mon Jan 16 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.7.pre5
113 - Add patch to not chown files to root.root during make install; it
114   happens normally.
115
116 * Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.6.pre5
117 - Correctly install the pkgconfig file
118
119 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
120 - rebuilt
121
122 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.5.pre5
123 - Fix 64bit LIBDIR issue; use $LIBDIR instead of $PREFIX/lib
124
125 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.4.pre5
126 - Update to 1.0-pre5
127
128 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.3.pre4
129 - Update to 1.0-pre4
130
131 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.2.pre3
132 - Minor specfile cleanup
133
134 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.1.pre3
135 - Split into main and devel packages
136
137 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.0.pre3
138 - initial build