enable tagging
[libnl.git] / libnl.spec
1 %define url $URL$
2
3 %define name libnl
4 %define version 1.1
5 %define taglevel 1
6
7 Summary: Convenience library for kernel netlink sockets
8 Group: Development/Libraries
9 License: LGPL
10 Name: %{name}
11 Version: %{version}
12 Release: %{taglevel}%{?dist}
13 URL: http://people.suug.ch/~tgr/libnl/
14 Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}.tar.gz
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16 BuildRequires: doxygen
17 Patch1: libnl-1.0-pre5-static.patch
18 Patch2: libnl-1.0-pre5-debuginfo.patch
19 Patch3: libnl-1.0-pre8-use-vasprintf-retval.patch
20 Patch4: libnl-1.0-pre8-more-build-output.patch
21 Patch5: libnl-1.0-missing-declaration.patch
22
23 %description
24 This package contains a convenience library to simplify
25 using the Linux kernel's netlink sockets interface for
26 network manipulation
27
28 %package devel
29 Summary: Libraries and headers for using libnl
30 Group: Development/Libraries
31 Requires: %{name} = %{version}-%{release}
32 Requires: kernel-headers
33
34 %description devel
35 This package contains various headers for using libnl
36
37
38 %prep
39 %setup -q -n %{name}-%{version}
40 %patch1 -p1 -b .build-static
41 %patch2 -p1 -b .debuginfo
42 %patch3 -p1 -b .use-vasprintf-retval
43 %patch4 -p1 -b .more-build-output
44 %patch5 -p1 -b .missing-declaration
45
46 %build
47 %configure
48 make
49
50 %install
51 %{__rm} -rf $RPM_BUILD_ROOT
52 make install DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 %{__rm} -rf $RPM_BUILD_ROOT
56
57 %post -p /sbin/ldconfig
58 %postun -p /sbin/ldconfig
59
60 %files
61 %defattr(-,root,root)
62 %{_libdir}/%{name}.so.*
63 %doc COPYING
64
65 %files devel
66 %defattr(-,root,root,0755)
67 %{_includedir}/netlink/
68 %doc doc/*
69 %{_libdir}/%{name}.so
70 %{_libdir}/%{name}.a
71 %{_libdir}/pkgconfig/%{name}-1.pc
72
73 %changelog
74 * Mon Feb 11 2008 Dan Williams <dcbw@redhat.com> - 1.1-1
75 - Update to version 1.1
76
77 * Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.15.pre8.git20071218
78 - Handle removal of include/linux/ip_mp_alg.h in 2.6.24
79
80 * Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.14.pre8.git20071217
81 - devel package should require kernel-headers
82
83 * Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.13.pre8.git20071217
84 - Add dist tag to revision 
85
86 * Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.12.pre8.git20071217
87 - Update to -pre8 + fixes (rh #401761)
88
89 * Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
90 - Fix nl_recv() for ppc64
91
92 * Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.10.pre5.3
93 - unbreak the pkgconfig file
94
95 * Wed Jul 26 2006 Matthias Clasen <mclasen@redhat.com> - 1.0-0.10.pre5.2
96 - Fix the pkgconfig file on 64-bit systems (#197176)
97
98 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.10.pre5.1
99 - rebuild
100
101 * Thu Jun 15 2006 Peter Jones <pjones@redhat.com> 1.0-0.10.pre5
102 - Fix debuginfo generation.
103
104 * Fri May 26 2006 Jason Vas Dias <jvdias@redhat.com> 1.0-0.9.pre5
105 - Allow build to succeed with new gcc / glibc-kernheaders
106   (compile failed on __u64 redefinition on x86_64).
107 - Add a static %{_libdir}/libnl.a library to libnl-devel for
108   programs that might need to do a static link to libnl.
109   Added after consultation with Christopher Aillon.
110
111 * Tue Feb 12 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.8.pre5
112 - Rebuild
113
114 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0-0.7.pre5.1
115 - rebuilt for new gcc4.1 snapshot and glibc changes
116
117 * Mon Jan 16 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.7.pre5
118 - Add patch to not chown files to root.root during make install; it
119   happens normally.
120
121 * Mon Jan  9 2006 Christopher Aillon <caillon@redhat.com> 1.0-0.6.pre5
122 - Correctly install the pkgconfig file
123
124 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
125 - rebuilt
126
127 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.5.pre5
128 - Fix 64bit LIBDIR issue; use $LIBDIR instead of $PREFIX/lib
129
130 * Wed Nov  2 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.4.pre5
131 - Update to 1.0-pre5
132
133 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.3.pre4
134 - Update to 1.0-pre4
135
136 * Tue Nov  1 2005 Christopher Aillon <caillon@redhat.com> 1.0-0.2.pre3
137 - Minor specfile cleanup
138
139 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.1.pre3
140 - Split into main and devel packages
141
142 * Thu Oct 27 2005 Dan Williams <dcbw@redhat.com> 1.0-0.0.pre3
143 - initial build