Tagging module libnl - libnl-1.1-2
[libnl.git] / libnl.spec
index 192d0ae..0756226 100644 (file)
@@ -1,34 +1,24 @@
-#
-# $Id$
-#
 %define url $URL$
 
 %define name libnl
-%define version 1.0
-%define taglevel 11
-%define preversion pre6
-
-%define release %{taglevel}.%{preversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define version 1.1
+%define taglevel 2
 
 Summary: Convenience library for kernel netlink sockets
 Group: Development/Libraries
+License: LGPL
 Name: %{name}
 Version: %{version}
-Release: %{release}
-License: LGPL
-Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}-%{preversion}.tar.gz
+Release: %{taglevel}%{?dist}
+URL: http://people.suug.ch/~tgr/libnl/
+Source: http://people.suug.ch/~tgr/libnl/files/libnl-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-
-Vendor: PlanetLab
-Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
-#URL: http://people.suug.ch/~tgr/libnl/
-
 BuildRequires: doxygen
-#Patch3: libnl-1.0-pre6-static.patch
-#Patch4: libnl-1.0-pre5-__u64_x86_64.patch
-#Patch5: libnl-1.0-pre6-debuginfo.patch
+Patch1: libnl-1.0-pre5-static.patch
+Patch2: libnl-1.0-pre5-debuginfo.patch
+Patch3: libnl-1.0-pre8-use-vasprintf-retval.patch
+Patch4: libnl-1.0-pre8-more-build-output.patch
+Patch5: libnl-1.0-missing-declaration.patch
 
 %description
 This package contains a convenience library to simplify
@@ -39,16 +29,19 @@ network manipulation
 Summary: Libraries and headers for using libnl
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
+Requires: kernel-headers
 
 %description devel
 This package contains various headers for using libnl
 
 
 %prep
-%setup -q -n libnl-%{version}-%{preversion}
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
+%setup -q -n %{name}-%{version}
+%patch1 -p1 -b .build-static
+%patch2 -p1 -b .debuginfo
+%patch3 -p1 -b .use-vasprintf-retval
+%patch4 -p1 -b .more-build-output
+%patch5 -p1 -b .missing-declaration
 
 %build
 %configure
@@ -58,22 +51,6 @@ make
 %{__rm} -rf $RPM_BUILD_ROOT
 make install DESTDIR=$RPM_BUILD_ROOT
 
-%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
-cat >libnl-1.pc <<EOF
-prefix=%{_prefix}
-exec_prefix=%{_prefix}
-libdir=%{_libdir}
-includedir=%{_includedir}
-
-Name: libnl
-Description: Convenience library for netlink sockets
-Version: %{version}-%{release}
-Libs: -L%{_libdir} -lnl
-Cflags:
-EOF
-
-%{__install} -m 644 libnl-1.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
-
 %clean
 %{__rm} -rf $RPM_BUILD_ROOT
 
@@ -94,8 +71,23 @@ EOF
 %{_libdir}/pkgconfig/%{name}-1.pc
 
 %changelog
-* Thu Jul 26 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 1.0-0.11.pre6
-- Upgrade to pre6
+* Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libnl-1.1-2
+- pull source tarball from planet-lab.org rather than onelab.eu
+
+* Mon Feb 11 2008 Dan Williams <dcbw@redhat.com> - 1.1-1
+- Update to version 1.1
+
+* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.15.pre8.git20071218
+- Handle removal of include/linux/ip_mp_alg.h in 2.6.24
+
+* Tue Dec 18 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.14.pre8.git20071217
+- devel package should require kernel-headers
+
+* Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.13.pre8.git20071217
+- Add dist tag to revision 
+
+* Mon Dec 17 2007 Dan Williams <dcbw@redhat.com> - 1.0-0.12.pre8.git20071217
+- Update to -pre8 + fixes (rh #401761)
 
 * Mon Aug 14 2006 Peter Jones <pjones@redhat.com> - 1.0-0.10.pre5.4
 - Fix nl_recv() for ppc64