Setting tag libvirt-python-1.2.11-2
[libvirt-python.git] / libvirt-python.spec
index 424c82a..ba5cf24 100644 (file)
@@ -1,11 +1,16 @@
 # -*- rpm-spec -*-
 
-%define mainstream_version 1.2.3
+%define mainstream_version 1.2.11
 %define module_version_varname mainstream_version
-%define taglevel 0
+%define taglevel 2
 
 # Disable python 3 bindings
 %define with_python3 0
+%if 0%{?fedora} > 18
+# turning this off as we do not need it in PL for now
+#%define with_python3 1
+%define with_python3 0
+%endif
 
 Summary: The libvirt virtualization API python2 binding
 Name: libvirt-python
@@ -17,16 +22,12 @@ License: LGPLv2+
 Group: Development/Libraries
 BuildRequires: libvirt-devel = %{version}-%{release}
 BuildRequires: python-devel
+BuildRequires: python-nose
+BuildRequires: python-lxml
 %if %{with_python3}
 BuildRequires: python3-devel
-%endif
-
-%if %{with_python3}
-%package -n libvirt-python3
-Summary: The libvirt virtualization API python3 binding
-Url: http://libvirt.org
-License: LGPLv2+
-Group: Development/Libraries
+BuildRequires: python3-nose
+BuildRequires: python3-lxml
 %endif
 
 # Don't want provides for python shared objects
@@ -40,6 +41,12 @@ supplied by the libvirt library to use the virtualization capabilities
 of recent versions of Linux (and other OSes).
 
 %if %{with_python3}
+%package -n libvirt-python3
+Summary: The libvirt virtualization API python3 binding
+Url: http://libvirt.org
+License: LGPLv2+
+Group: Development/Libraries
+
 %description -n libvirt-python3
 The libvirt-python package contains a module that permits applications
 written in the Python programming language to use the interface
@@ -85,6 +92,15 @@ rm -f %{buildroot}%{_libdir}/python*/site-packages/*egg-info
 %endif
 
 %changelog
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-python-1.2.11-2
+- 1.2.11
+
+* Thu Jul 17 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-python-1.2.5-1
+- mainstream as-is
+
+* Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-python-1.2.3-2
+- 1.2.3
+
 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - libvirt-python-1.2.1-1
 - builds fine on f{18,20}