Setting tag lxc-userspace-2.0-0
[lxc-userspace.git] / lxc-userspace.spec
1 %define name lxc-userspace
2 %define version 2.0
3 %define taglevel 0
4
5 %define percent %
6 %define braop \{
7 %define bracl \}
8
9 # this is getting really a lot of stuff, could be made simpler probably
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Userspace tools for switching between lxc containers
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: lxc-userspace-%{version}.tar.gz
25 Requires: binutils
26 # lxcsu uses pgrep to compute the container's init_pid
27 Requires: procps-ng
28
29 Obsoletes: lxctools
30
31 %description
32 Userspace tools for switching between lxc containers.
33
34 %prep
35 %setup -q
36
37 %build
38 make
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/usr/sbin
42 install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
43 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
44 install -D -m 755 lxcsu-internal $RPM_BUILD_ROOT/usr/sbin/lxcsu-internal
45 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
46 cp build/lib*/setns*.so $RPM_BUILD_ROOT/usr/sbin
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 /usr/sbin/*
53
54 %post
55 chmod u+s /usr/sbin/vsh
56
57 %postun
58
59 %changelog
60 * Mon Jan 07 2019 Thierry <Parmentelat> - lxc-userspace-2.0-0
61 - ported to python3, including the setns C extension
62
63 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-12
64 - fix lxcsu to spot the right architecture for the container - was always using the host's arch
65
66 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-11
67 - reworked kvmsu
68
69 * Wed Mar 26 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-10
70 - lxcsu evaluates slice_uid earlier
71 - this is for old-installed f18 nodes like in PLE
72
73 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-9
74 - does not rely on capsh (actually this was the one in the sliver)
75 - use native capability dropping instead
76 - provides new slicesu binary
77 - suitable for libvirt-1.1 and above
78
79 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-8
80 - fix vsh permissions
81
82 * Sat Aug 31 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-7
83 - perform vsys sysctl inside of container
84 - remove unnecessary proc remounts
85 - prevent setting LD_PRELOAD if the library doesn't exist in image
86 - add --noslicehome option
87 - check /etc/lxcsu_default for default arguments
88 - fix permissions
89 - support conventional invocation of make
90
91 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-6
92 - merge back lxcsu and -internal into a single source file
93 - capsh --uid instead of --user that was not yet supported in f12 (hopefully tmp)
94
95 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-5
96 - entering in a slice now correctly ends up with right uid and pwd
97 - make sync
98
99 * Mon Jul 01 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-4
100 - Bug fixes:
101 - - lxcsu <slice_name> works again
102 - - pid namespace issue that would let slices see all processes
103
104 * Fri Jun 28 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-3
105 - Fixed bug that would let slices see all processes in root context.
106
107 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-2
108 - split into lxcsu{,-internal}
109
110 * Wed Jun 05 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-1
111 - rename module and package from lxctools into lxc-userspace
112
113 * Mon Jun 03 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxctools-0.9-8
114 - - Upgraded code for compatibility with kernel 3.6.9
115 - - Obsoleted modules for switching into mnt and pid namespaces
116 - - Added command to mount /proc if not mounted
117
118 * Wed May 29 2013 Andy Bavier <acb@cs.princeton.edu> - lxctools-0.9-7
119 - Use ArgumentParser, fix issue with sensing arch
120
121 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-6
122 - implements vm's arch
123
124 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-5
125 - more flexible and more robust lxcsu
126
127 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-4
128 - nicer polish to lxcsu returning the right thing
129
130 * Mon Mar 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-3
131 - lxcsu to propagate its forked process's return code
132
133 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-2
134 - various fixes