explicitly chdir to slice's homedir since bash does not seem to be willing to do...
[lxc-userspace.git] / lxc-userspace.spec
index e047b90..401f962 100644 (file)
@@ -1,6 +1,6 @@
 %define name lxc-userspace
 %define version 1.0
-%define taglevel 0
+%define taglevel 4
 
 %define percent %
 %define braop \{
@@ -39,6 +39,7 @@ make
 mkdir -p $RPM_BUILD_ROOT/usr/sbin
 install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
+install -D -m 755 lxcsu-internal $RPM_BUILD_ROOT/usr/sbin/lxcsu-internal
 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
 cp build/lib*/setns.so $RPM_BUILD_ROOT/usr/sbin
 
@@ -54,6 +55,20 @@ chmod u+s /usr/sbin/vsh
 %postun
 
 %changelog
+* Mon Jul 01 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-4
+- Bug fixes:
+- - lxcsu <slice_name> works again
+- - pid namespace issue that would let slices see all processes
+
+* Fri Jun 28 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-3
+- Fixed bug that would let slices see all processes in root context.
+
+* Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-2
+- split into lxcsu{,-internal}
+
+* Wed Jun 05 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-1
+- rename module and package from lxctools into lxc-userspace
+
 * Mon Jun 03 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxctools-0.9-8
 - - Upgraded code for compatibility with kernel 3.6.9
 - - Obsoleted modules for switching into mnt and pid namespaces