Setting tag lxc-userspace-2.0-0
[lxc-userspace.git] / lxc-userspace.spec
index 0d40082..b0e4da1 100644 (file)
@@ -1,6 +1,6 @@
 %define name lxc-userspace
-%define version 1.0
-%define taglevel 5
+%define version 2.0
+%define taglevel 0
 
 %define percent %
 %define braop \{
@@ -23,17 +23,19 @@ Group: System Environment/Kernel
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Source0: lxc-userspace-%{version}.tar.gz
 Requires: binutils
+# lxcsu uses pgrep to compute the container's init_pid
+Requires: procps-ng
 
 Obsoletes: lxctools
 
 %description
 Userspace tools for switching between lxc containers.
 
-%prep 
+%prep
 %setup -q
 
 %build
-make 
+make
 
 %install
 mkdir -p $RPM_BUILD_ROOT/usr/sbin
@@ -41,7 +43,7 @@ install -D -m 755 vsh $RPM_BUILD_ROOT/usr/sbin/vsh
 install -D -m 755 lxcsu $RPM_BUILD_ROOT/usr/sbin/lxcsu
 install -D -m 755 lxcsu-internal $RPM_BUILD_ROOT/usr/sbin/lxcsu-internal
 chmod u+s $RPM_BUILD_ROOT/usr/sbin/lxcsu
-cp build/lib*/setns.so $RPM_BUILD_ROOT/usr/sbin
+cp build/lib*/setns*.so $RPM_BUILD_ROOT/usr/sbin
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -55,6 +57,41 @@ chmod u+s /usr/sbin/vsh
 %postun
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - lxc-userspace-2.0-0
+- ported to python3, including the setns C extension
+
+* Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-12
+- fix lxcsu to spot the right architecture for the container - was always using the host's arch
+
+* Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-11
+- reworked kvmsu
+
+* Wed Mar 26 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-10
+- lxcsu evaluates slice_uid earlier
+- this is for old-installed f18 nodes like in PLE
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-9
+- does not rely on capsh (actually this was the one in the sliver)
+- use native capability dropping instead
+- provides new slicesu binary
+- suitable for libvirt-1.1 and above
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-8
+- fix vsh permissions
+
+* Sat Aug 31 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-7
+- perform vsys sysctl inside of container
+- remove unnecessary proc remounts
+- prevent setting LD_PRELOAD if the library doesn't exist in image
+- add --noslicehome option
+- check /etc/lxcsu_default for default arguments
+- fix permissions
+- support conventional invocation of make
+
+* Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-6
+- merge back lxcsu and -internal into a single source file
+- capsh --uid instead of --user that was not yet supported in f12 (hopefully tmp)
+
 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-5
 - entering in a slice now correctly ends up with right uid and pwd
 - make sync
@@ -95,4 +132,3 @@ chmod u+s /usr/sbin/vsh
 
 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxctools-0.9-2
 - various fixes
-