add a Requires: to procps-ng as we use pgrep in lxcsu to determine container's arch
[lxc-userspace.git] / lxc-userspace.spec
index e9e5375..cc48ec1 100644 (file)
@@ -1,6 +1,6 @@
 %define name lxc-userspace
 %define version 1.0
-%define taglevel 2
+%define taglevel 11
 
 %define percent %
 %define braop \{
@@ -23,6 +23,8 @@ Group: System Environment/Kernel
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Source0: lxc-userspace-%{version}.tar.gz
 Requires: binutils
+# lxcsu uses pgrep to compute the container's init_pid
+Requires: procps-ng
 
 Obsoletes: lxctools
 
@@ -55,6 +57,47 @@ chmod u+s /usr/sbin/vsh
 %postun
 
 %changelog
+* Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-11
+- reworked kvmsu
+
+* Wed Mar 26 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-10
+- lxcsu evaluates slice_uid earlier
+- this is for old-installed f18 nodes like in PLE
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-9
+- does not rely on capsh (actually this was the one in the sliver)
+- use native capability dropping instead
+- provides new slicesu binary
+- suitable for libvirt-1.1 and above
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-8
+- fix vsh permissions
+
+* Sat Aug 31 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-7
+- perform vsys sysctl inside of container
+- remove unnecessary proc remounts
+- prevent setting LD_PRELOAD if the library doesn't exist in image
+- add --noslicehome option
+- check /etc/lxcsu_default for default arguments
+- fix permissions
+- support conventional invocation of make
+
+* Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-6
+- merge back lxcsu and -internal into a single source file
+- capsh --uid instead of --user that was not yet supported in f12 (hopefully tmp)
+
+* Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-5
+- entering in a slice now correctly ends up with right uid and pwd
+- make sync
+
+* Mon Jul 01 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-4
+- Bug fixes:
+- - lxcsu <slice_name> works again
+- - pid namespace issue that would let slices see all processes
+
+* Fri Jun 28 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - lxc-userspace-1.0-3
+- Fixed bug that would let slices see all processes in root context.
+
 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - lxc-userspace-1.0-2
 - split into lxcsu{,-internal}