Setting tag Mom-2.3-2
[mom.git] / pl_mom.spec
index 34875f4..0fd2262 100644 (file)
@@ -1,6 +1,13 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name pl_mom
-%define version 0.4
-%define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define version 2.3
+%define taglevel 2
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
  
 Summary: PlanetLab node monitoring tools
 Name: %{name}
@@ -11,8 +18,9 @@ Group: System Environment/Kernel
 Source: %{name}-%{version}.tgz
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://cvs.planet-lab.org/cvs/pl_mom
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+#URL: http://cvs.planet-lab.org/cvs/pl_mom
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 Requires: expect
 # swapmon requires vps and bwlimit.py
@@ -28,9 +36,6 @@ process memory usage. At 90% utilization, resets the slice that is
 consuming the most physical memory. At 95% utilization, it reboots the
 machine to avoid a crash.
 
-bwmon is a cron job that monitors the average bandwidth usage of each
-slice and enforces a daily byte limit for each slice.
-
 pl_mop is a cron job that "fixes" various common problems with nodes
 (dead services, ext3 corruption, zombie SSH sessions, etc.).
 
@@ -46,14 +51,14 @@ rm -rf $RPM_BUILD_ROOT
 install -D -m 644 pl_mom.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/pl_mom.py
 
 # Bandwidth monitor (bwmon), run periodically
-install -D -m 755 bwmon.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/bwmon.py
+#install -D -m 755 bwmon.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/bwmon.py
 
 # Swap monitoring daemon (swapmon)
 install -D -m 755 swapmon.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/swapmon.py
 install -D -m 755 swapmon.init $RPM_BUILD_ROOT/%{_initrddir}/swapmon
 
 # Cleanup script
-install -D -m 755 pl_mop.sh $RPM_BUILD_ROOT/usr/local/planetlab/bin/pl_mop.sh
+install -D -m 755 pl_mop.sh $RPM_BUILD_ROOT/usr/bin/pl_mop.sh
 
 # Runs pl_mop and bwmon periodically
 install -D -m 644 pl_mom.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/pl_mom
@@ -96,9 +101,32 @@ exit 0
 
 %files
 %defattr(-, root, root, -)
-%{_datadir}/%{name}/pl_mom.py
-%{_datadir}/%{name}/bwmon.py
-%{_datadir}/%{name}/swapmon.py
+%{_datadir}/%{name}/pl_mom.py*
+%{_datadir}/%{name}/swapmon.py*
 %{_initrddir}/swapmon
-/usr/local/planetlab/bin/pl_mop.sh
+/usr/bin/pl_mop.sh
 %{_sysconfdir}/cron.d/pl_mom
+
+%changelog
+* Sun Dec 13 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - Mom-2.3-2
+- Don't restart disabled services.
+
+* Tue Apr 07 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - Mom-2.3-1
+- Merge from trunk.
+
+* Wed Jul 19 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-7.planetlab
+- swapmon: Added state info so same reset email does not keep getting
+  sent. If slice is already being killed, will wait for a timeout
+  before trying to kill again.
+
+* Mon Jul 17 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-6.planetlab
+- swapmon: Added state information per slice.  Slices are now killed
+  after consuming more memory than the threshold more than twice.
+  Also fixed the slice restart issue where slices would be restarted
+  and repeated restart emails would be sent.
+
+* Mon Jul 10 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-5.planetlab
+- bwmon: Initialize default limits
+
+* Mon Jul 10 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-4.planetlab
+- bwmon: Use cached values if NM stops responding