- check $PL_BOOTCD instead of runlevel
[mom.git] / pl_mom.spec
index 6a90f78..4810d84 100644 (file)
@@ -46,26 +46,25 @@ cp pl_mom.pl $RPM_BUILD_ROOT/usr/local/planetlab/bin/
 
 
 %post 
-RUNLEVEL=`/sbin/runlevel`
-
 if [ "$1" -ge 1 ]; then
 
         chkconfig --add pl_mom
         chkconfig --level 3 pl_mom on
 
-        if [[ "$RUNLEVEL" != "unknown" ]]; then
+        if [[ "$PL_BOOTCD" != "1" ]]; then
                 /etc/init.d/pl_mom stop
                 /etc/init.d/pl_mom start
         fi
 fi
 
 %preun
-RUNLEVEL=`/sbin/runlevel`
-
 if [ "$1" -eq 0 ]; then
-        if [[ "$RUNLEVEL" != "unknown" ]]; then
+        if [[ "$PL_BOOTCD" != "1" ]]; then
                 /etc/init.d/pl_mom stop
         fi
+
+        chkconfig --del pl_mom
+        chkconfig pl_mom off
 fi