- bump release number
[mom.git] / pl_mom.spec
index 2af45ec..770521c 100644 (file)
@@ -1,6 +1,6 @@
 %define name pl_mom
 %define version 0.4
-%define release 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
  
 Summary: PlanetLab node monitoring tools
 Name: %{name}
@@ -61,6 +61,13 @@ install -D -m 644 pl_mom.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/pl_mom
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+if [ "$PL_BOOTCD" != "1" ] ; then
+    service pl_mom stop
+fi
+
+exit 0
+
 %post 
 chkconfig --add swapmon
 chkconfig swapmon on
@@ -95,3 +102,7 @@ exit 0
 %{_initrddir}/swapmon
 /usr/local/planetlab/bin/pl_mop.sh
 %{_sysconfdir}/cron.d/pl_mom
+
+%changelog
+* Mon July 10 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
+- bwlimit: Use cached values if NM stops responding